qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH] kvm: Add a new machine property kvm_type


From: Alexander Graf
Subject: Re: [Qemu-devel] [PATCH] kvm: Add a new machine property kvm_type
Date: Mon, 4 Nov 2013 13:28:24 +0100

On 07.10.2013, at 18:53, Aneesh Kumar K.V <address@hidden> wrote:

> From: "Aneesh Kumar K.V" <address@hidden>
> 
> Targets like ppc64 support different typed of KVM, one which use
> hypervisor mode and the other which doesn't. Add a new machine
> property kvm_type that helps in selecting the respective ones
> We also add a new QEMUMachine callback get_vm_type that helps
> in mapping the string representation of kvm type specified.
> 
> Signed-off-by: Aneesh Kumar K.V <address@hidden>
> ---
> hw/ppc/e500plat.c      |  2 ++
> hw/ppc/mac_newworld.c  |  2 ++
> hw/ppc/mac_oldworld.c  |  2 ++
> hw/ppc/ppc440_bamboo.c |  2 ++
> hw/ppc/spapr.c         | 19 +++++++++++++++++++
> hw/ppc/vmtype.h        | 18 ++++++++++++++++++
> include/hw/boards.h    |  3 +++
> include/hw/xen/xen.h   |  3 ++-
> include/sysemu/kvm.h   |  4 ++--
> include/sysemu/qtest.h |  5 +++--
> kvm-all.c              | 16 +++++++++++++---
> kvm-stub.c             |  4 +++-
> qtest.c                |  2 +-
> vl.c                   | 17 +++++++++++------
> xen-all.c              |  2 +-
> xen-stub.c             |  2 +-
> 16 files changed, 85 insertions(+), 18 deletions(-)
> create mode 100644 hw/ppc/vmtype.h
> 
> diff --git a/hw/ppc/e500plat.c b/hw/ppc/e500plat.c
> index 2e964b2..3e53e85 100644
> --- a/hw/ppc/e500plat.c
> +++ b/hw/ppc/e500plat.c
> @@ -17,6 +17,7 @@
> #include "hw/pci/pci.h"
> #include "hw/ppc/openpic.h"
> #include "kvm_ppc.h"
> +#include "vmtype.h"
> 
> static void e500plat_fixup_devtree(PPCE500Params *params, void *fdt)
> {
> @@ -51,6 +52,7 @@ static QEMUMachine e500plat_machine = {
>     .desc = "generic paravirt e500 platform",
>     .init = e500plat_init,
>     .max_cpus = 32,
> +    .get_vm_type = pr_get_vm_type,

It should be called kvm_type, like the machine opt.

Apart from that I like the patch :). But it needs to be ack'ed by Gleb / Paolo.


Alex




reply via email to

[Prev in Thread] Current Thread [Next in Thread]