qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PULL 00/26] tcg updates


From: Richard Henderson
Subject: [Qemu-devel] [PULL 00/26] tcg updates
Date: Mon, 12 May 2014 16:30:48 -0700

This is a combination of the "tidy the type" patch set (which has been
reviewed), along with the "call and move cleanup" patch set (which has not).
I feel the later is mostly trivial, and my other patch sets which are based
on these should not be blocked because of it.


r~


The following changes since commit 06b4f00d53637f2c16a62c2cbaa30bffb045cf88:

  Merge remote-tracking branch 'remotes/qmp-unstable/queue/qmp' into staging 
(2014-05-09 15:46:34 +0100)

are available in the git repository at:


  git://github.com/rth7680/qemu.git tags/pull-tcg-20140512

for you to fetch changes up to 96d0ee7f0950e725ef7a4f7516e0af6a08d303e0:

  tcg: Remove unreachable code in tcg_out_op and op_defs (2014-05-12 11:13:13 
-0700)

----------------------------------------------------------------
tcg updates for 20140512

----------------------------------------------------------------
Peter Maydell (3):
      exec-all.h: Use stl_p to avoid undefined behaviour patching x86 jumps
      tcg: Avoid stores to unaligned addresses
      tcg: Avoid undefined behaviour patching code at unaligned addresses

Richard Henderson (23):
      tcg: Introduce byte pointer arithmetic helpers
      tcg: Define tcg_insn_unit for code pointers
      tcg-i386: Define TCG_TARGET_INSN_UNIT_SIZE
      tcg-ppc64: Define TCG_TARGET_INSN_UNIT_SIZE
      tcg-ppc: Define TCG_TARGET_INSN_UNIT_SIZE
      tcg-sparc: Define TCG_TARGET_INSN_UNIT_SIZE
      tcg-arm: Define TCG_TARGET_INSN_UNIT_SIZE
      tcg-aarch64: Define TCG_TARGET_INSN_UNIT_SIZE
      tcg-s390: Define TCG_TARGET_INSN_UNIT_SIZE
      tcg-ia64: Define TCG_TARGET_INSN_UNIT_SIZE
      tcg-mips: Define TCG_TARGET_INSN_UNIT_SIZE
      tci: Define TCG_TARGET_INSN_UNIT_SIZE
      tcg: Require TCG_TARGET_INSN_UNIT_SIZE
      tcg-i386: Rename tcg_out_calli to tcg_out_call
      tcg-s390: Rename tgen_calli to tcg_out_call
      tcg-ppc: Split out tcg_out_call
      tcg-ppc64: Rename tcg_out_calli to tcg_out_call
      tcg-sparc: Create tcg_out_call
      tcg-mips: Split out tcg_out_call
      tci: Create tcg_out_call
      tcg: Make call address a constant parameter
      tcg: Use tcg_target_available_regs in tcg_reg_alloc_mov
      tcg: Remove unreachable code in tcg_out_op and op_defs

 include/exec/exec-all.h  |   4 +-
 tcg/aarch64/tcg-target.c | 141 ++++++++++----------------
 tcg/aarch64/tcg-target.h |   1 +
 tcg/arm/tcg-target.c     | 174 ++++++++++----------------------
 tcg/arm/tcg-target.h     |   1 +
 tcg/i386/tcg-target.c    |  82 +++++++--------
 tcg/i386/tcg-target.h    |   2 +
 tcg/ia64/tcg-target.c    | 255 ++++++++++++++--------------------------------
 tcg/ia64/tcg-target.h    |   6 ++
 tcg/mips/tcg-target.c    | 145 +++++++++-----------------
 tcg/mips/tcg-target.h    |   1 +
 tcg/optimize.c           |  75 ++++++--------
 tcg/ppc/tcg-target.c     | 202 ++++++++++++++++---------------------
 tcg/ppc/tcg-target.h     |   1 +
 tcg/ppc64/tcg-target.c   | 170 +++++++++++++------------------
 tcg/ppc64/tcg-target.h   |   1 +
 tcg/s390/tcg-target.c    | 124 +++++++++--------------
 tcg/s390/tcg-target.h    |   2 +
 tcg/sparc/tcg-target.c   | 161 +++++++++++++----------------
 tcg/sparc/tcg-target.h   |   1 +
 tcg/tcg-be-ldst.h        |   4 +-
 tcg/tcg-op.h             |  16 +--
 tcg/tcg-opc.h            |  10 +-
 tcg/tcg.c                | 257 +++++++++++++++++++++++------------------------
 tcg/tcg.h                |  85 ++++++++++++++--
 tcg/tci/tcg-target.c     |  50 +++++----
 tcg/tci/tcg-target.h     |   1 +
 translate-all.c          |  13 ++-
 28 files changed, 829 insertions(+), 1156 deletions(-)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]