qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH V9 3/4] raw-posix: Add full image preallocation


From: Peter Lieven
Subject: Re: [Qemu-devel] [PATCH V9 3/4] raw-posix: Add full image preallocation option
Date: Tue, 27 May 2014 22:59:30 +0200

Am 27.05.2014 um 21:24 schrieb Eric Blake <address@hidden>:

> On 05/27/2014 02:22 AM, Chen Fan wrote:
>> From: Hu Tao <address@hidden>
>> 
>> This patch adds a new option preallocation for raw format, and implements
>> full preallocation by writing zeros to disk.
>> 
>> The metadata option is changed to use posix_fallocate() to ensure
>> subsquent writes to image file won't fail because of lack of disk space.
>> 
>> The purpose is to ensure disk space for image file. In cases
>> posix_fallocate() is supported, metadata option can be used, otherwise
>> (posix_fallocate() is not supported by filesystem, or in case of thin
>> provisioning), full option has to be used. User has to choose the proper
>> way to use.
>> 
>> Signed-off-by: Hu Tao <address@hidden>
>> ---
>> block/raw-posix.c | 61 
>> ++++++++++++++++++++++++++++++++++++++++++++++++-------
>> 1 file changed, 54 insertions(+), 7 deletions(-)
>> 
> 
>> @@ -1254,6 +1255,18 @@ static int raw_create(const char *filename, 
>> QEMUOptionParameter *options,
>>         if (!strcmp(options->name, BLOCK_OPT_SIZE)) {
>>             total_size = (options->value.n + BDRV_SECTOR_SIZE) &
>>                 BDRV_SECTOR_MASK;
>> +        } else if (!strcmp(options->name, BLOCK_OPT_PREALLOC)) {
>> +            if (!options->value.s || !strcmp(options->value.s, "off")) {
>> +                prealloc = PREALLOC_MODE_OFF;
>> +            } else if (!strcmp(options->value.s, "metadata")) {
>> +                prealloc = PREALLOC_MODE_METADATA;
>> +            } else if (!strcmp(options->value.s, "full")) {
>> +                prealloc = PREALLOC_MODE_FULL;
>> +            } else {
> 
> Instead of open-coding this conversion from string to enum, can you
> reuse Peter's pending patch?  (Hmm, that means Peter needs to export it
> to somewhere public, not just blockdev.c)
> 
> https://lists.gnu.org/archive/html/qemu-devel/2014-05/msg03772.html

I don't mind if this function is made public. You can send a patch for it.
Please don't forget to remove the static declaration. You might
also want to remove the inline. This was just to avoid an unused
function error. I don't know if blockdev.c is still the right
place for this function then.

Peter

> 
> -- 
> Eric Blake   eblake redhat com    +1-919-301-3266
> Libvirt virtualization library http://libvirt.org
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]