qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v10 3/6] rename parse_enum_option to qapi_enum_p


From: Max Reitz
Subject: Re: [Qemu-devel] [PATCH v10 3/6] rename parse_enum_option to qapi_enum_parse and make it public
Date: Sat, 14 Jun 2014 21:07:19 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

On 12.06.2014 05:54, Hu Tao wrote:
Signed-off-by: Hu Tao <address@hidden>
Suggested-by: Markus Armbruster <address@hidden>
---
  blockdev.c          | 22 ++--------------------
  include/qapi/util.h | 17 +++++++++++++++++
  qapi/Makefile.objs  |  2 +-
  qapi/qapi-util.c    | 32 ++++++++++++++++++++++++++++++++
  4 files changed, 52 insertions(+), 21 deletions(-)
  create mode 100644 include/qapi/util.h
  create mode 100644 qapi/qapi-util.c

diff --git a/blockdev.c b/blockdev.c
index 4cbcc56..9adfdbb 100644
--- a/blockdev.c
+++ b/blockdev.c
@@ -39,6 +39,7 @@
  #include "qapi/qmp/types.h"
  #include "qapi-visit.h"
  #include "qapi/qmp-output-visitor.h"
+#include "qapi/util.h"
  #include "sysemu/sysemu.h"
  #include "block/block_int.h"
  #include "qmp-commands.h"
@@ -287,25 +288,6 @@ static int parse_block_error_action(const char *buf, bool 
is_read, Error **errp)
      }
  }
-static inline int parse_enum_option(const char *lookup[], const char *buf,
-                                    int max, int def, Error **errp)
-{
-    int i;
-
-    if (!buf) {
-        return def;
-    }
-
-    for (i = 0; i < max; i++) {
-        if (!strcmp(buf, lookup[i])) {
-            return i;
-        }
-    }
-
-    error_setg(errp, "invalid parameter value: %s", buf);
-    return def;
-}
-
  static bool check_throttle_config(ThrottleConfig *cfg, Error **errp)
  {
      if (throttle_conflicting(cfg)) {
@@ -472,7 +454,7 @@ static DriveInfo *blockdev_init(const char *file, QDict 
*bs_opts,
      }
detect_zeroes =
-        parse_enum_option(BlockdevDetectZeroesOptions_lookup,
+        qapi_enum_parse(BlockdevDetectZeroesOptions_lookup,
                            qemu_opt_get(opts, "detect-zeroes"),
                            BLOCKDEV_DETECT_ZEROES_OPTIONS_MAX,
                            BLOCKDEV_DETECT_ZEROES_OPTIONS_OFF,

Please adapt the indentation of the other parameters.

Other than that:

Reviewed-by: Max Reitz <address@hidden>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]