qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH] tests: simplify code


From: Michael S. Tsirkin
Subject: [Qemu-devel] [PATCH] tests: simplify code
Date: Wed, 18 Jun 2014 18:37:08 +0300

Use error_abort instead of open-coded assert.
Cleaner and shorter.

Reported-by: Eric Blake <address@hidden>
Signed-off-by: Michael S. Tsirkin <address@hidden>
---
 tests/test-string-input-visitor.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/tests/test-string-input-visitor.c 
b/tests/test-string-input-visitor.c
index b01e2f2..8e3433e 100644
--- a/tests/test-string-input-visitor.c
+++ b/tests/test-string-input-visitor.c
@@ -69,14 +69,12 @@ static void test_visitor_in_intList(TestInputVisitorData 
*data,
 {
     int64_t value[] = {0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 20};
     int16List *res = NULL, *tmp;
-    Error *errp = NULL;
     Visitor *v;
     int i = 0;
 
     v = visitor_input_test_init(data, "1,2,0,2-4,20,5-9,1-8");
 
-    visit_type_int16List(v, &res, NULL, &errp);
-    g_assert(errp == NULL);
+    visit_type_int16List(v, &res, NULL, &error_abort);
     tmp = res;
     while (i < sizeof(value) / sizeof(value[0])) {
         g_assert(tmp);
-- 
MST



reply via email to

[Prev in Thread] Current Thread [Next in Thread]