qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v5 1/2] loader: Add load_image_gzipped function.


From: Alex Bennée
Subject: Re: [Qemu-devel] [PATCH v5 1/2] loader: Add load_image_gzipped function.
Date: Tue, 05 Aug 2014 10:52:17 +0100

Richard W.M. Jones writes:

> As the name suggests this lets you load a ROM/disk image that is
> gzipped.  It is uncompressed before storing it in guest memory.
>
<snip>
> +
> +    /* Is it a gzip-compressed file? */
> +    if (len < 2 ||
> +        compressed_data[0] != '\x1f' ||
> +        compressed_data[1] != '\x8b') {
> +        goto out;
> +    }

I was looking to see if the zlib library provided the magic numbers or a
verification routine here but I couldn't find it.

> +
> +    if (max_sz > LOAD_IMAGE_MAX_GUNZIP_BYTES) {
> +        max_sz = LOAD_IMAGE_MAX_GUNZIP_BYTES;
> +    }
> +
> +    data = g_malloc(max_sz);
> +    bytes = gunzip(data, max_sz, compressed_data, len);
> +    if (bytes < 0) {
> +        fprintf(stderr, "%s: unable to decompress gzipped kernel file\n",
> +                filename);
> +        goto out;
> +    }
> +
> +    rom_add_blob_fixed(filename, data, bytes, addr);
> +    ret = bytes;
> +
> + out:
> +    g_free(compressed_data);
> +    g_free(data);
> +    return ret;
> +}
> +
>  /*
>   * Functions for reboot-persistent memory regions.
>   *  - used for vga bios and option roms.
> diff --git a/include/hw/loader.h b/include/hw/loader.h
> index 796cbf9..00c9117 100644
> --- a/include/hw/loader.h
> +++ b/include/hw/loader.h
> @@ -15,6 +15,7 @@ int get_image_size(const char *filename);
>  int load_image(const char *filename, uint8_t *addr); /* deprecated */
>  int load_image_targphys(const char *filename, hwaddr,
>                          uint64_t max_sz);
> +int load_image_gzipped(const char *filename, hwaddr addr, uint64_t max_sz);
>  
>  #define ELF_LOAD_FAILED       -1
>  #define ELF_LOAD_NOT_ELF      -2

Reviewed-by: Alex Bennée <address@hidden>

-- 
Alex Bennée



reply via email to

[Prev in Thread] Current Thread [Next in Thread]