qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH v2 00/11] vga: cleanup and endianness patch series


From: Gerd Hoffmann
Subject: [Qemu-devel] [PATCH v2 00/11] vga: cleanup and endianness patch series
Date: Mon, 29 Sep 2014 11:31:01 +0200

  Hi,

Here comes v2 of the vga patches, this time the two patch series
combined into one.  Fixed issues found by David Gibson in review,
fixed some codestyle issues.  Nothing major.  Should be ready for
merge now, /me plans to send a pull req later this week, possibly
excluding patch #11 as I'd like to have ppc64le testing feedback
for that one first.

please review,
  Gerd

Benjamin Herrenschmidt (10):
  vga: Start cutting out non-32bpp conversion support
  vga: Remove remainder of old conversion cruft
  vga: Separate LE and BE conversion functions
  vga: Remove rgb_to_pixel indirection
  vga: Simplify vga_draw_blank() a bit
  cirrus: Remove non-32bpp cursor drawing
  vga: Remove some "should be done in BIOS" comments
  vga: Rename vga_template.h to vga-helpers.h
  vga: Make fb endian a common state variable
  vga: Add endian control register

Gerd Hoffmann (1):
  vga-pci: add qext region to mmio

 docs/specs/standard-vga.txt                  |   9 +
 hw/display/cirrus_vga.c                      |  79 +++---
 hw/display/cirrus_vga_template.h             | 102 -------
 hw/display/{vga_template.h => vga-helpers.h} | 318 +++++++++++-----------
 hw/display/vga-pci.c                         |  68 +++++
 hw/display/vga.c                             | 382 +++++++--------------------
 hw/display/vga_int.h                         |   5 +-
 include/hw/i386/pc.h                         |   8 +
 8 files changed, 381 insertions(+), 590 deletions(-)
 delete mode 100644 hw/display/cirrus_vga_template.h
 rename hw/display/{vga_template.h => vga-helpers.h} (52%)

-- 
1.8.3.1




reply via email to

[Prev in Thread] Current Thread [Next in Thread]