qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v5 01/11] qcow2: Calculate refcount block entry


From: Max Reitz
Subject: Re: [Qemu-devel] [PATCH v5 01/11] qcow2: Calculate refcount block entry count
Date: Sat, 11 Oct 2014 12:27:51 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.1.0

Am 10.10.2014 um 14:29 schrieb Benoît Canet:
On Fri, Aug 29, 2014 at 11:40:53PM +0200, Max Reitz wrote:
The size of a refblock entry is (in theory) variable; calculate
therefore the number of entries per refblock and the according bit shift
(1 << x == entry count) when opening an image.

Signed-off-by: Max Reitz <address@hidden>
---
  block/qcow2.c | 2 ++
  block/qcow2.h | 2 ++
  2 files changed, 4 insertions(+)

diff --git a/block/qcow2.c b/block/qcow2.c
index f9e045f..172ad00 100644
--- a/block/qcow2.c
+++ b/block/qcow2.c
@@ -689,6 +689,8 @@ static int qcow2_open(BlockDriverState *bs, QDict *options, 
int flags,
s->l2_bits = s->cluster_bits - 3; /* L2 is always one cluster */
      s->l2_size = 1 << s->l2_bits;
+    s->refcount_block_bits = s->cluster_bits - (s->refcount_order - 3);
After carefull examination (s->refcount_order - 3) == REFCOUNT_SHIFT.
Why not also creating s->refcount_shift and make use of it in order to avoid
torturing the mind of the next reader.

I'm sorry. *g*

Well, I'm against creating s->refcount_shift, because that name implies you could use it for shifts. But you shouldn't do that, because it may be both negative and positive.

Or simply recall in a comment that there is 2^3 bits in a byte.

I like this more. :-)

Max

Best regards

Benoît

+    s->refcount_block_size = 1 << s->refcount_block_bits;
      bs->total_sectors = header.size / 512;
      s->csize_shift = (62 - (s->cluster_bits - 8));
      s->csize_mask = (1 << (s->cluster_bits - 8)) - 1;
diff --git a/block/qcow2.h b/block/qcow2.h
index 6aeb7ea..7c01fb7 100644
--- a/block/qcow2.h
+++ b/block/qcow2.h
@@ -222,6 +222,8 @@ typedef struct BDRVQcowState {
      int l2_size;
      int l1_size;
      int l1_vm_state_index;
+    int refcount_block_bits;
+    int refcount_block_size;
      int csize_shift;
      int csize_mask;
      uint64_t cluster_offset_mask;
--
2.1.0





reply via email to

[Prev in Thread] Current Thread [Next in Thread]