qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 02/10] sdl2: rename sdl2_state to sdl2_console,


From: Max Reitz
Subject: Re: [Qemu-devel] [PATCH 02/10] sdl2: rename sdl2_state to sdl2_console, move to header file
Date: Thu, 11 Dec 2014 14:45:18 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.2.0

On 2014-12-11 at 11:49, Gerd Hoffmann wrote:
Create sdl2.h header file, in preparation for sdl2 code splitup.
Populate it with sdl2_console struct (renamed from sdl2_state).

Signed-off-by: Gerd Hoffmann <address@hidden>
---
  include/ui/sdl2.h | 11 ++++++++++
  ui/sdl2.c         | 63 ++++++++++++++++++++++++-------------------------------
  2 files changed, 38 insertions(+), 36 deletions(-)
  create mode 100644 include/ui/sdl2.h

diff --git a/include/ui/sdl2.h b/include/ui/sdl2.h
new file mode 100644
index 0000000..7f91a75
--- /dev/null
+++ b/include/ui/sdl2.h
@@ -0,0 +1,11 @@
+struct sdl2_console {
+    DisplayChangeListener dcl;
+    DisplaySurface *surface;
+    SDL_Texture *texture;
+    SDL_Window *real_window;
+    SDL_Renderer *real_renderer;
+    int idx;
+    int last_vm_running; /* per console for caption reasons */
+    int x, y;
+    int hidden;
+};

Is there a reason why you did not use include guards?

Max



reply via email to

[Prev in Thread] Current Thread [Next in Thread]