qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH V2 0/8] pc: acpi: various fixes and cleanups


From: Igor Mammedov
Subject: [Qemu-devel] [PATCH V2 0/8] pc: acpi: various fixes and cleanups
Date: Tue, 16 Dec 2014 10:58:36 +0000

changes from v1:
 * drop: [PATCH 7/9] acpi: replace opencoded notify codes with named values
 * use Michael's suggestion to improve build_append_nameseg()
 * drop long scope names and go back to recursion,
   but still significantly simplify building of PCI tree

this series is an attempt to shave off a bunch of
not directly related patches from already big dynamic
AML series (although it's dependency for it)

Tested: on XPsp3 to WS2012R2 and REHL6/7 guests.

Git tree for testing:
 https://github.com/imammedo/qemu/commits/acpi_pci_gen_simplification_v2

Igor Mammedov (8):
  pc: acpi: fix WindowsXP BSOD when memory hotplug is enabled
  pc: acpi: decribe bridge device as not hotpluggable
  pc: acpi-build: cleanup AcpiPmInfo initialization
  acpi: build_append_nameseg(): add padding if necessary
  acpi: move generic aml building helpers into dedictated file
  acpi: add build_append_namestring() helper
  acpi: drop min-bytes in build_package()
  pc: acpi-build: simplify PCI bus tree generation

 hw/acpi/Makefile.objs             |   1 +
 hw/acpi/acpi_gen_utils.c          | 244 +++++++++++++++++++++
 hw/i386/acpi-build.c              | 451 ++++++++------------------------------
 hw/i386/acpi-dsdt-cpu-hotplug.dsl |   1 +
 include/hw/acpi/acpi_gen_utils.h  |  23 ++
 5 files changed, 363 insertions(+), 357 deletions(-)
 create mode 100644 hw/acpi/acpi_gen_utils.c
 create mode 100644 include/hw/acpi/acpi_gen_utils.h

-- 
1.8.3.1




reply via email to

[Prev in Thread] Current Thread [Next in Thread]