qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PULL 00/14] QEMU: VFIO updates


From: Alex Williamson
Subject: [Qemu-devel] [PULL 00/14] QEMU: VFIO updates
Date: Mon, 22 Dec 2014 13:43:09 -0700
User-agent: StGit/0.17-dirty

The following changes since commit b574f602680d41c4cf4a9c106e3e2244bed01cdd:

  Merge remote-tracking branch 'remotes/kraxel/tags/pull-vga-20141216-1' into 
staging (2014-12-17 19:22:42 +0000)

are available in the git repository at:


  git://github.com/awilliam/qemu-vfio.git tags/vfio-update-20141222.0

for you to fetch changes up to dcbfc5cefb22e9219f8253dba87de33104ca73fe:

  vfio: Cleanup error_report()s (2014-12-22 10:37:27 -0700)

----------------------------------------------------------------
VFIO updates:
- Conversion to tracepoints (Eric Auger)
- Fix memory listener address space (Frank Blaschka)
- Move to hw/vfio/ and split common vs pci (Eric Auger & Kim Phillips)
- Trivial error_report() fixes (Alex Williamson)

In addition to enabling S390 with the address space fix and updating
to use tracepoints rather than compile time debug, this set of patches
moves hw/misc/vfio.c to hw/vfio/ and paves the way for vfio-platform
support by splitting common functionality from PCI specific code.

----------------------------------------------------------------
Alex Williamson (1):
      vfio: Cleanup error_report()s

Eric Auger (11):
      vfio: migration to trace points
      hw/vfio/pci: Rename VFIODevice into VFIOPCIDevice
      hw/vfio/pci: generalize mask/unmask to any IRQ index
      hw/vfio/pci: introduce minimalist VFIODevice with fd
      hw/vfio/pci: add type, name and group fields in VFIODevice
      hw/vfio/pci: handle reset at VFIODevice
      hw/vfio/pci: Introduce VFIORegion
      hw/vfio/pci: split vfio_get_device
      hw/vfio/pci: rename group_list into vfio_group_list
      hw/vfio/pci: use name field in format strings
      hw/vfio: create common module

Frank Blaschka (1):
      vfio: fix adding memory listener to the right address space

Kim Phillips (1):
      vfio: move hw/misc/vfio.c to hw/vfio/pci.c Move vfio.h into 
include/hw/vfio

 LICENSE                          |    2 +-
 MAINTAINERS                      |    2 +-
 hw/Makefile.objs                 |    1 +
 hw/misc/Makefile.objs            |    1 -
 hw/ppc/spapr_pci_vfio.c          |    2 +-
 hw/vfio/Makefile.objs            |    4 +
 hw/vfio/common.c                 |  959 +++++++++++++++++++++
 hw/{misc/vfio.c => vfio/pci.c}   | 1723 ++++++++------------------------------
 include/hw/vfio/vfio-common.h    |  151 ++++
 include/hw/{misc => vfio}/vfio.h |    0
 trace-events                     |   81 +-
 11 files changed, 1546 insertions(+), 1380 deletions(-)
 create mode 100644 hw/vfio/Makefile.objs
 create mode 100644 hw/vfio/common.c
 rename hw/{misc/vfio.c => vfio/pci.c} (64%)
 create mode 100644 include/hw/vfio/vfio-common.h
 rename include/hw/{misc => vfio}/vfio.h (100%)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]