qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 6/8] tcg: Rename tb_jmp_remove() to tb_remove_fr


From: Alex Bennée
Subject: Re: [Qemu-devel] [PATCH 6/8] tcg: Rename tb_jmp_remove() to tb_remove_from_jmp_list()
Date: Thu, 24 Mar 2016 15:24:05 +0000
User-agent: mu4e 0.9.17; emacs 25.0.92.7

address@hidden writes:

> From: Sergey Fedorov <address@hidden>
>
> tb_jmp_remove() was only used to remove the TB from a list of all TBs
> jumping to the same TB which is n-th jump destination of the given TB.
> Put a comment briefly describing the function behavior and rename it to
> better reflect its purpose.
>
> Signed-off-by: Sergey Fedorov <address@hidden>
> Signed-off-by: Sergey Fedorov <address@hidden>
> ---
>  translate-all.c | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/translate-all.c b/translate-all.c
> index f68716e1819f..28154ed75888 100644
> --- a/translate-all.c
> +++ b/translate-all.c
> @@ -922,7 +922,8 @@ static inline void tb_page_remove(TranslationBlock **ptb, 
> TranslationBlock *tb)
>      }
>  }
>
> -static inline void tb_jmp_remove(TranslationBlock *tb, int n)
> +/* remove the TB from a list of TBs jumping to the n-th jump target of the 
> TB */
> +static inline void tb_remove_from_jmp_list(TranslationBlock *tb, int n)
>  {
>      TranslationBlock *tb1;
>      uintptr_t *ptb;
> @@ -995,8 +996,8 @@ void tb_phys_invalidate(TranslationBlock *tb, 
> tb_page_addr_t page_addr)
>      }
>
>      /* suppress this TB from the two jump lists */
> -    tb_jmp_remove(tb, 0);
> -    tb_jmp_remove(tb, 1);
> +    tb_remove_from_jmp_list(tb, 0);
> +    tb_remove_from_jmp_list(tb, 1);
>
>      /* suppress any remaining jumps to this TB */
>      tb1 = tb->jmp_list_first;


Reviewed-by: Alex Bennée <address@hidden>

--
Alex Bennée



reply via email to

[Prev in Thread] Current Thread [Next in Thread]