qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PULL 0/6] target-arm queue


From: Peter Maydell
Subject: [Qemu-devel] [PULL 0/6] target-arm queue
Date: Thu, 7 Jul 2016 14:48:51 +0100

This week's collection of target-arm bugfixes...

thanks
-- PMM


The following changes since commit 5563168c530e2cde8e000ee7aa4afc0ea4d0b42e:

  Merge remote-tracking branch 'remotes/jasowang/tags/net-pull-request' into 
staging (2016-07-07 10:29:05 +0100)

are available in the git repository at:


  git://git.linaro.org/people/pmaydell/qemu-arm.git 
tags/pull-target-arm-20160707

for you to fetch changes up to 66542f639927bd1420db38a969d5fa8ad1c89ae1:

  i.MX: split the GPT timer implementation into per SOC definitions (2016-07-07 
13:47:01 +0100)

----------------------------------------------------------------
target-arm queue:
 * fix a wrong variable type for A64 SYS_HEAPINFO semihosting call
 * xlnx_dp: fix iffy xlnx_dp_aux_push_tx_fifo
 * aux: fix break that wanted to break two levels out
 * aux: Rename aux.[ch] to auxbus.[ch] for the benefit of Windows
 * hw/block/m25p80: fix resource leak
 * i.MX: split the GPT timer implementation into per SOC definitions

----------------------------------------------------------------
Jean-Christophe Dubois (1):
      i.MX: split the GPT timer implementation into per SOC definitions

Paolo Bonzini (2):
      xlnx_dp: fix iffy xlnx_dp_aux_push_tx_fifo
      aux: fix break that wanted to break two levels out

Peter Maydell (2):
      target-arm/arm-semi.c: In SYS_HEAPINFO use correct type for 'limit'
      aux: Rename aux.[ch] to auxbus.[ch] for the benefit of Windows

Shannon Zhao (1):
      hw/block/m25p80: fix resource leak

 hw/arm/fsl-imx25.c                  |  2 +-
 hw/arm/fsl-imx31.c                  |  2 +-
 hw/arm/fsl-imx6.c                   |  2 +-
 hw/block/m25p80.c                   |  6 ++--
 hw/display/dpcd.c                   |  2 +-
 hw/display/xlnx_dp.c                | 10 +++---
 hw/misc/Makefile.objs               |  2 +-
 hw/misc/{aux.c => auxbus.c}         | 16 ++++-----
 hw/misc/imx6_ccm.c                  |  6 ++++
 hw/timer/imx_gpt.c                  | 69 +++++++++++++++++++++++++++++++++----
 include/hw/display/xlnx_dp.h        |  2 +-
 include/hw/misc/{aux.h => auxbus.h} |  2 +-
 include/hw/misc/imx_ccm.h           |  5 ++-
 include/hw/timer/imx_gpt.h          |  9 ++++-
 target-arm/arm-semi.c               |  2 +-
 15 files changed, 107 insertions(+), 30 deletions(-)
 rename hw/misc/{aux.c => auxbus.c} (97%)
 rename include/hw/misc/{aux.h => auxbus.h} (99%)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]