qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH v2 0/7] Add "read-only" to the options QDict


From: Alberto Garcia
Subject: [Qemu-devel] [PATCH v2 0/7] Add "read-only" to the options QDict
Date: Thu, 15 Sep 2016 17:52:58 +0300

This series adds "read-only" to the options QDict, fixing a
long-standing problem with the reopening code.

   [E] <- [D] <- [C] <- [B] <- [A]

In a normal scenario, the active layer [A] is in read-write mode and
everything else is read-only. If we reopen [D] in read-write mode and
later reopen [B], then [D] will become read-only when inheriting the
flags from its parent (see bdrv_backing_options()). With this series,
inheriting options doesn't need to override values that have been
explicitly set before.

The BDRV_O_RDWR flag is not removed yet, but its keep in sync with the
value of the "read-only" option. Removing the BDRV_O_RDWR flag is not
straightforward in all cases and can result in code that is
significantly slower and less readable. Therefore it will be dealt
with in the future.

Regards,

Berto

v2:
- Patch 2:
  - Update description [Kevin]
- Patch 4:
  - Inherit the value of "read-only" in bdrv_temp_snapshot_options().
    [Kevin]
  - Remove "read-only" from qemu_root_bds_opts and simply set a
    default value in bds_tree_init(). [Kevin]
- Patch 7:
  - Rebase after the changes made to qemu_root_bds_opts in patch 4.

v1: https://lists.gnu.org/archive/html/qemu-block/2016-09/msg00191.html
- Initial release

git backport-diff against v1:

Key:
[----] : patches are identical
[####] : number of functional differences between upstream/downstream patch
[down] : patch is downstream-only
The flags [FC] indicate (F)unctional and (C)ontextual differences, respectively

001/7:[----] [--] 'block: Remove bdrv_is_snapshot'
002/7:[----] [--] 'block: Set BDRV_O_ALLOW_RDWR and snapshot_options before 
storing the flags'
003/7:[----] [--] 'block: Update bs->open_flags earlier in bdrv_open_common()'
004/7:[0013] [FC] 'block: Add "read-only" to the options QDict'
005/7:[----] [--] 'block: Don't queue the same BDS twice in 
bdrv_reopen_queue_child()'
006/7:[----] [--] 'commit: Add 'base' to the reopen queue before 'overlay_bs''
007/7:[0002] [FC] 'block: rename "read-only" to BDRV_OPT_READ_ONLY'

Alberto Garcia (7):
  block: Remove bdrv_is_snapshot
  block: Set BDRV_O_ALLOW_RDWR and snapshot_options before storing the
    flags
  block: Update bs->open_flags earlier in bdrv_open_common()
  block: Add "read-only" to the options QDict
  block: Don't queue the same BDS twice in bdrv_reopen_queue_child()
  commit: Add 'base' to the reopen queue before 'overlay_bs'
  block: rename "read-only" to BDRV_OPT_READ_ONLY

 block.c               | 89 +++++++++++++++++++++++++++++++++++++--------------
 block/commit.c        |  8 ++---
 block/vvfat.c         |  3 +-
 blockdev.c            | 26 +++++++--------
 include/block/block.h |  2 +-
 5 files changed, 84 insertions(+), 44 deletions(-)

-- 
2.9.3




reply via email to

[Prev in Thread] Current Thread [Next in Thread]