qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v3 4/4] ARRAY_SIZE: check that argument is an ar


From: Michael S. Tsirkin
Subject: Re: [Qemu-devel] [PATCH v3 4/4] ARRAY_SIZE: check that argument is an array
Date: Fri, 20 Jan 2017 00:11:02 +0200

On Thu, Jan 19, 2017 at 03:59:33PM -0600, Eric Blake wrote:
> On 01/19/2017 03:07 PM, Michael S. Tsirkin wrote:
> > It's a familiar pattern: some code uses ARRAY_SIZE, then refactoring
> > changes the argument from an array to a pointer to a dynamically
> > allocated buffer.  Code keeps compiling but any ARRAY_SIZE calls now
> > return the size of the pointer divided by element size.
> > 
> > Let's add build time checks to ARRAY_SIZE before we allow more
> > of these in the code-base.
> > 
> > Signed-off-by: Michael S. Tsirkin <address@hidden>
> > Reviewed-by: Markus Armbruster <address@hidden>
> > ---
> >  include/qemu/osdep.h | 9 ++++++++-
> >  1 file changed, 8 insertions(+), 1 deletion(-)
> 
> Reviewed-by: Eric Blake <address@hidden>
> 
> > 
> > diff --git a/include/qemu/osdep.h b/include/qemu/osdep.h
> > index 689f253..56c9e22 100644
> > --- a/include/qemu/osdep.h
> > +++ b/include/qemu/osdep.h
> > @@ -198,8 +198,15 @@ extern int daemon(int, int);
> >  #define DIV_ROUND_UP(n,d) (((n) + (d) - 1) / (d))
> >  #endif
> >  
> > +/*
> > + * &(x)[0] is always a pointer - if it's same type as x then the argument 
> > is a
> > + * pointer, not an array.
> > + */
> > +#define QEMU_IS_ARRAY(x) (!__builtin_types_compatible_p(typeof(x), \
> > +                                                        typeof(&(x)[0])))
> >  #ifndef ARRAY_SIZE
> > -#define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
> > +#define ARRAY_SIZE(x) ((sizeof(x) / sizeof((x)[0])) + \
> > +                       QEMU_BUILD_BUG_ON_ZERO(!QEMU_IS_ARRAY(x)))
> 
> We've got some double-negation going on here ("cause a build bug if the
> negation of QEMU_IS_ARRAY() is not 0") which takes some mental
> gymnastics, but it is the correct result.  [I kind of like that gnulib
> uses positive logic in its 'verify(x)' meaning "verify that x is true,
> or cause a build error"; compared to the negative logic in the kernal
> 'BUILD_BUG_ON[_ZERO](x)' meaning "cause a build bug if x is non-zero" -
> but that's personal preference and not something for qemu to change]

I can rename QEMU_IS_ARRAY to QEMU_IS_PTR and reverse the logic - would
this be preferable?

-- 
MST



reply via email to

[Prev in Thread] Current Thread [Next in Thread]