qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v3] migrate: Introduce a 'dc->vmsd' check to avo


From: Dr. David Alan Gilbert
Subject: Re: [Qemu-devel] [PATCH v3] migrate: Introduce a 'dc->vmsd' check to avoid segfault for --only-migratable
Date: Fri, 10 Feb 2017 15:04:03 +0000
User-agent: Mutt/1.7.1 (2016-10-04)

* Ashijeet Acharya (address@hidden) wrote:
> Commit a3a3d8c7 introduced a segfault bug while checking for
> 'dc->vmsd->unmigratable' which caused QEMU to crash when trying to add
> devices which do no set their 'dc->vmsd' yet while initialization.
> Place a 'dc->vmsd' check prior to it so that we do not segfault for
> such devices.
> 
> NOTE: This doesn't compromise the functioning of --only-migratable
> option as all the unmigratable devices do set their 'dc->vmsd'.
> 
> Also, move the only_migratable check inside device_set_realized() to avoid
> code duplication and fix the bug to display only_migratable error message
> only if the device constructuon is right.
> 
> Signed-off-by: Ashijeet Acharya <address@hidden>

Queued

> ---
> Changes is v3:
> - move only_migratable check inside device_set_realized() to avoid code 
> - duplication
> - I have dropped Juan's R-b tag for this one
> Changes in v2:
> - place dc->vmsd check in hw/usb/bus.c as well
> ---
>  hw/core/qdev.c | 10 ++++++++++
>  hw/usb/bus.c   | 19 -------------------
>  qdev-monitor.c |  9 ---------
>  3 files changed, 10 insertions(+), 28 deletions(-)
> 
> diff --git a/hw/core/qdev.c b/hw/core/qdev.c
> index 5783442..4438cbf 100644
> --- a/hw/core/qdev.c
> +++ b/hw/core/qdev.c
> @@ -37,6 +37,7 @@
>  #include "hw/boards.h"
>  #include "hw/sysbus.h"
>  #include "qapi-event.h"
> +#include "migration/migration.h"
>  
>  int qdev_hotplug = 0;
>  static bool qdev_hot_added = false;
> @@ -896,6 +897,15 @@ static void device_set_realized(Object *obj, bool value, 
> Error **errp)
>      }
>  
>      if (value && !dev->realized) {
> +        if (only_migratable && dc->vmsd) {
> +            if (dc->vmsd->unmigratable) {
> +                error_setg(&local_err, "Device %s is not migratable, but "
> +                           "--only-migratable was specified",
> +                           object_get_typename(obj));
> +                goto fail;
> +            }
> +        }
> +
>          if (!obj->parent) {
>              gchar *name = g_strdup_printf("device[%d]", unattached_count++);
>  
> diff --git a/hw/usb/bus.c b/hw/usb/bus.c
> index 1dcc35c..25913ad 100644
> --- a/hw/usb/bus.c
> +++ b/hw/usb/bus.c
> @@ -8,7 +8,6 @@
>  #include "monitor/monitor.h"
>  #include "trace.h"
>  #include "qemu/cutils.h"
> -#include "migration/migration.h"
>  
>  static void usb_bus_dev_print(Monitor *mon, DeviceState *qdev, int indent);
>  
> @@ -687,8 +686,6 @@ USBDevice *usbdevice_create(const char *cmdline)
>      const char *params;
>      int len;
>      USBDevice *dev;
> -    ObjectClass *klass;
> -    DeviceClass *dc;
>  
>      params = strchr(cmdline,':');
>      if (params) {
> @@ -723,22 +720,6 @@ USBDevice *usbdevice_create(const char *cmdline)
>          return NULL;
>      }
>  
> -    klass = object_class_by_name(f->name);
> -    if (klass == NULL) {
> -        error_report("Device '%s' not found", f->name);
> -        return NULL;
> -    }
> -
> -    dc = DEVICE_CLASS(klass);
> -
> -    if (only_migratable) {
> -        if (dc->vmsd->unmigratable) {
> -            error_report("Device %s is not migratable, but --only-migratable 
> "
> -                         "was specified", f->name);
> -            return NULL;
> -        }
> -    }
> -
>      if (f->usbdevice_init) {
>          dev = f->usbdevice_init(bus, params);
>      } else {
> diff --git a/qdev-monitor.c b/qdev-monitor.c
> index 549f45f..5f2fcdf 100644
> --- a/qdev-monitor.c
> +++ b/qdev-monitor.c
> @@ -29,7 +29,6 @@
>  #include "qemu/error-report.h"
>  #include "qemu/help_option.h"
>  #include "sysemu/block-backend.h"
> -#include "migration/migration.h"
>  
>  /*
>   * Aliases were a bad idea from the start.  Let's keep them
> @@ -579,14 +578,6 @@ DeviceState *qdev_device_add(QemuOpts *opts, Error 
> **errp)
>          return NULL;
>      }
>  
> -    if (only_migratable) {
> -        if (dc->vmsd->unmigratable) {
> -            error_setg(errp, "Device %s is not migratable, but "
> -                       "--only-migratable was specified", driver);
> -            return NULL;
> -        }
> -    }
> -
>      /* find bus */
>      path = qemu_opt_get(opts, "bus");
>      if (path != NULL) {
> -- 
> 2.6.2
> 
> 
--
Dr. David Alan Gilbert / address@hidden / Manchester, UK



reply via email to

[Prev in Thread] Current Thread [Next in Thread]