qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2 00/24] QemuOpts util/cutils: Fix and clean up


From: no-reply
Subject: Re: [Qemu-devel] [PATCH v2 00/24] QemuOpts util/cutils: Fix and clean up number conversions
Date: Tue, 21 Feb 2017 12:47:26 -0800 (PST)

Hi,

This series seems to have some coding style problems. See output below for
more information:

Type: series
Subject: [Qemu-devel] [PATCH v2 00/24] QemuOpts util/cutils: Fix and clean up 
number conversions
Message-id: address@hidden

=== TEST SCRIPT BEGIN ===
#!/bin/bash

BASE=base
n=1
total=$(git log --oneline $BASE.. | wc -l)
failed=0

# Useful git options
git config --local diff.renamelimit 0
git config --local diff.renames True

commits="$(git log --format=%H --reverse $BASE..)"
for c in $commits; do
    echo "Checking PATCH $n/$total: $(git log -n 1 --format=%s $c)..."
    if ! git show $c --format=email | ./scripts/checkpatch.pl --mailback -; then
        failed=1
        echo
    fi
    n=$((n+1))
done

exit $failed
=== TEST SCRIPT END ===

Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384
From https://github.com/patchew-project/qemu
 - [tag update]      patchew/address@hidden -> patchew/address@hidden
 * [new tag]         patchew/address@hidden -> patchew/address@hidden
Switched to a new branch 'test'
4614a4e option: Fix checking of sizes for overflow and trailing crap
2cca120 util/cutils: Change qemu_strtosz*() from int64_t to uint64_t
88d3b27 util/cutils: Return qemu_strtosz*() error and value separately
c79486e util/cutils: Let qemu_strtosz*() optionally reject trailing crap
5762cc9 qemu-img: Wrap cvtnum() around qemu_strtosz()
b7d5a3e test-cutils: Drop suffix from test_qemu_strtosz_simple()
b56f0cc test-cutils: Use qemu_strtosz() more often
71853e7 util/cutils: Drop QEMU_STRTOSZ_DEFSUFFIX_* macros
22aaa8b util/cutils: New qemu_strtosz()
b4c8eca util/cutils: Rename qemu_strtosz() to qemu_strtosz_MiB()
9b60caa util/cutils: New qemu_strtosz_metric()
6f1187c test-cutils: Cover qemu_strtosz() around range limits
03871b2 test-cutils: Cover qemu_strtosz() with trailing crap
dc82546 test-cutils: Cover qemu_strtosz() invalid input
0935137 test-cutils: Add missing qemu_strtosz()... endptr checks
f380127 option: Fix to reject invalid and overflowing numbers
885d2be util/cutils: Clean up control flow around qemu_strtol() a bit
f8e7ca1 util/cutils: Clean up variable names around qemu_strtol()
6b8dd91 util/cutils: Rename qemu_strtoll(), qemu_strtoull()
c449975 util/cutils: Rewrite documentation of qemu_strtol() & friends
521a70d test-cutils: Clean up qemu_strtoul() result checks
8ce54de test-cutils: Add missing qemu_strtol()... endptr checks
995429d option: Assert value string isn't null
d671592 test-qemu-opts: Cover qemu_opts_parse()

=== OUTPUT BEGIN ===
Checking PATCH 1/24: test-qemu-opts: Cover qemu_opts_parse()...
Checking PATCH 2/24: option: Assert value string isn't null...
ERROR: consider using qemu_strtoull in preference to strtoull
#76: FILE: util/qemu-option.c:147:
+    number = strtoull(value, &postfix, 0);

total: 1 errors, 0 warnings, 117 lines checked

Your patch has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.

Checking PATCH 3/24: test-cutils: Add missing qemu_strtol()... endptr checks...
Checking PATCH 4/24: test-cutils: Clean up qemu_strtoul() result checks...
Checking PATCH 5/24: util/cutils: Rewrite documentation of qemu_strtol() & 
friends...
Checking PATCH 6/24: util/cutils: Rename qemu_strtoll(), qemu_strtoull()...
Checking PATCH 7/24: util/cutils: Clean up variable names around 
qemu_strtol()...
ERROR: consider using qemu_strtol in preference to strtol
#77: FILE: util/cutils.c:316:
+        *result = strtol(nptr, &ep, base);

ERROR: consider using qemu_strtoul in preference to strtoul
#96: FILE: util/cutils.c:359:
+        *result = strtoul(nptr, &ep, base);

ERROR: consider using qemu_strtoll in preference to strtoll
#121: FILE: util/cutils.c:388:
+        *result = strtoll(nptr, &ep, base);

ERROR: consider using qemu_strtoull in preference to strtoull
#140: FILE: util/cutils.c:412:
+        *result = strtoull(nptr, &ep, base);

total: 4 errors, 0 warnings, 110 lines checked

Your patch has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.

Checking PATCH 8/24: util/cutils: Clean up control flow around qemu_strtol() a 
bit...
ERROR: consider using qemu_strtol in preference to strtol
#82: FILE: util/cutils.c:322:
+    *result = strtol(nptr, &ep, base);

ERROR: consider using qemu_strtoul in preference to strtoul
#110: FILE: util/cutils.c:364:
+    *result = strtoul(nptr, &ep, base);

ERROR: consider using qemu_strtoll in preference to strtoll
#142: FILE: util/cutils.c:392:
+    *result = strtoll(nptr, &ep, base);

ERROR: consider using qemu_strtoull in preference to strtoull
#172: FILE: util/cutils.c:415:
+    *result = strtoull(nptr, &ep, base);

total: 4 errors, 0 warnings, 140 lines checked

Your patch has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.

Checking PATCH 9/24: option: Fix to reject invalid and overflowing numbers...
Checking PATCH 10/24: test-cutils: Add missing qemu_strtosz()... endptr 
checks...
Checking PATCH 11/24: test-cutils: Cover qemu_strtosz() invalid input...
Checking PATCH 12/24: test-cutils: Cover qemu_strtosz() with trailing crap...
Checking PATCH 13/24: test-cutils: Cover qemu_strtosz() around range limits...
Checking PATCH 14/24: util/cutils: New qemu_strtosz_metric()...
Checking PATCH 15/24: util/cutils: Rename qemu_strtosz() to 
qemu_strtosz_MiB()...
Checking PATCH 16/24: util/cutils: New qemu_strtosz()...
Checking PATCH 17/24: util/cutils: Drop QEMU_STRTOSZ_DEFSUFFIX_* macros...
Checking PATCH 18/24: test-cutils: Use qemu_strtosz() more often...
Checking PATCH 19/24: test-cutils: Drop suffix from 
test_qemu_strtosz_simple()...
Checking PATCH 20/24: qemu-img: Wrap cvtnum() around qemu_strtosz()...
Checking PATCH 21/24: util/cutils: Let qemu_strtosz*() optionally reject 
trailing crap...
Checking PATCH 22/24: util/cutils: Return qemu_strtosz*() error and value 
separately...
Checking PATCH 23/24: util/cutils: Change qemu_strtosz*() from int64_t to 
uint64_t...
Checking PATCH 24/24: option: Fix checking of sizes for overflow and trailing 
crap...
=== OUTPUT END ===

Test command exited with code: 1


---
Email generated automatically by Patchew [http://patchew.org/].
Please send your feedback to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]