qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v3 00/43] qobject/qapi: add uint type


From: no-reply
Subject: Re: [Qemu-devel] [PATCH v3 00/43] qobject/qapi: add uint type
Date: Wed, 7 Jun 2017 18:47:00 -0700 (PDT)

Hi,

This series seems to have some coding style problems. See output below for
more information:

Type: series
Message-id: address@hidden
Subject: [Qemu-devel] [PATCH v3 00/43] qobject/qapi: add uint type

=== TEST SCRIPT BEGIN ===
#!/bin/bash

BASE=base
n=1
total=$(git log --oneline $BASE.. | wc -l)
failed=0

git config --local diff.renamelimit 0
git config --local diff.renames True

commits="$(git log --format=%H --reverse $BASE..)"
for c in $commits; do
    echo "Checking PATCH $n/$total: $(git log -n 1 --format=%s $c)..."
    if ! git show $c --format=email | ./scripts/checkpatch.pl --mailback -; then
        failed=1
        echo
    fi
    n=$((n+1))
done

exit $failed
=== TEST SCRIPT END ===

Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384
Switched to a new branch 'test'
5304b17 qobject: move dump_qobject() from block/ to qobject/
04e93f9 RFC: qdict: add uint
b1f8183 tests/qdict: check more get_try_int() cases
32dc113 console: use get_uint() for "head" property
ccdbdd6 i386/cpu: use get_uint() for "min-level"/"min-xlevel" properties
eabad51 numa: use get_uint() for "size" property
23ad49e pnv-core: use get_uint() for "core-pir" property
c327b58 pvpanic: use get_uint() for "ioport" property
2af440d auxbus: use get_uint() for "addr" property
63db11b arm: use get_uint() for "mp-affinity" property
ede6718 xen: use get_uint() for "max-ram-below-4g" property
d00a748 pc: use get_uint() for "hpet-intcap" property
2be46be pc: use get_uint() for "apic-id" property
0bbec76 pc: use get_uint() for "iobase" property
54613bf acpi: use get_uint() for "pci-hole*" properties
a9029ef acpi: use get_uint() for various acpi properties
4c2ac9c acpi: use get_uint() for "acpi-pcihp-io*" properties
5890942 platform-bus: use get_uint() for "addr" property
16b2431 bcm2835_fb: use {get, set}_uint() for "vcram-size" and "vcram-base"
52a5c50 aspeed: use {set, get}_uint() for "ram-size" property
8ee5ed0 pcihp: use get_uint() for "bsel" property
ec9a2db pc-dimm: make "size" property uint64
5b65717 pc-dimm: use get_uint() for dimm properties
e05a02f isa: use get_uint() for "io-base"
74e0f4b qdev: use appropriate getter/setters type
ea4b431 apic-common: make "id" property a uint32
917ff10 qdev: avoid type casts between signed and unsigned
c803fcd qdev: wrap default property value in an union
0153836 qdev: rename DEFINE_PROP_DEFAULT() to DEFINE_PROP_SIGNED()
00b6346 object: use more specific property type names
6ebdb40 q35: fix get_mmcfg_size to use uint64 visitor
b66da0f object: add uint property setter/getter
3123cbf qapi: update the qobject visitor to use QNUM_U64
f65fbd4 json: learn to parse uint64 numbers
cbe9a26 qnum: add uint type
47d9e93 tests: remove /{qnum, qlist, dict}/destroy test
19e22e7 qapi: Remove visit_start_alternate() parameter promote_int
8564a30 qapi: merge QInt and QFloat in QNum
3a28906 qapi: minor refactoring
5c73880 tests: add more int/number ranges checks
98c8358 tests: Remove test cases for alternates of 'number' and 'int'
d2fce78 object: fix potential leak in getters
0c9c6c3 qdev: remove PropertyInfo.qtype field

=== OUTPUT BEGIN ===
Checking PATCH 1/43: qdev: remove PropertyInfo.qtype field...
Checking PATCH 2/43: object: fix potential leak in getters...
Checking PATCH 3/43: tests: Remove test cases for alternates of 'number' and 
'int'...
Checking PATCH 4/43: tests: add more int/number ranges checks...
Checking PATCH 5/43: qapi: minor refactoring...
Checking PATCH 6/43: qapi: merge QInt and QFloat in QNum...
ERROR: do not use C99 // comments
#1971: FILE: tests/check-qnum.c:39:
+    // destroy doesn't exit yet

ERROR: do not use C99 // comments
#1987: FILE: tests/check-qnum.c:55:
+    // destroy doesn't exit yet

total: 2 errors, 0 warnings, 1894 lines checked

Your patch has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.

Checking PATCH 7/43: qapi: Remove visit_start_alternate() parameter 
promote_int...
Checking PATCH 8/43: tests: remove /{qnum, qlist, dict}/destroy test...
Checking PATCH 9/43: qnum: add uint type...
Checking PATCH 10/43: json: learn to parse uint64 numbers...
Checking PATCH 11/43: qapi: update the qobject visitor to use QNUM_U64...
Checking PATCH 12/43: object: add uint property setter/getter...
Checking PATCH 13/43: q35: fix get_mmcfg_size to use uint64 visitor...
Checking PATCH 14/43: object: use more specific property type names...
Checking PATCH 15/43: qdev: rename DEFINE_PROP_DEFAULT() to 
DEFINE_PROP_SIGNED()...
Checking PATCH 16/43: qdev: wrap default property value in an union...
Checking PATCH 17/43: qdev: avoid type casts between signed and unsigned...
Checking PATCH 18/43: apic-common: make "id" property a uint32...
Checking PATCH 19/43: qdev: use appropriate getter/setters type...
Checking PATCH 20/43: isa: use get_uint() for "io-base"...
Checking PATCH 21/43: pc-dimm: use get_uint() for dimm properties...
Checking PATCH 22/43: pc-dimm: make "size" property uint64...
Checking PATCH 23/43: pcihp: use get_uint() for "bsel" property...
Checking PATCH 24/43: aspeed: use {set, get}_uint() for "ram-size" property...
Checking PATCH 25/43: bcm2835_fb: use {get, set}_uint() for "vcram-size" and 
"vcram-base"...
Checking PATCH 26/43: platform-bus: use get_uint() for "addr" property...
Checking PATCH 27/43: acpi: use get_uint() for "acpi-pcihp-io*" properties...
Checking PATCH 28/43: acpi: use get_uint() for various acpi properties...
Checking PATCH 29/43: acpi: use get_uint() for "pci-hole*" properties...
Checking PATCH 30/43: pc: use get_uint() for "iobase" property...
Checking PATCH 31/43: pc: use get_uint() for "apic-id" property...
Checking PATCH 32/43: pc: use get_uint() for "hpet-intcap" property...
Checking PATCH 33/43: xen: use get_uint() for "max-ram-below-4g" property...
Checking PATCH 34/43: arm: use get_uint() for "mp-affinity" property...
Checking PATCH 35/43: auxbus: use get_uint() for "addr" property...
Checking PATCH 36/43: pvpanic: use get_uint() for "ioport" property...
Checking PATCH 37/43: pnv-core: use get_uint() for "core-pir" property...
Checking PATCH 38/43: numa: use get_uint() for "size" property...
Checking PATCH 39/43: i386/cpu: use get_uint() for "min-level"/"min-xlevel" 
properties...
Checking PATCH 40/43: console: use get_uint() for "head" property...
Checking PATCH 41/43: tests/qdict: check more get_try_int() cases...
Checking PATCH 42/43: RFC: qdict: add uint...
Checking PATCH 43/43: qobject: move dump_qobject() from block/ to qobject/...
=== OUTPUT END ===

Test command exited with code: 1


---
Email generated automatically by Patchew [http://patchew.org/].
Please send your feedback to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]