qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 1/2] libvhost-user: support resuming vq->last_av


From: Marc-André Lureau
Subject: Re: [Qemu-devel] [PATCH 1/2] libvhost-user: support resuming vq->last_avail_idx based on used_idx
Date: Tue, 29 Aug 2017 17:04:34 +0200

Hi

On Tue, Aug 29, 2017 at 5:01 PM, Michael S. Tsirkin <address@hidden> wrote:
> On Tue, Aug 29, 2017 at 04:48:04PM +0200, Marc-André Lureau wrote:
>> This is the same workaround as commit 523b018dde3b765, which was lost
>> with libvhost-user transition in commit e10e798c85c2331.
>>
>> Signed-off-by: Marc-André Lureau <address@hidden>
>> ---
>>  contrib/libvhost-user/libvhost-user.h |  5 +++++
>>  contrib/libvhost-user/libvhost-user.c | 13 +++++++++++++
>>  2 files changed, 18 insertions(+)
>>
>> diff --git a/contrib/libvhost-user/libvhost-user.h 
>> b/contrib/libvhost-user/libvhost-user.h
>> index 53ef222c0b..aca71717c1 100644
>> --- a/contrib/libvhost-user/libvhost-user.h
>> +++ b/contrib/libvhost-user/libvhost-user.h
>> @@ -132,6 +132,7 @@ typedef void (*vu_set_features_cb) (VuDev *dev, uint64_t 
>> features);
>>  typedef int (*vu_process_msg_cb) (VuDev *dev, VhostUserMsg *vmsg,
>>                                    int *do_reply);
>>  typedef void (*vu_queue_set_started_cb) (VuDev *dev, int qidx, bool 
>> started);
>> +typedef bool (*vu_queue_resume_to_used_cb) (VuDev *dev, int qidx);
>>
>>  typedef struct VuDevIface {
>>      /* called by VHOST_USER_GET_FEATURES to get the features bitmask */
>> @@ -148,6 +149,10 @@ typedef struct VuDevIface {
>>      vu_process_msg_cb process_msg;
>>      /* tells when queues can be processed */
>>      vu_queue_set_started_cb queue_set_started;
>> +    /* If the queue must be resumed to vring.used->idx. */
>> +    /* This can help to support resuming on unmanaged exit/crash when
>> +     * the slave/driver processes elements in order. */
>> +    vu_queue_resume_to_used_cb queue_resume_to_used;
>>  } VuDevIface;
>>
>>  typedef void (*vu_queue_handler_cb) (VuDev *dev, int qidx);
>
> Let's consider: this is only safe if queue is processed in order.
> So I think that would be a better name for the field.
>
That's what the comment say already :)

Which name do you suggest? vu_queue_is_processed_in_order? Does that
imply it should always resume?

>
>> diff --git a/contrib/libvhost-user/libvhost-user.c 
>> b/contrib/libvhost-user/libvhost-user.c
>> index 35fa0c5e56..36439caed6 100644
>> --- a/contrib/libvhost-user/libvhost-user.c
>> +++ b/contrib/libvhost-user/libvhost-user.c
>> @@ -521,6 +521,19 @@ vu_set_vring_addr_exec(VuDev *dev, VhostUserMsg *vmsg)
>>
>>      vq->used_idx = vq->vring.used->idx;
>>
>> +    if (vq->last_avail_idx != vq->used_idx) {
>> +        bool resume = dev->iface->queue_resume_to_used &&
>> +            dev->iface->queue_resume_to_used(dev, index);
>> +
>> +        DPRINT("Last avail index != used index: %u != %u%s\n",
>> +               vq->last_avail_idx, vq->used_idx,
>> +               resume ? ", resuming" : "");
>> +
>> +        if (resume) {
>> +            vq->shadow_avail_idx = vq->last_avail_idx = vq->used_idx;
>> +        }
>> +    }
>> +
>>      return false;
>>  }
>>
>> --
>> 2.14.1.146.gd35faa819
>



-- 
Marc-André Lureau



reply via email to

[Prev in Thread] Current Thread [Next in Thread]