qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCHv2 00/10] sun4u: APB tidy-up/rename and tracepoin


From: no-reply
Subject: Re: [Qemu-devel] [PATCHv2 00/10] sun4u: APB tidy-up/rename and tracepoint conversions
Date: Sun, 21 Jan 2018 01:26:29 -0800 (PST)

Hi,

This series seems to have some coding style problems. See output below for
more information:

Type: series
Message-id: address@hidden
Subject: [Qemu-devel] [PATCHv2 00/10] sun4u: APB tidy-up/rename and tracepoint 
conversions

=== TEST SCRIPT BEGIN ===
#!/bin/bash

BASE=base
n=1
total=$(git log --oneline $BASE.. | wc -l)
failed=0

git config --local diff.renamelimit 0
git config --local diff.renames True

commits="$(git log --format=%H --reverse $BASE..)"
for c in $commits; do
    echo "Checking PATCH $n/$total: $(git log -n 1 --format=%s $c)..."
    if ! git show $c --format=email | ./scripts/checkpatch.pl --mailback -; then
        failed=1
        echo
    fi
    n=$((n+1))
done

exit $failed
=== TEST SCRIPT END ===

Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384
From https://github.com/patchew-project/qemu
 * [new tag]               patchew/address@hidden -> patchew/address@hidden
Switched to a new branch 'test'
0eb52aeef3 sparc64: convert hw/sparc64/sparc64.c from DPRINTF macros to trace 
events
32f1d8e1b5 sabre: convert from SABRE_DPRINTF macro to trace-events
6958f18f5a apb: rename apb.c to sabre.c
fe3e1b336c sun4u: rename apb variables and constants
a750fff18e apb: rename QOM type from TYPE_APB to TYPE_SABRE
9280916a01 apb: QOMify sabre PCI host bridge
5180d214a9 apb: change pbm_pci_host prefix functions to use sabre_pci prefix
748c2e2536 apb: rename APB functions to use sabre prefix
05b08c4f2f simba: rename PBMPCIBridge and QOM types to reflect simba naming
ea5afa753a apb: split simba PCI bridge into hw/pci-bridge/simba.c

=== OUTPUT BEGIN ===
Checking PATCH 1/10: apb: split simba PCI bridge into hw/pci-bridge/simba.c...
Checking PATCH 2/10: simba: rename PBMPCIBridge and QOM types to reflect simba 
naming...
Checking PATCH 3/10: apb: rename APB functions to use sabre prefix...
Checking PATCH 4/10: apb: change pbm_pci_host prefix functions to use sabre_pci 
prefix...
Checking PATCH 5/10: apb: QOMify sabre PCI host bridge...
Checking PATCH 6/10: apb: rename QOM type from TYPE_APB to TYPE_SABRE...
Checking PATCH 7/10: sun4u: rename apb variables and constants...
Checking PATCH 8/10: apb: rename apb.c to sabre.c...
ERROR: do not use C99 // comments
#91: FILE: hw/pci-host/sabre.c:41:
+//#define DEBUG_SABRE

total: 1 errors, 0 warnings, 188 lines checked

Your patch has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.

Checking PATCH 9/10: sabre: convert from SABRE_DPRINTF macro to trace-events...
Checking PATCH 10/10: sparc64: convert hw/sparc64/sparc64.c from DPRINTF macros 
to trace events...
=== OUTPUT END ===

Test command exited with code: 1


---
Email generated automatically by Patchew [http://patchew.org/].
Please send your feedback to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]