qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH v2 00/12] rework display initialization, part one


From: Gerd Hoffmann
Subject: [Qemu-devel] [PATCH v2 00/12] rework display initialization, part one
Date: Mon, 29 Jan 2018 17:23:56 +0100

  Hi,

This series is the first part of my the qemu display initialization
update.  Changes:

  * Create a QAPI DisplayOptions type for display configuration.
  * Switch all display initialization calls to accept DisplayOptions
    instead of a bunch of bools.

Coming soon, building on top of the above:

  * Add a registry for displays, and remove alot of #ifdefs from vl.c
  * Build sdl, gtk and curses as modules.

cheers,
  Gerd

Gerd Hoffmann (12):
  vl: deprecate -no-frame
  vl: deprecate -alt-grab and -ctrl-grab
  vl: rename DisplayType to LegacyDisplayType
  gtk: add and use DisplayOptions + DisplayGTK
  sdl: use DisplayOptions
  vl: drop no_quit variable
  egl-headless: use DisplayOptions
  curses: use DisplayOptions
  cocoa: use DisplayOptions
  vl: drop full_screen variable
  vl: drop display_type variable
  vl: drop request_opengl variable

 include/ui/console.h |  27 ++++++-----
 ui/curses.c          |   2 +-
 ui/egl-headless.c    |   2 +-
 ui/gtk.c             |  32 +++++++------
 ui/sdl.c             |  19 +++++---
 ui/sdl2.c            |  33 +++++++------
 vl.c                 | 127 ++++++++++++++++++++++++++-------------------------
 qapi/ui.json         |  64 ++++++++++++++++++++++++++
 qemu-doc.texi        |  13 ++++++
 ui/cocoa.m           |   4 +-
 10 files changed, 208 insertions(+), 115 deletions(-)

-- 
2.9.3




reply via email to

[Prev in Thread] Current Thread [Next in Thread]