qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v5 1/6] machine: Convert the valid cpu types to


From: Eduardo Habkost
Subject: Re: [Qemu-devel] [PATCH v5 1/6] machine: Convert the valid cpu types to use cpu_model
Date: Fri, 2 Feb 2018 16:23:26 -0200
User-agent: Mutt/1.9.1 (2017-09-22)

On Thu, Feb 01, 2018 at 04:42:05PM -0800, Alistair Francis wrote:
> As cpu_type is not a user visible string let's convert the
> valid_cpu_types to compare against cpu_model instead. This way we have a
> user friendly string to report back.
> 
> Once we have a cpu_type to cpu_model conversion this patch should be
> reverted and we should use cpu_type instead.
> 
> Signed-off-by: Alistair Francis <address@hidden>
> ---
> 
>  hw/core/machine.c | 11 +++++------
>  1 file changed, 5 insertions(+), 6 deletions(-)
> 
> diff --git a/hw/core/machine.c b/hw/core/machine.c
> index cdc1163dc6..de5bac1c84 100644
> --- a/hw/core/machine.c
> +++ b/hw/core/machine.c
> @@ -776,13 +776,12 @@ void machine_run_board_init(MachineState *machine)
>      /* If the machine supports the valid_cpu_types check and the user
>       * specified a CPU with -cpu check here that the user CPU is supported.
>       */
> -    if (machine_class->valid_cpu_types && machine->cpu_type) {
> -        ObjectClass *class = object_class_by_name(machine->cpu_type);
> +    if (machine_class->valid_cpu_types && machine->cpu_model) {
>          int i;
>  
>          for (i = 0; machine_class->valid_cpu_types[i]; i++) {
> -            if (object_class_dynamic_cast(class,
> -                                          
> machine_class->valid_cpu_types[i])) {
> +            if (!strcmp(machine->cpu_model,
> +                        machine_class->valid_cpu_types[i])) {

I would rename valid_cpu_types to valid_cpu_models to make the
new semantics clearer.

Anyway, I have bad and good news:

The bad news is Igor already sent patches last week that remove
MachineState::cpu_model, so this conflicts with his series.  Now
parse_cpu_model() will be the only place where the original CPU model name is
available, but the function needs to work on *-user too.  See:
"[PATCH v3 23/25] Use cpu_create(type) instead of cpu_init(cpu_model)".

The good news is that I think we can fix this very easily if
validation is done at the same place where parse_cpu_model() is
called.  e.g.:

    current_machine->cpu_type = machine_class->default_cpu_type;
    if (cpu_model) {
        current_machine->cpu_type = parse_cpu_model(cpu_model);

        if (machine_class->valid_cpu_models) {
            ObjectClass *class = object_class_by_name(machine->cpu_type);
            int i;

            for (i = 0; machine_class->valid_cpu_models[i]; i++) {
                const char *valid_model = machine_class->valid_cpu_models[i];
                ObjectClass *valid_class = cpu_class_by_name(machine->cpu_type, 
valid_model);
                if (object_class_dynamic_cast(class,
                                              
object_class_get_name(valid_class))) {
                     /* Valid CPU type, we're good to go */
                     break;
                }
            }
            if (!machine_class->valid_cpu_models[i]) {
                error_report("Invalid CPU model: %s", cpu_model);
                error_printf("The valid CPU models are: %s",
                             machine_class->valid_cpu_models[0]);
                for (i = 1; machine_class->valid_cpu_models[i]; i++) {
                    error_printf(", %s", machine_class->valid_cpu_models[i]);
                }
                error_printf("\n");
                exit(1);
            }
        }
    }

This can be done inside main(), or moved inside
machine_run_board_init() if main() pass cpu_model as argument to
the function.

On either case, I think it's a good idea to do validation and
printing of error messages closer to the code that parses the
command-line options.  This way we separate parsing/validation
from initialization.

>                  /* The user specificed CPU is in the valid field, we are
>                   * good to go.
>                   */
> @@ -792,8 +791,8 @@ void machine_run_board_init(MachineState *machine)
>  
>          if (!machine_class->valid_cpu_types[i]) {
>              /* The user specified CPU is not valid */
> -            error_report("Invalid CPU type: %s", machine->cpu_type);
> -            error_printf("The valid types are: %s",
> +            error_report("Invalid CPU model: %s", machine->cpu_model);
> +            error_printf("The valid models are: %s",
>                           machine_class->valid_cpu_types[0]);
>              for (i = 1; machine_class->valid_cpu_types[i]; i++) {
>                  error_printf(", %s", machine_class->valid_cpu_types[i]);
> -- 
> 2.14.1
> 
> 

-- 
Eduardo



reply via email to

[Prev in Thread] Current Thread [Next in Thread]