qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v4 2/9] numa: split out NumaOptions parsing into


From: Igor Mammedov
Subject: Re: [Qemu-devel] [PATCH v4 2/9] numa: split out NumaOptions parsing into parse_NumaOptions()
Date: Tue, 27 Mar 2018 15:08:27 +0200

On Fri, 23 Mar 2018 17:42:18 -0300
Eduardo Habkost <address@hidden> wrote:

> On Mon, Mar 12, 2018 at 02:11:08PM +0100, Igor Mammedov wrote:
> > it will allow to reuse parse_NumaOptions() for parsing
> > configuration commands received via QMP interface
> > 
> > Signed-off-by: Igor Mammedov <address@hidden>
> > ---
> >  include/sysemu/numa.h |  1 +
> >  numa.c                | 48 +++++++++++++++++++++++++++++-------------------
> >  2 files changed, 30 insertions(+), 19 deletions(-)
> > 
> > diff --git a/include/sysemu/numa.h b/include/sysemu/numa.h
> > index 21713b7..7a0ae75 100644
> > --- a/include/sysemu/numa.h
> > +++ b/include/sysemu/numa.h
> > @@ -22,6 +22,7 @@ struct NumaNodeMem {
> >  };
> >  
> >  extern NodeInfo numa_info[MAX_NODES];
> > +int parse_numa(void *opaque, QemuOpts *opts, Error **errp);
> >  void parse_numa_opts(MachineState *ms);
> >  void numa_complete_configuration(MachineState *ms);
> >  void query_numa_node_mem(NumaNodeMem node_mem[]);
> > diff --git a/numa.c b/numa.c
> > index 126c649..2b1d292 100644
> > --- a/numa.c
> > +++ b/numa.c
> > @@ -169,28 +169,11 @@ static void parse_numa_distance(NumaDistOptions 
> > *dist, Error **errp)
> >      have_numa_distance = true;
> >  }
> >  
> > -static int parse_numa(void *opaque, QemuOpts *opts, Error **errp)
> > +static
> > +void parse_NumaOptions(MachineState *ms, NumaOptions *object, Error 
> > **errp)  
> 
> I wonder if we should rename the parse_numa_{node,distance}()
> functions to configure_numa_{node,distance}(), and this one
> configure_numa().  These functions don't parse anything, anymore.
I'd preffer to do it in another patch on top of this series
(added it my TODO list)


> >  {
> > -    NumaOptions *object = NULL;
> > -    MachineState *ms = opaque;
> >      Error *err = NULL;
> >  
> > -    {
> > -        Visitor *v = opts_visitor_new(opts);
> > -        visit_type_NumaOptions(v, NULL, &object, &err);
> > -        visit_free(v);
> > -    }
> > -
> > -    if (err) {
> > -        goto end;
> > -    }
> > -
> > -    /* Fix up legacy suffix-less format */
> > -    if ((object->type == NUMA_OPTIONS_TYPE_NODE) && 
> > object->u.node.has_mem) {
> > -        const char *mem_str = qemu_opt_get(opts, "mem");
> > -        qemu_strtosz_MiB(mem_str, NULL, &object->u.node.mem);
> > -    }
> > -
> >      switch (object->type) {
> >      case NUMA_OPTIONS_TYPE_NODE:
> >          parse_numa_node(ms, &object->u.node, &err);
> > @@ -224,6 +207,33 @@ static int parse_numa(void *opaque, QemuOpts *opts, 
> > Error **errp)
> >      }
> >  
> >  end:
> > +    if (err) {
> > +        error_propagate(errp, err);
> > +    }  
> 
> "if (err)" is not necessary here.  See
> scripts/coccinelle/error_propagate_null.cocci.
fixed
 
> > +}
> > +
> > +int parse_numa(void *opaque, QemuOpts *opts, Error **errp)
> > +{
> > +    NumaOptions *object = NULL;
> > +    MachineState *ms = MACHINE(opaque);
> > +    Error *err = NULL;
> > +    Visitor *v = opts_visitor_new(opts);
> > +
> > +    visit_type_NumaOptions(v, NULL, &object, &err);
> > +    visit_free(v);
> > +    if (err) {
> > +        goto end;
> > +    }
> > +
> > +    /* Fix up legacy suffix-less format */
> > +    if ((object->type == NUMA_OPTIONS_TYPE_NODE) && 
> > object->u.node.has_mem) {
> > +        const char *mem_str = qemu_opt_get(opts, "mem");
> > +        qemu_strtosz_MiB(mem_str, NULL, &object->u.node.mem);
> > +    }
> > +
> > +    parse_NumaOptions(ms, object, &err);
> > +
> > +end:
> >      qapi_free_NumaOptions(object);
> >      if (err) {
> >          error_report_err(err);  
> 
> We can fix this one too while at it.
error_report_err() doesn't check for NULL value,
'if(err)' is needed here
 
> The rest of the patch looks good.
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]