On Tue, 2011-11-29 at 12:14 -0600, Jeremiah Benham wrote:
On 11/29/2011 12:13 PM, Richard Shann wrote:
On Tue, 2011-11-29 at 08:43 -0600, Jeremiah Benham wrote:
Does this apply to all code incased in GTK_CHECK_VERSION or
GTK_MAJOR_VERSION, or does this apply to commonly recurring gtk
functions like gtk_adjustment() (or whatever it is called).
For commonly recurring things it makes sense to collect the conditional
(#if GTK_MAJOR_VERSION==3) code to appear just once (often in a header).
No point for one-off things.
I think GTK_CHECK_VERSION is a case in point - I don't think it is
defined in gtk2, so it would be good to dig its code out of gtk3 and
define it for the case GTK_MAJOR_VERSION<3.
Ok. I have changed all of that. I don't think there is excessive GTK
conditionals that make it too hard to read. Should I merge the gtk-3
branch into master now or would you rather me cherry pick a handful of
files at a time?
First thing to do will be to test it. If you think it is ok I will
switch to that branch and work with it to test it out over the next few
days. (I will be compiling it under gtk2 of course, anything extra that
works under gtk3 is a bonus).