[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[GNUnet-SVN] [libmicrohttpd] 139/154: Rename senfile_adapter to MHD_send
From: |
gnunet |
Subject: |
[GNUnet-SVN] [libmicrohttpd] 139/154: Rename senfile_adapter to MHD_send_sendfile_ and remove duplicate prototype. |
Date: |
Mon, 19 Aug 2019 10:17:31 +0200 |
This is an automated email from the git hooks/post-receive script.
ng0 pushed a commit to branch master
in repository libmicrohttpd.
commit b98ad354ca1ec1d88e2cc1da5a67e7da11b9f6c4
Author: ng0 <address@hidden>
AuthorDate: Fri Aug 2 09:08:51 2019 +0000
Rename senfile_adapter to MHD_send_sendfile_ and remove duplicate prototype.
---
src/microhttpd/connection.c | 2 +-
src/microhttpd/mhd_send.c | 3 +--
src/microhttpd/mhd_send.h | 5 +----
3 files changed, 3 insertions(+), 7 deletions(-)
diff --git a/src/microhttpd/connection.c b/src/microhttpd/connection.c
index cee38b8d..070fad51 100644
--- a/src/microhttpd/connection.c
+++ b/src/microhttpd/connection.c
@@ -3123,7 +3123,7 @@ MHD_connection_handle_write (struct MHD_Connection
*connection)
#if defined(_MHD_HAVE_SENDFILE)
if (MHD_resp_sender_sendfile == connection->resp_sender)
{
- ret = sendfile_adapter (connection);
+ ret = MHD_send_sendfile_ (connection);
}
else
#else /* ! _MHD_HAVE_SENDFILE */
diff --git a/src/microhttpd/mhd_send.c b/src/microhttpd/mhd_send.c
index 11ed6db7..0b1ae127 100644
--- a/src/microhttpd/mhd_send.c
+++ b/src/microhttpd/mhd_send.c
@@ -435,9 +435,8 @@ static int freebsd_sendfile_flags_thd_p_c_;
* @param connection the MHD connection structure
* @return actual number of bytes sent
*/
-// FIXME: rename...
ssize_t
-sendfile_adapter (struct MHD_Connection *connection)
+MHD_send_sendfile_ (struct MHD_Connection *connection)
{
ssize_t ret;
const int file_fd = connection->response->fd;
diff --git a/src/microhttpd/mhd_send.h b/src/microhttpd/mhd_send.h
index 5f0f8155..a766c8c0 100644
--- a/src/microhttpd/mhd_send.h
+++ b/src/microhttpd/mhd_send.h
@@ -89,12 +89,9 @@ MHD_send_on_connection2_ (struct MHD_Connection *connection,
const char *buffer,
size_t buffer_size);
-ssize_t
-MHD_sendfile_on_connection_ (struct MHD_Connection *connection);
-
#if defined(_MHD_HAVE_SENDFILE)
ssize_t
-sendfile_adapter (struct MHD_Connection *connection);
+MHD_send_sendfile_ (struct MHD_Connection *connection);
#endif
#endif /* MHD_SEND_H */
--
To stop receiving notification emails like this one, please contact
address@hidden.
- [GNUnet-SVN] [libmicrohttpd] 121/154: MSG_MORE fix, (continued)
- [GNUnet-SVN] [libmicrohttpd] 121/154: MSG_MORE fix, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 115/154: gitignore build-aux., gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 132/154: reduce variable scope, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 131/154: toggle Naggle if and only if corking is not possible by other means, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 126/154: fixes, comments, FIXMEs, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 133/154: properly handle return value from send_on_connection2, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 130/154: always set nodelay, except if we cannot cork, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 135/154: add ways for application to control corking for upgraded sockets, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 138/154: mhd_send: fix failure to build, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 136/154: do it in both tests, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 139/154: Rename senfile_adapter to MHD_send_sendfile_ and remove duplicate prototype.,
gnunet <=
- [GNUnet-SVN] [libmicrohttpd] 151/154: mhd_send.c: for now, let EINVAL and EBADF fail hard., gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 152/154: connection.c: remove dead code., gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 154/154: Revert "connection.c: remove dead code.", gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 114/154: writev check, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 144/154: connection.c: remove dead code, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 153/154: Revert "mhd_send.c: for now, let EINVAL and EBADF fail hard.", gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 146/154: remove code, gnunet, 2019/08/19
- [GNUnet-SVN] [libmicrohttpd] 140/154: Mark function calls which could be removed as dead code., gnunet, 2019/08/19