gnunet-svn
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[taler-wallet-core] branch master updated: wallet-core: rename request t


From: gnunet
Subject: [taler-wallet-core] branch master updated: wallet-core: rename request to setWalletRunConfig
Date: Mon, 08 Apr 2024 16:41:21 +0200

This is an automated email from the git hooks/post-receive script.

dold pushed a commit to branch master
in repository wallet-core.

The following commit(s) were added to refs/heads/master by this push:
     new 4fda640cb wallet-core: rename request to setWalletRunConfig
4fda640cb is described below

commit 4fda640cbb68a6eb077b8313eb93e2a65266eded
Author: Florian Dold <florian@dold.me>
AuthorDate: Mon Apr 8 16:40:21 2024 +0200

    wallet-core: rename request to setWalletRunConfig
    
    The old name was ambiguous, as the request does not refer to the
    persistent config of the wallet, but the ephemeral run-time
    configuration of the wallet-core instance.
---
 packages/taler-wallet-core/src/wallet-api-types.ts | 8 ++++----
 packages/taler-wallet-core/src/wallet.ts           | 2 +-
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/packages/taler-wallet-core/src/wallet-api-types.ts 
b/packages/taler-wallet-core/src/wallet-api-types.ts
index 0fd0ffbd6..d7f34409f 100644
--- a/packages/taler-wallet-core/src/wallet-api-types.ts
+++ b/packages/taler-wallet-core/src/wallet-api-types.ts
@@ -154,7 +154,7 @@ import { PaymentBalanceDetails } from "./balance.js";
 
 export enum WalletApiOperation {
   InitWallet = "initWallet",
-  SetConfig = "setConfig",
+  SetWalletRunConfig = "setWalletRunConfig",
   WithdrawTestkudos = "withdrawTestkudos",
   WithdrawTestBalance = "withdrawTestBalance",
   PreparePayForUri = "preparePayForUri",
@@ -281,8 +281,8 @@ export type InitWalletOp = {
  *
  * Currently an alias for the initWallet request.
  */
-export type SetConfigOp = {
-  op: WalletApiOperation.SetConfig;
+export type SetWalletRunConfigOp = {
+  op: WalletApiOperation.SetWalletRunConfig;
   request: InitRequest;
   response: InitResponse;
 };
@@ -1160,7 +1160,7 @@ export type ForceRefreshOp = {
 
 export type WalletOperations = {
   [WalletApiOperation.InitWallet]: InitWalletOp;
-  [WalletApiOperation.SetConfig]: SetConfigOp;
+  [WalletApiOperation.SetWalletRunConfig]: SetWalletRunConfigOp;
   [WalletApiOperation.GetVersion]: GetVersionOp;
   [WalletApiOperation.PreparePayForUri]: PreparePayForUriOp;
   [WalletApiOperation.SharePayment]: SharePaymentOp;
diff --git a/packages/taler-wallet-core/src/wallet.ts 
b/packages/taler-wallet-core/src/wallet.ts
index b54204d64..fa78cf24b 100644
--- a/packages/taler-wallet-core/src/wallet.ts
+++ b/packages/taler-wallet-core/src/wallet.ts
@@ -688,7 +688,7 @@ async function dispatchRequestInternal<Op extends 
WalletApiOperation>(
       await recoverStoredBackup(wex, req);
       return {};
     }
-    case WalletApiOperation.SetConfig:
+    case WalletApiOperation.SetWalletRunConfig:
     case WalletApiOperation.InitWallet: {
       const req = codecForInitRequest().decode(payload);
 

-- 
To stop receiving notification emails like this one, please contact
gnunet@gnunet.org.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]