[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[CRYPTO-LUKS v1 14/19] loopback: Add procfs entry 'loopbacks' to output
From: |
Glenn Washburn |
Subject: |
[CRYPTO-LUKS v1 14/19] loopback: Add procfs entry 'loopbacks' to output configured loopback devices. |
Date: |
Fri, 31 Jul 2020 07:01:55 -0500 |
Signed-off-by: Glenn Washburn <development@efficientek.com>
---
grub-core/disk/loopback.c | 56 +++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)
diff --git a/grub-core/disk/loopback.c b/grub-core/disk/loopback.c
index cdf9123fa..6a2be257b 100644
--- a/grub-core/disk/loopback.c
+++ b/grub-core/disk/loopback.c
@@ -21,6 +21,7 @@
#include <grub/misc.h>
#include <grub/file.h>
#include <grub/disk.h>
+#include <grub/procfs.h>
#include <grub/mm.h>
#include <grub/extcmd.h>
#include <grub/i18n.h>
@@ -229,6 +230,60 @@ static struct grub_disk_dev grub_loopback_dev =
.next = 0
};
+
+/* Open a file named NAME and initialize FILE. */
+#define STR(s) #s
+#define MAX_ID_PRINT 10000
+static char *
+loopbacks_get (grub_size_t *sz)
+{
+ struct grub_loopback *i;
+ grub_size_t size = 0;
+ char *ptr, *ret;
+ const char header[] = N_("<id> <devname> <filename>\n");
+ static char errmsg[] = N_("Can not list more than " STR(MAX_ID_PRINT)
+ " loopback devices.\n");
+
+ for (i = loopback_list; i != NULL; i = i->next)
+ if (i->id < MAX_ID_PRINT)
+ {
+ /* id + spaces + '\n' */
+ size += sizeof (STR(MAX_ID_PRINT)) + 2 + 1;
+ size += grub_strlen (i->devname);
+ size += grub_strlen (i->file->name);
+ }
+ else
+ {
+ *sz = sizeof (errmsg);
+ return errmsg;
+ }
+
+ ret = grub_malloc (sizeof (header) + size + 1);
+ if (!ret)
+ return 0;
+
+ ptr = grub_stpcpy (ret, header);
+
+ for (i = loopback_list; i != NULL; i = i->next)
+ {
+ ptr += grub_snprintf (ptr, 21, "%lu ", i->id);
+ ptr = grub_stpcpy (ptr, i->devname);
+ *ptr++ = ' ';
+ ptr = grub_stpcpy (ptr, i->file->name);
+ *ptr++ = '\n';
+ }
+ *ptr = '\0';
+ *sz = ptr - ret;
+ return ret;
+}
+
+struct grub_procfs_entry loopbacks =
+{
+ .name = "loopbacks",
+ .get_contents = loopbacks_get
+};
+
+
static grub_extcmd_t cmd;
GRUB_MOD_INIT(loopback)
@@ -239,6 +294,7 @@ GRUB_MOD_INIT(loopback)
or transformed into drive. */
N_("Make a virtual drive from a file."), options);
grub_disk_dev_register (&grub_loopback_dev);
+ grub_procfs_register ("loopbacks", &loopbacks);
}
GRUB_MOD_FINI(loopback)
--
2.25.1
- [CRYPTO-LUKS v1 05/19] luks2: Add support for LUKS2 in (proc)/luks_script, (continued)
- [CRYPTO-LUKS v1 05/19] luks2: Add support for LUKS2 in (proc)/luks_script, Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 06/19] luks2: Rename source disk variabled named 'disk' to 'source' as in luks.c., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 07/19] luks2: grub_cryptodisk_t->total_length is the max number of device native sectors., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 08/19] cryptodisk, luks: Allow special processing for comparing UUIDs., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 09/19] cryptodisk: Unregister cryptomount command when removing module., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 10/19] fs: Fix block lists not being able to address to end of disk sometimes., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 11/19] cryptodisk: Properly handle non-512 byte sized sectors., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 12/19] cryptodisk: Rename total_length field in grub_cryptodisk_t to total_sectors., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 13/19] fs: Allow number of blocks in block list to be optional, where length will be defaulted to the length of the device., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 14/19] loopback: Add procfs entry 'loopbacks' to output configured loopback devices.,
Glenn Washburn <=
- [CRYPTO-LUKS v1 15/19] cryptodisk, luks2: Add header line to procfs entry and crypto and source device names., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 16/19] cryptodisk: Add a couple comments noting the usage of a couple fields in grub_cryptodisk_t as is done for grub_disk_t., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 17/19] luks2: Ensure that bit fields of grub_luks2_digest_t in luks2_parse_digest are initialized before returning., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 18/19] luks2: Fix use of incorrect index and some error messages., Glenn Washburn, 2020/07/31
- [CRYPTO-LUKS v1 19/19] cryptodisk: Rename offset in grub_cryptodisk_t to offset_sectors to improve readability., Glenn Washburn, 2020/07/31
- Re: [CRYPTO-LUKS v1 00/19] Fixes and improvements for cryptodisks+luks2 and a few other things., Patrick Steinhardt, 2020/07/31