[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Libunwind-devel] [PATCH 17/17] ptrace: add more Debug to access_reg
From: |
Mike Frysinger |
Subject: |
Re: [Libunwind-devel] [PATCH 17/17] ptrace: add more Debug to access_reg |
Date: |
Fri, 14 Sep 2012 17:32:30 -0700 |
On Fri, Sep 14, 2012 at 5:12 PM, Cody P Schafer wrote:
> --- a/src/ptrace/_UPT_access_reg.c
> +++ b/src/ptrace/_UPT_access_reg.c
> @@ -43,6 +43,10 @@ _UPT_access_reg (unw_addr_space_t as, unw_regnum_t reg,
> unw_word_t *val,
> pid_t pid = ui->pid;
>
> #if UNW_DEBUG
> + Debug(16, "using pokeuser: reg: %s [%u], val: %lx, write: %d\n",
> unw_regname(reg), (unsigned) reg, (long) val, write);
> +#endif
> +
> +#if UNW_DEBUG
why do you need the #endif/#if in the middle here ?
> #if UNW_DEBUG
> + Debug(16, "using getregs: reg: %s [%u], val: %lx, write: %u\n",
> unw_regname(reg), (unsigned) reg, (long) val, write);
> +#endif
> +
> +#if UNW_DEBUG
here too
-mike
- [Libunwind-devel] [PATCH 04/17] ppc32: ppc64: test altivec support by running the compiler., (continued)
- [Libunwind-devel] [PATCH 04/17] ppc32: ppc64: test altivec support by running the compiler., Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 06/17] configure: use AS_HELP_STRING for configure args instead of manual formating, Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 07/17] ppc64: remove tests/ppc64-test-wchar, Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 08/17] configure: avoid using a shell function in autoconf, Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 16/17] ptrace: check for NULL arg., Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 14/17] configure: rename configure.in to configure.ac, Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 11/17] UPT: Add reg offsets for ppc32/64, Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 12/17] ppc64: be explicit in access_reg range check, Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 17/17] ptrace: add more Debug to access_reg, Cody P Schafer, 2012/09/14
- Re: [Libunwind-devel] [PATCH 17/17] ptrace: add more Debug to access_reg,
Mike Frysinger <=
- [Libunwind-devel] [PATCH 13/17] ppc64: add FRAME_POINTER & NIP to regname., Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 15/17] ptrace/access_reg: print out register name on "bad register", Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 10/17] configure: use AC_ARG_ENABLE(arg, text, , custom-act), Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 03/17] ppc32: add UNUSED attribute to dmy_ctxt, Cody P Schafer, 2012/09/14
- [Libunwind-devel] [PATCH 09/17] configure: use AC_ARG_ENABLE's defaults when possible, Cody P Schafer, 2012/09/14