[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[lwip-commits] [SCM] lwIP - A Lightweight TCPIP stack branch, master, up
From: |
Dirk Ziegelmeier |
Subject: |
[lwip-commits] [SCM] lwIP - A Lightweight TCPIP stack branch, master, updated. STABLE-2_1_0_RELEASE-164-gd386388 |
Date: |
Tue, 13 Nov 2018 06:24:14 -0500 (EST) |
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "lwIP - A Lightweight TCPIP stack".
The branch, master has been updated
via d386388fb566d61bdc95eb9decb4d7a08bf5c723 (commit)
via 2adc6d268737495e6d5211b87730f7c2a05c9be4 (commit)
via 405fc4d8026a25f1f16cdd7fd9e7f45fc8b8eac9 (commit)
via ee7ed8c87dcf02697b3bb82fcac9d5df1fb6a097 (commit)
via 65eb36b10d33527c980e250651ed129f8a251f98 (commit)
via 16da67bb212d8453e87e2ecf65719c37a97715d9 (commit)
via 331368e3aa93c6631f5bbae707313fd074be6a7c (commit)
via 201e772e15ab9f82efc302953f5a22e9a5d3d2eb (commit)
via 4289293061a1da39c04e86fe6c02eaec29352f50 (commit)
via 4ea511066281598d653a03eab6db59268f18756b (commit)
via 62fb2fd749ba0bf5fed8c494e840075663484347 (commit)
via c4321330d0ec3846dd0d5a204ec23735e2d3f478 (commit)
via 3043d9d023c96deeccaeb21a135c34e2a89a65ab (commit)
from 1a10a942f22c5d139573c5a4b68431a57ea47d30 (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit d386388fb566d61bdc95eb9decb4d7a08bf5c723
Author: Dirk Ziegelmeier <address@hidden>
Date: Tue Nov 13 12:22:24 2018 +0100
Move netif_mdns_data() and get_mdns_pcb() to mdns_priv.h
commit 2adc6d268737495e6d5211b87730f7c2a05c9be4
Author: Dirk Ziegelmeier <address@hidden>
Date: Tue Nov 13 12:20:57 2018 +0100
MDNS: Minor compile fix, declare variables before code
commit 405fc4d8026a25f1f16cdd7fd9e7f45fc8b8eac9
Author: Jasper Verschueren <address@hidden>
Date: Fri Nov 9 17:10:40 2018 +0100
Revert "mDNS: authority section of probe message needs to contain all
records"
This reverts commit e959e6efaf8a1cb57e9a5d4d8e0056c7ea52179f.
commit ee7ed8c87dcf02697b3bb82fcac9d5df1fb6a097
Author: Jasper Verschueren <address@hidden>
Date: Wed Nov 7 11:41:29 2018 +0100
mDNS: cleanup probing and announcing sequence
The implementation was not fully to the standard. This commit adds
a nicer state machine implementation and multiple announce messages
with a minimum of 2.
commit 65eb36b10d33527c980e250651ed129f8a251f98
Author: Jasper Verschueren <address@hidden>
Date: Fri Oct 19 16:09:07 2018 +0200
mDNS: ignore responses with src port != 5353 (rfc6762 section 6)
commit 16da67bb212d8453e87e2ecf65719c37a97715d9
Author: Jasper Verschueren <address@hidden>
Date: Fri Oct 19 13:58:49 2018 +0200
mDNS: source address check added
RFC6762 section 5.5 and 11 define that we should check that all
packets originated on the local link.
commit 331368e3aa93c6631f5bbae707313fd074be6a7c
Author: Jasper Verschueren <address@hidden>
Date: Thu Oct 25 09:41:00 2018 +0200
mDNS: add new files to filelists + solve compile errors
ttl setting removed from example code.
string.h included where needed.
commit 201e772e15ab9f82efc302953f5a22e9a5d3d2eb
Author: Jasper Verschueren <address@hidden>
Date: Wed Oct 24 16:15:11 2018 +0200
mDNS: author comment update + things left to implement update
commit 4289293061a1da39c04e86fe6c02eaec29352f50
Author: Jasper Verschueren <address@hidden>
Date: Fri Oct 12 15:35:02 2018 +0200
mDNS: add support for output delaying
See below commit messages for more information
mDNS: support for direct and delayed sends
There are two ways to send a response, directly and after a delay.
A probe or an announce msg are now send via the direct way and
all responses are send via the delayed way.
mDNS improved delay vs direct send behavior on questions
All multicast answers are delayed at the moment. While all unicast
answers are send out directly. A unicast answer is send when this
is requested by the QU bit, when a unicast question was send or
when the question originated from a legacy querier.
mDNS: add probe query detection.
If a probe query is detected a direct unicast respond is send.
Independent of the QU/QM bit.
mDNS split delayed multicast msgs into ipv4 and ipv6 buffers.
We are implementing a two resolvers in one (IPv6 and IPv4 together).
For directly send answers, this does not matter. But for delayed
answers, we need to make a separate buffer for both.
mDNS: addr bug, we should not clear full outmsg
memset deleted also the dest_addr and dest_port, which should remain
and is constant. This commit contains a function that resets only the
needed parts of the outmsg struct.
mDNS: do not multicast a rr within one second.
RFC6762 section 6: prevent network flooding. When a multicast packet
is send out, we start a timeout of 1s within this 1 second all
multicast requests are ignored. We do not make a difference between
the records, we set the delay for all records.
mDNS: improved split for unicast vs multicast and direct vs delayed
unicast delayed message are now possible and multicast direct msgs to.
MDNS: changed printfs to lwip debug messages
MDNS: change timeouts from max time to random time
mDNS: send multicast response on QU questions if not multicasted recently.
If a QU question is received, the responder should multicast the
answer if it did not multicast that record within 25% of it's ttl.
we implemented a stripped down version, meaning that we look at the
records as one set and use one timer for all records. So if the
responder multicasted a record within 30s of the QU question it
will respond with a unicast answer. if not, it will respond
multicast.
mDNS: timeouts -> create function for mdns timeout handling
mdns_set_timeout will check if the timer is running or not and will
update the flag to running after starting the timer.
Multicast timeouts were not set everywhere they needed to be. This
is solved.
mulit <-> multi typo fixed.
mDNS: solve commenting and style issues
mDNS: add #if LWIP_IPVx to new code
LWIP_IPV4/6 can be enabled or disabled, all combination should work.
commit 4ea511066281598d653a03eab6db59268f18756b
Author: Jasper Verschueren <address@hidden>
Date: Fri Oct 12 10:01:04 2018 +0200
mDNS: remove netif from mDNS structs
it's more practical to use netif as a wrapper instead of wrapping
netif in the mdns packets. netif contains all information.
Netif is passed along were needed.
commit 62fb2fd749ba0bf5fed8c494e840075663484347
Author: Jasper Verschueren <address@hidden>
Date: Thu Oct 11 15:16:21 2018 +0200
mDNS fix TTL bug
MDNS_TTL changed to MDNS_IP_TTL for clarity.
The mDNS RR ttl does not need to be settalbe, this is against the
RFC. RFC6762 states that for rr's with the hostname in them
somewhere, the ttl should be 120s. If it's not in their it should
be 75 minutes and if the answer is send to a legacy dns querier,
it should be no more then 10s.
This patch corrects the ttl behavior to the RFC.
commit c4321330d0ec3846dd0d5a204ec23735e2d3f478
Author: Jasper Verschueren <address@hidden>
Date: Wed Oct 10 09:59:02 2018 +0200
mDNS: authority section of probe message needs to contain all records
see RFC 6762 section 8.2: for tiebreaking to work correctly in all
cases, the Authority section must contain all the records and
proposed rdata being probed for uniqueness.
commit 3043d9d023c96deeccaeb21a135c34e2a89a65ab
Author: Jasper Verschueren <address@hidden>
Date: Wed Oct 10 09:40:03 2018 +0200
mDNS: move domain related functions and output related funtions
mDNS.c needed to become cleaner. Domain related functions are
moved to the mdns_domain.c util module. The output related
functions are split off (clear separation between defining the
packet and generating the packet). The output functions can
now be found in mdns_out.c.
mDNS move probe question packet generation to mdns_send_outpacket
The probe any questions were added to the pbuf in the send_probe
routine. It is better if we move all pbuf generation to the output
function so later on packets can be delayed etc. keep it all in
one place.
mDNS: move legacy question generation to mdns_send_outpacket
It's better to do the pbuf generation in one place.
Especially important for message delaying etc.
mDNS take out domain related functionality and put in other file.
The mDNS file is getting very big and a lot still needs to be added.
For clarity reasons it's better to split these domain functions
from the main mDNS file.
mDNS split off output related functionality and put in other file
A lot of functions are only needed for the generation of the pbuf,
by separating them into another file we clean up the mdns file.
We only need the mdns_send_outpacket function as interface.
Packet definition is now completely separated from packet
generation.
-----------------------------------------------------------------------
Summary of changes:
contrib/examples/mdns/mdns_example.c | 4 +-
src/Filelists.cmake | 2 +
src/Filelists.mk | 4 +-
src/apps/mdns/mdns.c | 1867 +++++++-------------
src/apps/mdns/mdns_domain.c | 548 ++++++
src/apps/mdns/mdns_out.c | 992 +++++++++++
src/include/lwip/apps/mdns.h | 5 +-
.../lwip/apps/{mdns_priv.h => mdns_domain.h} | 37 +-
src/include/lwip/apps/mdns_opts.h | 1 +
src/include/lwip/apps/mdns_out.h | 121 ++
src/include/lwip/apps/mdns_priv.h | 146 +-
test/unit/mdns/test_mdns.c | 1 +
12 files changed, 2451 insertions(+), 1277 deletions(-)
create mode 100644 src/apps/mdns/mdns_domain.c
create mode 100644 src/apps/mdns/mdns_out.c
copy src/include/lwip/apps/{mdns_priv.h => mdns_domain.h} (69%)
create mode 100644 src/include/lwip/apps/mdns_out.h
hooks/post-receive
--
lwIP - A Lightweight TCPIP stack
[Prev in Thread] |
Current Thread |
[Next in Thread] |
- [lwip-commits] [SCM] lwIP - A Lightweight TCPIP stack branch, master, updated. STABLE-2_1_0_RELEASE-164-gd386388,
Dirk Ziegelmeier <=