[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[paparazzi-commits] [paparazzi/paparazzi] 2478bd: [arch/linux] udp: only
From: |
GitHub |
Subject: |
[paparazzi-commits] [paparazzi/paparazzi] 2478bd: [arch/linux] udp: only create one socket for sendi... |
Date: |
Thu, 05 Mar 2015 07:12:36 -0800 |
Branch: refs/heads/master
Home: https://github.com/paparazzi/paparazzi
Commit: 2478bd7bea94fc9d67b7c63452291a120e7467c6
https://github.com/paparazzi/paparazzi/commit/2478bd7bea94fc9d67b7c63452291a120e7467c6
Author: Felix Ruess <address@hidden>
Date: 2015-03-03 (Tue, 03 Mar 2015)
Changed paths:
M sw/airborne/arch/linux/mcu_periph/udp_arch.c
M sw/airborne/arch/linux/mcu_periph/udp_arch.h
Log Message:
-----------
[arch/linux] udp: only create one socket for sending and receiving
Commit: f75b87f595ea07812f1efc0c8ca517098c33b2c9
https://github.com/paparazzi/paparazzi/commit/f75b87f595ea07812f1efc0c8ca517098c33b2c9
Author: Felix Ruess <address@hidden>
Date: 2015-03-03 (Tue, 03 Mar 2015)
Changed paths:
M conf/firmwares/subsystems/shared/udp.makefile
M sw/airborne/arch/linux/mcu_periph/udp_arch.c
M sw/airborne/arch/linux/mcu_periph/udp_arch.h
A sw/airborne/arch/linux/udp_socket.c
A sw/airborne/arch/linux/udp_socket.h
Log Message:
-----------
[arch/linux] more generic udp_socket
Commit: ccc6f821607b2d576cc76354e6e7c3afbb1c73d9
https://github.com/paparazzi/paparazzi/commit/ccc6f821607b2d576cc76354e6e7c3afbb1c73d9
Author: Felix Ruess <address@hidden>
Date: 2015-03-03 (Tue, 03 Mar 2015)
Changed paths:
M conf/firmwares/subsystems/shared/udp.makefile
Log Message:
-----------
[conf] add udp_socket for nps target
Commit: 31f555ea9986747771970ac3ac0f663528d2f9a0
https://github.com/paparazzi/paparazzi/commit/31f555ea9986747771970ac3ac0f663528d2f9a0
Author: Felix Ruess <address@hidden>
Date: 2015-03-03 (Tue, 03 Mar 2015)
Changed paths:
M sw/airborne/arch/linux/mcu_periph/udp_arch.c
Log Message:
-----------
[arch/linux] udp: fix printf format warning
Commit: 2d3efdb6ee40832f3830293788132790b3e20a4a
https://github.com/paparazzi/paparazzi/commit/2d3efdb6ee40832f3830293788132790b3e20a4a
Author: Felix Ruess <address@hidden>
Date: 2015-03-04 (Wed, 04 Mar 2015)
Changed paths:
M sw/airborne/arch/linux/udp_socket.c
M sw/airborne/arch/linux/udp_socket.h
Log Message:
-----------
[arch/linu] udp_socket: possibility to use hostname
Commit: be6289440e116b3b1c0277129cbe52a8412868cf
https://github.com/paparazzi/paparazzi/commit/be6289440e116b3b1c0277129cbe52a8412868cf
Author: Felix Ruess <address@hidden>
Date: 2015-03-04 (Wed, 04 Mar 2015)
Changed paths:
M sw/airborne/arch/linux/mcu_periph/udp_arch.c
M sw/airborne/arch/linux/udp_socket.c
M sw/airborne/arch/linux/udp_socket.h
Log Message:
-----------
[arch/linux] rename UdpNetwork to UdpSocket
Commit: 2bc2ae43729fab6ca5918fc634de8260d4bb8895
https://github.com/paparazzi/paparazzi/commit/2bc2ae43729fab6ca5918fc634de8260d4bb8895
Author: Felix Ruess <address@hidden>
Date: 2015-03-05 (Thu, 05 Mar 2015)
Changed paths:
M conf/firmwares/subsystems/shared/udp.makefile
M sw/airborne/arch/linux/mcu_periph/udp_arch.c
M sw/airborne/arch/linux/mcu_periph/udp_arch.h
A sw/airborne/arch/linux/udp_socket.c
A sw/airborne/arch/linux/udp_socket.h
Log Message:
-----------
Merge pull request #1122 from paparazzi/single_udp_socket
Single udp socket
Only create one socket for sending and receiving, instead of two where you use
one only to send and the other only to receive.
There should be no reason/need to create two separate ones...
Also add udp_socket.[ch] to make it easier to use only the UDP sockets without
the UART like mcu_periph/udp interface around it.
Provides the functions:
- udp_socket_create
- udp_socket_send
- udp_socket_recv
- udp_socket_recv_dontwait
Compare:
https://github.com/paparazzi/paparazzi/compare/41fc1946953b...2bc2ae43729f