[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[patch #5491] Eliminated global variable current_dataset
From: |
Ben Pfaff |
Subject: |
[patch #5491] Eliminated global variable current_dataset |
Date: |
Thu, 26 Oct 2006 02:47:40 +0000 |
User-agent: |
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060830 Firefox/1.5.0.7 (Debian-1.5.dfsg+1.5.0.7-1) |
Update of patch #5491 (project pspp):
Assigned to: blp => jmd
_______________________________________________________
Follow-up Comment #1:
I expected this to be awful and invasive, because of the need to add
"struct dataset *" arguments to so many functions. But it's not
nearly as bad as I expected. On the whole, it's a significant
improvement. Thank you for writing this.
I have a few other comments:
Grammar of comment changed in dictionary.c got mangled.
There are several typedef declarations for function pointer types in
procedure.h. Instead of typedef'ing a pointer to function type,
please typedef the function type itself, and then specify the "pointer
to" part in each declaration that needs it. I prefer this form
because the typedef can then be used for function prototypes and
because I don't like to hide pointers behind typedefs. Also, it is
consistent with the style used elsewhere in PSPP.
Also, I'd prefer not to use a _t suffix on type names, because all
identifiers that end in _t are reserved by POSIX (see
http://www.opengroup.org/onlinepubs/009695399/functions/xsh_chap02_02.html).
For function types, I like to just have their names end in _func.
parse_dict_variable could be renamed to parse_variable now.
Now I have to go fix a bunch of conflicts against my working
directories...
_______________________________________________________
Reply to this item at:
<http://savannah.gnu.org/patch/?5491>
_______________________________________________
Message sent via/by Savannah
http://savannah.gnu.org/