File
New

            Opens a new data or syntax file. (ref data syntax sections)
Open

           Open an existing data or syntax file.   (ref data syntax sections)
Import Delimited Text Data
            Import all or part of a delimited text data file into the data editor. 
A series of dialogue boxes will guide you through the process of importing your data.
Importing Textual Data Dialogue 

Enables you to import all or part of the file. 
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Importing Textual Data

“This assistant will guide you through the process of importing
datainto PSPP from a text fle with one line per case, inwhich
fields are separated by tabs, commas, or other delimiters.

The selected file contains approximately 21 lines of text. Only
the first 21 lines of the file il be shown for preview purposes
in the following screens. You may choose below how much of
the file should actually be imported.
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First Line of Data Dialogue

Enables you to ignore headers or any other text that might be at the top of the data file.
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Choose Separators Dialogue
Enables you to choose from a choice of delimiters. Options include:

Space

Colon

Pipe

Tab

Comma

Semicolon

Bang

Hyphen

Slash

Custom Separator

In addition, you can choose to quote separator characters.
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Adjust Variable Formats
Enables you to verify and edit variable attributes. (reference to variable attributes)
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After you have edited the attributes select Apply to import the data.

Save

               Save the current opened file.
Save As

               Save the current opened file in a directory of you choice.

Display Data File Information

              Working File
                           Display the dictionary of the currently opened file.

                 Example
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                  External File
                       Display the dictionary of a data file that is not yet open. 

Recently Used Data

                   A list of shortcuts to recently opened data files.  

Recently Used Files

                A list of shortcuts to recently opened syntax files.  

Quit

                 Close the current data file and shutdown PSPP. 

Edit

Insert Variable

                Insert a new variable in data view to the left of the current column. The editor fills in system-missing values for all cases as a placeholder. By default, PSPP inserts a numerical variable type. 

( reference Data Editor Window)
Example

Select Edit->Insert Variable

PSPP inserts a new variable in the column to the left.
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Type a value and press enter.

Insert Cases
               Insert a new case in variable view above the current row. The editor fills in system-missing values for all variables as a placeholder. (reference data editor section)
Go To Case

                Jump to the selected case number.               

Cut 

               Remove the selected text and place it elsewhere by selecting paste at the desired insertion point. 
Copy

              Copy the selected text and place it elsewhere by selecting paste at the desired insertion point. 

Paste 

              Places the contents stored by the cut and copy commands at the insertion point. 

Find

               Search for a specified value in a variable column. 

View

Status Bar

               Turn the status bar located at the bottom of the data editor window on or off.  (reference status bar section)
Font

              View and edit the current font settings. 

Grid Lines
              Make the grid lines in the data editor window invisible or visible. 

Value Labels

             Show the value label associated with each result in data view.
Example
The data editor window on the right displays the value labels of the numerical survey data displayed in the window to the left. 
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Variables

Switch the data editor between data and variable view.

Data

Sort Cases

Sort cases in ascending or descending order based on one or more variables. 
Transpose

            Switch rows and columns on data that is in the reverse order to the PSPP file format. The standard file format lists cases in rows and variables in columns. (ref data editor section)
Split File

            Split a data file into separate groups for analysis by selecting one or more grouping variables.  If you select more than one grouping variable then each successive category is nested within the previous one. Note that cases should be sorted with the “Sort Cases” command first, and these should be in the same order that the grouping variables are listed in the “Groups based on” text box in the Split File pop up menu.
           Split File Dialog Box
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           Compare groups
           

Present split-file group output along side each other. For example, the output viewer displays a chart for each group in a single window.

           Organize output by groups
           Show results for each split-file group separately. 

           Example
Using a data file containing physiology data, the file is grouped based on height using the Split File menu command. 
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First, group the data according to height.

1) Select Data->Split File.

2) Select the “Compare groups” radio button in the dialogue box.

3) Click “Height in millimeters” to highlight the variable.
[image: image10.jpg][/ Sex of subject O Analyze all cases. Do not create groups.

® Compare groups.
# Weight in kilograms
# Internal b...es Celcius

O Organize output by groups.
Groups based on:

| ® Sort the fle by grouping variables.
O File s already sorted:

Current Status : Analysis by groups is off





4) Select the right arrow to place the height variable in the “Groups based on” text box.
5) Click OK.

Select Cases

              Seems non-operational.
Weight Cases

           

 Assign weights to variables for analyses. Note that cases with a zero, negative, or missing value for the weighting variable are not included in the analysis.
Transform
Compute

            
Perform operations on numeric and string data columns with inbuilt functions. You can compute new variables or replace existing ones.
Example

Compute the absolute difference in weight before and after participants followed a particular diet plan from the following study.
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Select Transform->Compute from the drop-down menu. A dialog box pops up.
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The Target Variable textbox is where you name the variable that will be equated to the result.
Enter “weight_change” in the textbox and click the Type & Label button below it.

This brings up the Type and Label dialogue box.
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Select the Label radio button, enter “weight change in kilograms” and press Continue.
Select the ABS(number) function from the list of functions and then press the up arrow.

This places the function up in the Numeric Expressions text box. 
Select the weight_after variable from the list of variables located on the left of the dialog box. Note that hovering the mouse over the list of variables brings up their names.
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Place the mouse cursor inside the ABS function parentheses. 
Click the right arrow to the left of the Numerical Expressions text box.

ABS(weight_after) is now displayed in the Numeric Expressions textbox.
Delete the question mark if it is still present in the ABS arguments. 

Enter a space followed by a minus sign and another space after the weight_after variable.

The text inside the Numeric Expressions text box now looks as follows:

ABS(weight_after - )

Select the weight_before variable from the list of variables located on the left of the dialog box.

Place the mouse cursor before the left facing parenthesis of the ABS function inside the Numeric Expressions textbox.

Click the right arrow located to the left of this textbox.
The equation in the Numeric Expressions textbox now looks as follows:
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Click OK.

PSPP adds the result to your data file.
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Rank Cases

The Rank cases component creates new variables that hold the ranks, Savage and Normal scores, and percentile values for numeric variables in the current data file. PSPP automatically names and labels these new variables indicating the original variable name and selected measures. 
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Assign rank 1 to the smallest value for ascending order, and to the largest value for descending.
You can rank numerical variables by moving them into the Variables textbox.

You can organize rankings into subgroups by moving one or more variables into the By textbox. For example, if you select gender and height then PSPP calculates ranks for each combination of gender and height.
Rank Types

You can select different rank types by clicking the Rank types Button towards the bottom of the Rank Cases dialogue box. This brings up the Rank Cases Types dialogue box.
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Rank 
        The value of the new variable is its rank.

Savage Score

        Returns a savage score based on an exponential distribution.

Fractional Rank

         Returns the rank divided by the sum of the weights of non-missing cases.
Fractional Rank as a Percent

           Returns the rank divided by the number of cases as a percent.
 Sum of Case Weights
           Return the sum of the case weights.
Ntiles

           Returns a rank based on the percentile group. The size of each percentile group is given by 100/Ntile. If Ntile=4, then rank 1 corresponds to the 1st 25th percentile, rank 2 to cases between the 25th and 50th percentile, rank 3 to cases between the 50th and 75th percentile and rank 4 to the last percentile group.

Proportion estimates
             Return estimates of the cumulative proportion of the distribution corresponding to a specific rank.

Normal scores

              Return the z scores corresponding to the estimated cumulative proportion.
Proportion Estimates

             Select a proportion estimate formula to apply when calculating proportion estimates and normal scores.  Options include Blom, Tukey, Rankit, or Van der Waerden.
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Blom
            The ranking variable is based on proportion estimates which employ the formula (r - 3/8)/(w+ ¼), where w is the sum of the case weights and r is the rank.

Tukey

           Applies the formula (r – 1/3) / (w + 1/3), where r is the rank and w is the sum of the case weights.

Rankit
        Applies the formula (r – ½) / w, where w is the number of observations and r is the rank, ranging from 1 to w.

Van der Waerden

        Return Van der Waerden’s transformation which is given by the formula r/(w+1), where w is the sum of the case weights and r is the rank, ranging from 1 to w.
Ties
The Ties dialog box allows you to select the method for assigning rankings to cases with the same value on the original variable. 
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Recode into Same Variables

You can change the values of variables with the recode into same variables dialog box. There are two options available; change a single value to a new one or change a range of values to a category. Note, that the new variable type must be the same as the original; numeric or string.
Example 1
Change a single value.
Change the value of 12 miles-per-gallon (MPG) to 13 MPG in the following data set.
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Select Transform->Recode into Same Variables. A Recode dialogue box appears.
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Select Miles Per Gallon and click the right arrow to put it into the Variables textbox.
Click Old and New Values. The Old and New Values dialogue box pops up.
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Type the number 12 in the Value text box under Old Value on the left side.
Type the number 13 in the Value text box under New Value on the right side.
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Click the Add button. The number 12 now appears under old and 12 under new.
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Press Continue. The Old and New Values dialogue box disappears.

Press OK on the Recode into Same Variable dialogue box.

The value 12 MPG is now 13 MPG.
Example 2

Collapse a Range of Values into a Category

The auto data set has mile-per-gallon values that range from 13 to 41 MGH. Split the range of values into categories as follows:

          If mpg is less than 19 MPG then mpg is equal to 1.
          If mpg is greater than or equal to 19 MPG and less than 24 then mpg is equal to 2.
          If mpg is greater or equal to 24 then mpg is equal to 3.

Select Transform->Recode into Same Variables

Select the range LOWEST thru value radio button, and enter 18.

Enter the number 1 in the value text box under New Value on the right side of the dialogue box.

Click the Add button. This results in “LOWEST-18” listed under old and “1” under new.

Repeat with the other ranges.
           Select the range-through radio button and enter 19 in the first text box and 23 in the second.

            Enter the number 2 in the value text box under New Value, and click the Add button.

           Select the range thru HIGHEST radio button and enter 24.

           Enter the number 3 in the value text box under New Value, and click the Add button.

The dialogue box now looks as follows:
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Click Continue. The Old and New Values dialogue box disappears.

Click OK on the Recode into New Variables dialogue box.

 The MPG variable now contains the new values. 
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Recode Into Different Variables

You can change the values of variables with the recode into different variables dialog box. There are two options available; change a single value to a new one or change a range of values to a category. Note, that the new variable type must be the same as the original; numeric or string.

This component operates in the same way as the recode into same variables dialog box except that it places the result into a variable that you name and label in the output variable text boxes. (Ref –Recode into Same Variables for further information and examples)
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Run Pending Transforms

Get back to – haven’t found more info about
Analyze

Descriptive Statistics
Statistics

Central Tendency

A measure of the central position of a set of data. 

Mean
        A measure of the average value, or first moment, and is the sum of all data within a set divided by the number of cases that make up the set.  Note that moments are sums of integer powers of the values, where a higher integer power corresponds to a higher moment e.g. the variance is the second moment, skewness the third, and kurtosis the fourth. 
The mean is susceptible to outlying values. For example, the average temperature over a month in a region that has had a few unusually hot days will be higher than usual. 
       Median

       The central value of an ordered set of numbers. In other words, 50% of the values fall above or below it. When the number of data values is even the median is the average of the middle two. The median is not as susceptible to outlying values as the mean.
Mode
The most frequently occurring value.  Note that this might not represent the central tendency, and there can be more than mode in a data set.
Sum

The addition of all the values across the different cases without missing values.

Dispersion
A measure of the spread or variation in data values about the mean.

Standard deviation

A measure of the spread in values about the mean. It is equal to the square root of the sum of the squares of the difference between each value and mean divided by one less than the number of cases. 
Variance
The standard deviation squared, or the second moment.
Range
The difference between the largest and smallest numerical values in the set.
Minimum

The smallest numerical value in the set.
Maximum

The largest numerical value in the set.
S. E. mean
The standard error of the mean is a measure of by how much the value of the mean varies with different samples from the same distribution.
Distribution

Statistics that describe the shape and symmetry of a distribution. 

Skewness

A measure of the asymmetry of a distribution. You can calculate this by taking the third moment (proportional to the sum of the cube of the difference of each data value and the mean). Note that unlike the mean and variance the definition is such as to make it a dimensionless quantity, and this pure number characterizes the shape of the distribution.  A positive skewness indicates a distribution that has a more heavily pronounced right tail, while a negative value indicates a more prominent left one. When both tails are equal the skewness is zero.
Kurtosis

A measure of the relative peakedness or flatness compared to a normal distribution. You can calculate this by taking the fourth moment (proportional to the sum of the fourth power of the difference of each data value and the mean). Like the skewness, this is also a dimensionless quantity. A distribution with negative kurtosis is termed leptokurtic, while one with a positive value as platykurtic, and an in-between distribution is termed mesorkurtic.
Frequencies

The frequencies dialogue box enables you to generate statistics including central tendency (mean, median, mode, and sum), dispersion (standard deviation, variances, range, minimum, maximum, standard error of the mean) and distribution (skewness and kurtosis). Optionally, you can also view frequency tables and charts.
Frequencies Dialogue Box
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The frequencies dialogue box displays the variables along the left side. In order to perform statistical analyses or plot charts you need to move the relevant variables into Variables dialogue box by clicking the variable until it is highlighted and then select the right arrow.
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Frequency Tables Dialogue Box
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You can turn the option to display frequency tables on or off, as well as choose in what way to order the tables; ascending or descending value or ascending or descending frequency.
Charts Dialogue Box
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You can plot histograms or pie charts with the Chart Dialogue box.

Histogram options include scaling with either frequencies or percentages and superimposing a normal curve.
Pie charts come with the option to include slices for missing values.
Example:
(Note histogram plot with percentages seems to be non functional)
Consider analyzing the following survey data of customers who stayed at a specified hotel. The first question asked how much they agreed with the statement “I am satisfied with the level of service”, where one equals strongly disagree and five equals agree. You can study the responses to this question with the frequencies tool.
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Select Analyze-> Descriptive Statistics-> Frequencies to bring up the Frequencies dialogue box.
Select the first variable from the list on the left side then click the right arrow to place it in the Variables dialogue box.
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Select the charts button to bring up the Charts dialogue box

Select Draw Histograms and press Continue to close this dialogue box.
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Select mode within the statistics section of the Frequencies dialogue box.
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Press OK. 
PSPP displays the results in the output viewer.
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The statistics in the table and histogram demonstrates that the most popular answer (the mode) is the one that indicates people strongly disagree that the levels of service were satisfactory, and this corresponds to 5 respondents or 29.41% of the survey participants.

Descriptives
Provides univariate summary statistics and z scores. Statistics include: central tendency (mean), dispersion (standard deviation, variance, range, minimum, maximum, and standard error of the mean), and distribution (kurtosis and skewness).
A z score is a dimensionless variable that classifies the number of standard deviations a value is away from the mean. This conversion is referred to as standardizing or normalizing. Note that z scores are based on normal theory and are best for quantitative variables with symmetrical distributions. If the distribution is skewed the z scores will be also.
Example

First, generate appropriate data by using the syntax editor to write a small program to generate normally distributed data representing SAT test scores with a mean of 500 and standard deviation of 110.

Select File->New->Syntax to open a syntax window.
Enter the following command lines in the syntax window.
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Select Run->All to execute the program. This populates the data editor with random numbers from a normal distribution.
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Now calculate the z scores using the Descriptives dialogue box.

Select Analyze->Descriptive Statistics->Descriptives to bring up the Descriptives dialogue box.

Select the newvar variable by clicking on it in the variables list to the left of the dialogue box, and then click the right arrow to bring it into the Variables textbox.

Select the save Z scores of selected variables as new variables check box.
Click OK to generate a list of z scores under the new variable in the data editor window.
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Explore

Provides descriptive statistics along with percentiles and extremes, and enables you to examine subgroups of data.
Descriptive statistics include the mean, median, variance, standard deviation, minimum, maximum, range, skewness, and kurtosis.

Example
You can generate descriptive statistics of the following data set of SAT test scores and gender by examining the results of all participants as a whole, or you can break it down into subgroups and do a separate analysis for each gender type.
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First, examine all the test scores collectively.
Select Analyze-> Descriptive Statistics-> Explore, to open the Explore dialogue box.
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Select Score and press the right arrow to place it in the Dependent List.
Press the Statistics button at the bottom left side of the dialogue box to bring up the statistics dialogue box.
Select the Descriptives and Extremes check boxes, and then press continue.
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Press OK on the Explore dialogue box.
PSPP displays the results of the analysis in the output editor.
[image: image44.jpg]Ele Edit windows Help

EXAMINE

| Examine

EXAMINE
EXAMINE
VARIABLES= Score
JsTaTisTICS
MissING=LsTISE

ESCRIPTIVES EXTREME

Cazer

Valid_| Missing | _Total

W [percent Npercert, N [percart

[Score[306]_003%l0] _ove[500]_100%

TCase Narber Valu
[scorerighesty U
2| 282080510
F Tiafras4
4 5[76s 52
3 ealre1 71
Tovastl] l1750
2| Sel16258
F 1561234 39
ki 300/245 0
B 21425552
Tetatic |74 Ero
[Scoretizan o151 | 637
95% Confidence Intervalfor MeanLover Sound| 38857
Uppar Sound| 51405
5% Trmmed Mean 522
Medan 0125
Varance 12175 55
55 Devation T1036
Mirimum 17908
Masimom a5
Range 5545
Irtarauartie Range 173
Skavness 0w | 14
Kurtose 2 |





Next, analyze the test scores for each gender group separately, where 0 represents a male.
Select Analyze->Descriptive Statistics->Explore to open the Explore dialogue box.
Select Score and press the corresponding right arrow button to place the variable in the Dependent List.

Select Gender and press the corresponding right arrow button to place the variable in the Factor List.
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Select the Statistics button at the bottom of the Explore dialogue box.
Select the Descriptives and Extremes check boxes and then press the continue button to close this dialogue box.

Press OK on the Explore dialogue box.

The output viewer lists different statistics for each group. For example, the lowest and highest test scores for the male group are 182.98 and 835.52, respectively, while the lowest test result for the females is 179.03 and the highest 805.10.
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Crosstabs

Provides information about bivariate relationships by cross-tabulating two variables. This tool is useful for determining if one variable is dependent upon another. For example, in a customer satisfaction survey you might discover a dependency of customer satisfaction levels on price.
Statistics and measures of association
Chi-square
 
For any number of rows and columns select Pearson’s Chi-square test, if the frequency in each cell is at least five. If the frequency is less than 5, and the contingency table is 2 x 2 in size then Fisher’s Exact test is performed. Note that this does not apply if the table is this size due to missing rows or columns in a larger table. When both variables are quantitative, this function also returns a linear-by-linear association test.
Correlations
             For tables that contain only ordered values in the rows and columns Correlations returns Spearman’s correlation coefficient and rho for numeric data. When both variables are quantitative Correlations returns the Pearson’s R. 
Nominal Data
For nominal data you can measure the degree of association with several coefficients.
Phi

Phi is a measure of association that returns the square root of the chi-square coefficient divided by the sample size. Typically, you apply phi to 2 x 2 tables although it can handle larger sizes. For 2 x 2 tables phi is identical to the correlation coefficient, but for larger tables the interpretation can be more complex.
Contingency Coefficient 
An adjustment to phi in order to make it suitable for tables larger than 2 x 2. The coefficient is equal to the square root of chi-square divided by chi-square plus the sample size. Note, that for tables smaller than 5-by-5 it will underestimate the level of association. 

Cramer’s V

            Gives accurate results when the number of rows is equal the number of columns, independent of the table size. V is equal to the square root of chi-square divided by the product of the sample size and the length of the smallest row or column. 
Lambda
            Returns the percent you reduce errors in guessing the value of the dependent variable when you know the value of the independent variable. A lambda of zero means that there is no advantage in using the distribution of the independent variable to estimate the value of the dependent variable. 
Uncertainty Coefficient

            Otherwise known as the entropy coefficient is the percent reduction in error accounting for the variance in the dependent variable, where the variance is defined in terms of entropy. When the uncertainty coefficient is zero, the independent variable is not helpful in predicting the dependent variable.

Ordinal Data

            Gamma

            Returns the strength of association for ordinal data, ignoring tied pairs. A tie is where cases have equal values on both variables. Gamma is defined as the number of concordant pairs minus the number discordant ones over the sum of each type of pair. Cases form a concordant pair when the ranking agrees meaning one case has a higher value than another case on both variables. When one case has a higher value on one variable, but a lower value on another the ranking disagrees and the cases form a discordant pair. Values range from -1 to 1. A value of 1 indicates perfect agreement between the rankings, while a value of -1 means there is perfect disagreement. There is no association between cases when gamma is equal to zero. Note, that since ties are ignored gamma might over exaggerate the strength of association between two variables.
         Somers’ d

            A modification of Gamma that accounts for pairs tied on the dependent variable. Values range from -1 for negative relationships to 1.
         Kendall’s Tau B

           A modification to gamma that takes into account tied pairs tied on both the dependent and independent variable. Kendall’s tau-b is symmetrical in that the same value is produced regardless of which variable is considered independent. Tau-b can only reach its maximum or minimum values of 1 and -1 for square tables.
         Kendall’s Tau C

             A modification to gamma that takes into account tied pairs tied on both the dependent and independent variable. A variant of Tau-B that can reach the maximum and minimum values of 1 and -1 for non-square tables. 
Nominal by Interval
            Eta
            Use this measure of association when the dependent variable is a quantitative measure and the independent variable is categorical. Eta ranges from 0 to 1, with increasing values indicating a higher degree of association.


Cohen’s Kappa

Kappa is a measure of the degree to which two raters agree in their sorting of items into mutually exclusive categories, and takes into account agreement occurring by chance. Values range from -1 to 1 and represent the proportion of agreements between raters after adjusting for those that take place by chance. A value of 1 indicates perfect agreement and -1 perfect disagreement. When kappa is zero, then there is no relationship between the raters and any agreements or disagreements are due to chance only. 

Estimated Relative Risk
           The observed risk of having the outcome of interest be greater due to a specific factor.  Note that this is only suitable for 2 x 2 tables. A confidence interval greater than one indicates there is a greater chance of the event occurring in the presence of the factor. Use the odds ratio as an estimate or measure of risk if the occurrence of the factor is rare. 
Example


As an example, consider a medical study examining the relative risk of patients having cerebella toxicity who have taken a generic chemotherapeutic agent rather than a non-generic one.

	
	Toxicity +
	Toxicity -

	Generic +
	11
	14

	Generic -
	3
	31



Enter the data in PSPP using the following format, where 1 represents + and 0 represents -.
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Weight the cases by selecting Data->Weight Cases, and then choose weight cases by freq.
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Select Analyze-> Descriptive Statistics -> Crosstabs to open the Crosstabs dialogue box.


Put the Toxicity variable into Rows and Generic variable into Columns and then click Statistics to bring up the Statistics dialogue box.
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Select the Risk check box and click Continue to close this dialogue box.

Click OK on the Crosstabs dialogue box.

PSPP displays the results in the output viewer.
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Compare Means
One-Sample T-Test

Tests whether the mean of a single variable differs from a specified constant. 

Example

You can compare the mean of 100 measurements of the number of hours that soft white light bulbs were operational to the time claimed by the manufacturer of 700 hours. The measurements are listed in a single column under the variable named hours.
            Select Analyze-> Compare Means -> One Sample T Test.
            Select the hour variable in the left text box and the click the right arrow to move it into the Test Variables dialogue box.

Enter the value 700 into the Test Value text box. 
           [image: image51.jpg]




Click OK.
            You can view the results in the output window.
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Independent Samples T Test

Compares the means of the same variable taken from two independent samples. The test requires normally distributed data, although minor departures from this assumption are tolerable. There is no requirement that the two samples are the same size. 
 Example

You can compare the mean height of 12-year-old boys and girls in centimeters measured in a class of ten girls and ten boys. 
Enter the following height and group data into PSPP, where 0 represents a female and 1 male.

	152.71
	0

	142.57
	0

	155.48
	0

	148.79
	0

	167.74
	0

	149.51
	0

	142.00
	0

	150.21
	0

	171.19
	0

	141.99
	0

	152.67
	1

	139.65
	1

	152.19
	1

	156.94
	1

	151.86
	1

	157.79
	1

	152.49
	1

	157.52
	1

	156.95
	1

	141.61
	1


Name the first variable Height and the second Gender.
Select Analyze-> Compare Means -> Independent Samples T Test.
Select Height and click the upper right arrow to move it into Test Variables.
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Select Gender and click the lower right arrow to move it into Define Groups.
Click the Define Groups button at the bottom of the dialogue box.
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Enter 0 into the Group1 Value textbox of the Define Groups dialogue box.
Enter 1 into the Group2 Value textbox of the Define Groups dialogue box.

Select Continue.
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Click OK on the Independent-Samples T Test dialogue box.
The results in the output viewer show that the girls are marginally taller.
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Paired Samples T Test
Compares the mean of two sets of quantitative data where the data sets are organized into pairs with a definite relationship. For example, one set of data might represent a measurement taken before some event and the other a measurement taken after. Each pair is then the measurement before coupled with the measurement after. 

Example

You can use the paired samples t-test compare the means of the following measurements of the peak expiratory flow rate before and after a walk on a cold winter’s day of 9 asthmatics.
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Select Analyze->Compare Means-> Paired Samples T Test.
Highlight the Before variable with the mouse and then click the right arrow to place it under Var1 in the Test variables dialogue box.
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Repeat with the After variable in order to place it under Var2.
Click OK

The Output window displays the results.
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One Way Anova

Use the one-way analysis of variance to determine whether there are any significant differences between the means of three or more independent groups. Note, that this analysis tells you only if groups are significantly different and not which ones. The independent variable consists of two or more categorical independent groups while the dependent one is either interval or ratio. 
One-Way ANOVA dialogue box.
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Optional Statistics include Descriptives (mean, standard deviation, standard error of the mean, minimum, maximum, and 95% confidence intervals for each dependent variable) and Homogeneity of variance test that calculates the Levene statistic to test for the equality of variances. 

Contrasts enable you to specify contrasts that you want tested by the t statistic. 

(Ref –Contrasts section)
Example

You can determine if the means of the lung capacity of different groups of smoker types (non-smoker, light-smoker, medium-smoker, and heavy-smoker) vary. The following data file lists forced expiratory flow measurements under the variable FEF and the corresponding group type (non-smoker=0, light-smoker=1, medium-smoker=2, heavy-smoker=3) under Groups.
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Select Analyze-> Compare Means-> One Way ANOVA
Click the FEF variable then select the upper right arrow to move it into the Dependent Variables textbox. 
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Select the Group variable and click the lower right arrow button to place into the Factor textbox.
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Click OK.
PSPP displays the results in the output viewer.
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Contrast
Contrast is a weighted sum of the means that allows you to test your research hypothesis as opposed to the statistical hypothesis.
Example
You might want to see if the mean lung capacity of non-smokers varies from smokers, independent of how many they smoke. There are four different groups, of which three are smokers of different intensities. This means the non-smoking group should have a mean with a weighting of unity and the others a weighting of one-third.

Select Contrasts on the One-Way ANOVA dialogue box.
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Enter 1.0 in the Coefficients textbox and then click the Add button.
Add the values -0.333, -0.333, and -0.334 to the coefficients list.
[image: image66.jpg]@ One-Way ANOVA: Contrasts. ]

Contrast Lof 1

Continue
4uBack & Forward
Coefficients:

A 1000000
——— | 033000 X coneel
£
L -0.333000
-0.334000

Coefficient Total: [0 pe





Press Continue to close the Contrasts dialogue box.
Press OK on the One-Way ANOVA dialogue box.

PSPP displays the results in the output viewer.
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Bivariate Correlation

Computes Pearson’s correlation coefficient, a number between -1 and 1 that indicates the degree of association between variables. A positive value indicates that large values of one variable are associated with large values of the other and likewise, small values of one variable are associated with small values of the other. A negative value means that large values of one variable are associated with small values of the other and vise versa. 
Example
You can use this feature to see if there is a correlation between ice cream sales and outside temperature. 

Open a new data file and enter the following data listing the number of ice cream cones sold per day at a particular store along with the corresponding daytime high temperature in degrees Fahrenheit for that day.
Number of       Temperature
 Cones Sold     (Fahrenheit) 

  171.00
   76.00

  161.00
   71.00

  156.00
   66.00

  151.00
   61.00

  154.00
   73.00

  143.00
   61.00

  146.00
   64.00

  157.00
   69.00

  171.00
   78.00

  173.00
   78.00

  166.00
   76.00

  168.00
   76.00

  176.00
   81.00

  181.00
   83.00

  181.00
   86.00

  144.00
   60.00

  174.00
   87.00

  177.00
   89.00

  178.00
   86.00

  186.00
   91.00

  164.00
   75.00

  161.00
   74.00

  163.00
   72.00

  149.00
   69.00

  161.00
   71.00

  155.00
   74.00

  170.00
   86.00

  179.00
   91.00

  176.00
   71.00

  165.00
   82.00
Select Analyze-> Bivariate Correlation to bring up the Bivariate Correlation dialogue box.
Select Cones and click the right arrow button to place it into the right textbox.
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Repeat with the Temperature variable.

Click OK.

PSPP displays the results in the output viewer.
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Factor Analysis

Aides in the identification of underlying variables, or factors that explain correlations. Variables should be either interval or ratio, and not categorical. PSPP assumes the data has a nearly bivariate normal distribution for each pair of variables and that observations are independent. 
Factor Analysis Dialogue Box
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Extraction Dialogue Box
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Method enables you to choose the method of factor extraction. Options include Principal Components Analysis and Principal Axis Factoring.

Principal Components Analysis

Used when a correlation matrix is singular, this function assembles uncorrelated linear combinations of the observed variables such that each successive component explains a progressively smaller portion of the variance.
Principal Axis Factoring

An iterative procedure that extracts and replaces factors from the current correlation matrix with new estimates until the convergence criterion for extraction is satisfied. 
Analyse 

This feature enables you to choose either a correlation or covariance matrix.

Display

You can display the unrotated factor solution and Scree plot with this option.

Unrotated Factor Solution
Displays the unrotated factor loadings, communalities, and eigenvalues for the solution.

Scree Plot

A plot of the variance for each factor. 

Extract

Specify to keep factors whose eigenvalues exceed a specified factor above the mean eigenvalue, or choose a specific number of factors to keep.
Maximum Iterations for Convergence

Specify the maximum number of steps the algorithm can take to estimate the solution.
Rotation Dialogue Box
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Method

Enables you to choose the type of factor rotation method. Options include none, varimax, quartimax, and equimax.

Varimax
An orthogonal rotation of the factor axes which has the effect of differentiating the original variables by the extracted factor. This solution provides results that make it easier to identify each variable with a single factor.
Quartimax

An orthogonal rotation that minimizes the number of factors needed to explain in each variable.

Equimax

A combination of the varimax and quartimax rotations.
Display Rotated Solution

If you pick a rotation method, you can choose to display the solution with this option.

Maximum iterations for convergence
You can choose the maximum number of steps the algorithm can take to reach convergence. The default value is 25. 

Example

You can perform factor analysis on the following survey results to try to determine the leading factors that drive people to purchase specific brands of bread. 
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Enter the data in figure x. (or ask if can provide data for download)

Select Analyze-> Factor Analysis to bring up Factor Analysis dialogue box.

Click the first variable, Reputation, and then the right arrow to place it in the Variables dialogue box.
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Repeat with all the other variables until no more remain on the left side.
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Click the Extraction button.
Select the Principal Components Analysis method.

Select the Correlation matrix option under Analyse.

Select Unrotated factor solution and Scree plot under Display.

Click Continue to close this dialogue box.

Select the Rotations button the Factor Analysis dialogue box.

Select the Varimax option under Method.
Select Display rotated solution.

Click Continue to close the dialogue box.

Click the OK button on the Factor Analysis dialogue box.
PSPP displays the results in the output viewer.
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Reliability

Estimate the internal consistency reliability. Options include Chronbach’s Alpha and Split-half reliability. 
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Split-Half Reliability

An estimation based on the correlation of two equivalent forms of the scale. This is essentially a three-step process. Randomly divide all items that measure the same construct into two sets. Next, administer the whole instrument and divide the total score for each item in half. Then, estimate the split-half reliability by calculating the correlation of these two sets. 
Cronbach’s Alpha

This estimation is equivalent to the average of all possible split-half estimates, and is an indication of the correlation among the variables. 
Example
You can examine the internal reliability of the following pass-fail test data, where 0 represents fail. 
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Enter the test data into a new data file. (Note – not sure may provide data)

Select Analyze-> Reliability.

Click the first variable and select the right arrow to move it into the items textbox.
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Repeat with the other variables until they are all in the items text box.
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Click OK.

The results display a Cronbach’s Alpha of 0.61 indicating the internal consistency is questionable.
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Linear Regression 

Non-functional, at least in the version I have.
Non-Parametric Statistics

Provide Chi-Square and Binomial statistics for an arbitrary distribution of data.
Test the differences between the observed and expected distribution of a sample. You can also use this to test the difference between two or more samples.
Binomial

Compare the observed frequencies of dichotomous data to the expected values from the binomial distribution. The primary purpose of this test is to observe if the number of outcomes for each variable differs. For example, you can verify a fair coin by comparing the frequency of heads and tails in coin tosses.

Example
 The following data lists the temperature at which customers visiting a local gourmet coffee and tea shop prefer to drink their beverage on a day when the outside temperature is 70(degrees) Fahrenheit, where they are given a choice of cold(ice), luke warm, warm, or hot. The HotCold variable is dichotomous with a value of 0 if the customer prefers cold and 1 if they want their drink heated in any way. In the next column, the variable Range varies from 0 to 3 indicating the temperature range of the drink, where 0=cold, 1=luke warm, 2=warm, and 3= hot. 
(Note data might be downloadable)
HotCold   Range
     .00
     .00

     .00
     .00

    1.00
    2.00

    1.00
    2.00

     .00
     .00

    1.00
    1.00

    1.00
    1.00

    1.00
    1.00

    1.00
    2.00

    1.00
    1.00

    1.00
    3.00

    1.00
    3.00

    1.00
    2.00

     .00
     .00

     .00
     .00

     .00
     .00
    1.00
    1.00

     .00
     .00

     .00
     .00

    1.00
    2.00

    1.00
    2.00

     .00
     .00

    1.00
    3.00

     .00
     .00
Enter the data into a data file.

Start by examining the dichotomous data.

Select Analyze->Non-Parametric Statistics->Binomial.
Select HotCold and click the right arrow to place it in the Test Variable List.
Verify Test proportion is 0.5.

Verify Get from data is selected under Define Dichotomy.
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Click OK.
PSPP displays the statistics in the output viewer.
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Next, examine the temperature ranges of the drinks.
Select Analyze->Non-Parametric Statistics->Chi-Square.
Select the Range variable then click the right arrow to place it into the Test Variable List.
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Verify that All categories equal is selected under Expected Values.

Verify that the Get from data option under Expected Range is selected.

Click OK.
PSPP displays the statistics in the output viewer.
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ROC Curve
Use this option to analyze binary classification systems. Examples of binary classification schemes include passing or failing newly made items during an inspection, or labeling patients to be either with or without a medical problem. The Roc Curve function returns an ROC curve with the option to display a diagonal reference line, standard error and confidence interval, as well as the coordinate points. 
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ROC Curve

This is a plot of one classification rate from a binary classification scheme versus the other as the criterion changes. For example, you can plot the true positive rate versus the false positive rate for a disease as the threshold value between these two classifications varies. 
With a diagonal reference line

Select this option to display a diagonal reference line across the graph. An ROC curve that coincides with this line indicates that the distribution of each classification group are the same. 

Test Variable
Continuous numerical data holding the test results.

Classification Variable

A binary variable with one of two possible values, typically 0 or 1.

Standard Error and Confidence Interval

Display the standard error, confidence interval, and area in a separate table. The value of the area ranges from 0 to 1, where 1 indicates the distributions of each classification group do not overlap and 0.5 means both distributions are the same.
Example

You can plot an ROC curve data listing the test data, patients ages, under the Age variable and the corresponding classification variable under disease which takes on the value 0 if they do not have a certain medical condition and 1 otherwise.
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Select Analyze-> ROC Curve
Select Age and click the upper right arrow to move it into the Test Variable box.

Select Disease and click the lower right arrow to move it into the State Variable box

Select all the check boxes under Display.

Enter the number 1 in the Value of state variable box.
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Click OK.

PSPP displays the ROC curve and accompanying tables in the output viewer.
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Utilities
Variables

Provides the following variable information:
(put link to other section describing variables in more detail)

Variable Name

Variable Label

Data Format
User-missing values

Measurement Level

Value Labels
You can also jump to a selected variable in the data file by selecting the variable and clicking the Jump to button on the dialogue box.
Example
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Select a variable in the left column to view the information.
Data File Comments

This feature enables you to add comments to a data file. 

Display comments in output
Enables you to display comments in the output viewer.

Reset

Clears the current comment.
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Windows

Minimize All Windows

Collapses all windows.  Click the PSPP icon on the tool bar to view them again.

Split

Splits the current data editor window.
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Help

Reference Manual

About

All the toolbar functions have been described elsewhere so provide links/refs to other pages

PSPP provides a tool bar with short cuts to commonly used menu commands including:

Open

Save

Go To Case

Variables

Find 

Insert Cases

Insert Variable

Split File

Weight Cases

Value Labels

