Inserted at Beginning of  Texinfo file, then Followed By Main Menu File

This chapter provides a description of the graphical user interface.

Introduction to the Graphical User Interface

The PSPP graphical user interface provides a set of windows through which you store, edit and analyze data. You can choose to perform tasks and operations through interactive drop down menus in the data editor window or through command line statements entered in the syntax editor. The three primary windows include the Data Editor, Syntax Editor, and the Output Viewer. 
Primary PSPP Windows
Data Editor
The data editor window is central to PSPP and launches when you start a session. This window is similar in organization to a spreadsheet, where data is stored and edited in columns and rows of cells. 
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Syntax Editor
The syntax editor window is where you can enter command line instructions to edit, import and analyze data. This has the advantage of enabling batch processing and code reuse. Launch the syntax editor from the data editor window by selecting File->Open->Syntax.
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Output Viewer

A window that displays any instructions executed as well as the results of any statistical analyses including, text, tables, and charts. Note: this window is not visible upon start up and only pops open after an instruction set has been executed.
Data Editor Window
There are two alternate views: emph{data view} and emph{variable view}. Data view shows the numerical value held by each datum while the other displays the metadictionary data of each variable. Toggle between views by clicking on the emph{Data View} or emph{Variable View} tab at the bottom left hand corner of the window.
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Data View

A specified layout is used where rows represent cases and columns measured variables, e.g., in the hotel customer satisfaction survey (see figure x.) each row represents the set of answers given by each respondent and each column represents one question. 

Data View of a Hotel Customer Satisfaction Survey
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Variable View
Display the variable attributes associated with each case, where the variable attributes (see section x) include name, type, width, decimal, variable label, value label, missing values, columns, align, and measurement. 
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Variable Attributes
(Elsewhere I have referenced the current manual where needed but with this section describing variable attributes I have reprinted the descriptions from the current manual, in the order presented in the data editor window.  The definitions are relevant to the data editor window so I thought perhaps they could be reprinted in this section as it might otherwise prove awkward to the reader since it’s going to be a linear pdf document.)

Name 

A name is an identifier, up to 64 bytes long. Each variable must have a different name.

Some system variable names begin with ‘$’, but user-defined variable names may not begin with ‘$’.

The final character in a variable name should not be ‘.’, because such an identifier will be misinterpreted when it is the final token on a line: FOO. will be divided into two separate tokens, ‘FOO’ and ‘.’, indicating end-of-command.  
The final character in a variable name should not be ‘_’, because some such identifiers are used for special purposes by PSPP procedures.

As with all PSPP identifiers, variable names are not case-sensitive. PSPP capitalizes variable names on output in the same way you define the variable. 
Type 

Numeric or string.
Width 

This is for string variables only. String variables with a width of 8 characters or fewer are called short string variables. Short string variables are used in many procedures where long string variables (those with widths greater than 8) are not allowed.

Certain systems may consider strings longer than 8 characters to be short strings. Eight characters is the minimum figure for the maximum length of a short string. 
Decimal

An optional parameter used for input and output formats that gives the number of decimal places, and has the value zero if not set.
Variable label

A string that describes the variable.

Value label

These are optional and associate each possible value of the variable with a string.

Missing values

These are optional and up to three values, or a range of values, or a specific value plus a range, can define user-missing values. PSPP assigns a system-missing value to an observation when there is no other obvious value for that observation. Observations with missing values are not included in analyses.  User-missing values are actual data values, while the system-missing value is not a value at all.

Columns
A parameter used for input and output formats that specifies the field width in columns.

Measurement 

States whether the measurement level is nominal, ordinal, or scale. 
Data Entry and Editing
New Variable

Enter a new variable by selecting emph{insert variable} from the emph{edit} drop down menu or tool bar. This function inserts a new variable with a generic name. In addition, if you already have at least one variable defined, then you can add a new variable to the left of the current column by right clicking on the variable’s title and selecting insert variable from the pop-up menu. 
[image: image6.jpg]@ hotel.sav0 — PSPPIRE Data Editor = W T
File Edit View Data Transform Analyze |
= = Es) o

Open Save Go To Case  Variz

rjpert Variable

2 Clear Variables





Edit Variable Attributes

You can edit variable attributes such as Name, Type, Width, Decimals, Label, and Values, Missing, Columns, Align, and Measure move in variable view.
Name
Click a cell in the emph{Name}column. 

Type a new name in the cell. 

Press the enter key.
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Type

Click a cell in the emph{Type} column.

Click on the grey box that appears to bring up a Variable Type dialogue box.
Choose a variable type (see @ref {needNode}) from the list: Numeric, Comma, Dot, Scientific Notation, Date, Dollar, Custom Currency, and String.

Enter the width and/or number of decimal places, if relevant.

Press OK.
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Width
Click a cell in the emph{Width}}(see @ref{needNode}) column.
 Select the up-down arrow that appears inside the cell to alter the value.
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Decimals 
Click a cell in the emph{Decimals}(see @ref{needNode}) column.

Select the up-down arrow that appears inside the cell to alter the value.
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Label
Click a cell in the Label column.

Type a variable label in the cell.
Press enter.
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Values

Click a cell in the emph{Values}(see @ref{nodeNeed}) column.

Click the gray box that appears inside the cell to bring up the emph{Value Labels} dialogue box.
Enter the Value label.

Click the Add Button.

Repeat to add other labels, if necessary.

Press OK.
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Missing

Select a cell in the emph{Missing} column.

Click the gray box that appears inside the cell to bring up the emph{Missing Values} dialogue box. 
Enter either up to three discrete missing values or specify a numerical range plus one discrete value. See @ref{needNode} for further information.

Press OK. 
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Columns

Select a cell in the emph{Columns} (see also @ref{nodeNeed}) column.

Click the up-down arrows that appears inside the cell to alter the value. 
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Align

Align values left, right or center in a cell. 
Click a cell in the emph{Align} column.
Select left, right, or center from the drop down menu that appears.
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Measure

Select a cell in the column emph{Measure} (see @ref{needNode}).
Select either nominal, ordinal, or scale from the drop down menu.
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New Case
There are a few ways to add a new case to an existing variable: 

             Select Edit->Insert Case from the drop down menu.

             Select emph{Insert Cases} from the toolbar.

             Right click on the row number above the insertion point to bring up a pop menu, and select emph{Insert Cases}.
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Read Variable Label in Data View

Hover the mouse over the variable’s name at the top of the column to view its label.
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Change Data Value
Switch to data view, if you are not there already.

Select the cell you want to change.

Type the new value.

Press enter.

Select a Whole Row or Column

Right click on the column title or row number to select the entire column or row, respectively. 
Clear Variables
There are a couple of ways to clear columns.
In data view: 
bullet:

              bullet      Right click on the variable name at the top of the column.

              Bullet        Select emph{Clear Variables} from the pop-up menu.

bullet

              bullet        Right click on the column to select it.

             Bullet        Select Edit->Clear Variables from the drop down menu.

In variable view:

Bullet     Right click on the number title to the left of the row.

 Bullet   Select emph{Clear Variables} from the pop-up menu.
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Clear Cases

There are a couple of ways to clear cases.
bullet:

              bullet      Right click on the row number to the left of  the row.

              Bullet        Select emph{Clear Cases} from the pop-up menu.

bullet

              bullet        Right click on the row number to the left of  the row.

             Bullet        Select Edit->Clear Cases from the drop down menu.
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Sort Cases

There are two alternative ways to sort cases.
Right click on the variable title and select emph{Ascending} or emph{Descending} from the pop-up menu.

Right click on the variable title and select Data->Sort Cases (see @ref{needNode}).  
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Status Bar

Located at the bottom of the data editor window, provides information about the data under process.  
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Filter Status

Turns on when you filter a subset of cases in the current file for analysis.
@comment (Note appears non functional right now)

Weight Status

States the variable you are weighting the data against in the analysis. 

Split File Status

Indicates there are separate data into groups.

Output Viewer

The output viewer displays results, charts, and the instruction set executed, whether invoked from a menu command or the syntax window.
//////////////////////////////////////////////////////////////////////////
redo

Note: The output viewer is not visible when PSPP loads, and appears upon execution of the first set of instructions.
Examples
Output viewer displays the last set of instructions executed.

1)
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2)
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redo
The right pane of the output viewer displays results such as tables, text, and charts. The left pane gives a corresponding outline.

Example
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Save Output Viewer Contents

To save the results in the output viewer select File->Export. File types include PDF, HTML, Open Document, Text, and Postscript. 

Syntax Editor Window

redo

Use the Syntax Editor window to enter command line instructions. For syntax and rules (see @ref{needNode}).
redo
Enter commands into the syntax window and then execute them by selecting run from the menu. The instruction set can optionally be saved for later reuse. For example, the following set of commands populates the data editor with a list of random numbers.
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Enter Syntax
redo
Most data-editor-menu functions enable you to paste the command line equivalent to that function directly into a syntax window from within the function’s dialogue box, by selecting the paste button.
Example

Place a command line instruction that generates descriptive statistics in the syntax editor window.

Open file xxx.sav.

Select Analyze -> Descriptive Statistics -> Descriptives (refer to section x)
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   Select emph{variables and statistics} in the emph{Descriptives} dialogue box.
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 redo
Click the Paste button to insert the command line equivalent into the syntax editor.
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Run 

Select run to execute code in the syntax window.

             Options include:

                              Run->All           Execute all commands.
                              Run->Selection Execute highlighted commands.

                              Run->Current Line Execute a single line at current cursor position. 

                              Run->To End Execute at cursor position onwards.
Save
redo
Save a set of commands by selecting emph{Save} in the emph{File} drop down menu. 
Example  (Leave this out for now)
1) Select File->New Syntax File in the Data Editor Window to bring up a syntax editor window.

2) Enter the following text into the window, and place the lines following the ONEWAY command at one tab stop position from the beginning of the line.

[image: image30.png][DATA LIST NOTABLE LIST /QUALITY * BRAND * -
BEGIN DATA

73
b 3
51
21
b1
b 2
22
52
53
L1
b1
5 2
22
53
3

END DATA

/ARIABLE LABELS brand 'Manufacturer'.
/ARIABLE LABELS quality 'Breaking Strain'.

/ALUE LABELS fbrand 1 Aspeger 2 'Bloggs' 3 ‘Charlies'.

oNEWAY
quality BY brand
JSTATISTICS descriptives homogeneity
JCONTRAST= -211
JCONTRAST=0-11





1) Execute the statements by selecting Run->All from the drop down menu. 
The output viewer window displays the results.
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2) Save the file by selecting File->Save As.

Redo Main Menu Overview
Redo also need to sandwich subheadings of list into menu or table with strong word 
Perform tasks and operations on data with functions available through the drop down menus and toolbar. See also @ref{nodeNeed}.

File

Perform all file handling operations such opening, closing and saving files.

Edit

redo

Move data and text around with cut, copy, and paste operations. In addition, can use to insert data and cases and perform searches. 

View

redo

Use to change fonts, display extra information such as a status bar and value labels, and toggle between emph{data} and emph{variable} view. 

Data

redo

Perform operations on data sets, such as sort, transpose, apply weights, extract subsets of cases, and split files.

Transform

redo

Replace select data with the result of applying mathematical or other operations on it. 

Analyze

Perform statistical analyses on the data.   

Utilities

Redo
Use to insert comments and view summary information of each variable.

Windows

Use to toggle between open windows, split and minimize them.

Help

Provide help contents.

Main Menu 

File

New

            Open a new data or syntax file. (ref data syntax sections)

Open

            Open data, syntax, system, or portable files.   (ref data syntax sections)

Import Delimited Text Data
            Import all or part of a delimited text data file into the data editor. 

A series of dialogue boxes guides you through this process as follows:

Importing Textual Data Dialogue Box
redo
Import all or part of the file. 
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First Line of Data Dialogue

redo
Select the first line of data.
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Choose Separators Dialogue

redo
Choose from a choice of delimiters. Options include:

Space

Colon

Pipe

Tab

Comma

Semicolon

Bang

Hyphen

Slash

Custom Separator

Redo (removed the custom sentence might not be there was title)
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Adjust Variable Formats

redo
Verify and edit variable attributes (see @ref{needNode}).
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redo

Select the emph{Apply} button to import the data.

Save

               Save the current file.

Save As

               Save the current file with a name and location of your choosing. 

Display Data File Information

              Working File

                           Display the dictionary of the currently opened file.

                 Example
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                  External File

                       Display the dictionary of a data file that is not yet open. 

Recently Used Data

                   Links to recently used data files.  

Recently Used Files

                Links to recently used syntax files.  

Quit

                 Close the current data file and shutdown PSPP. 

Edit

Insert Variable

                Insert a new variable in data view to the left of the current column. The editor fills in system-missing values for all cases as a placeholder. By default, PSPP inserts a numerical variable type.  Redo See also @ref{needNode}.

Example

Select Edit->Insert Variable to enter a new variable. 
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Insert Cases
Insert a new case in the selected row if it is empty, or, above otherwise.   

Go To Case

                Jump to the selected case number.               

Cut 

               Remove the selected text and place it elsewhere by selecting paste at the desired insertion point. 

Copy

              Copies text onto the clipboard. Highlight the text and then select Edit->Copy.

place it elsewhere by selecting paste at the desired insertion point. 

Paste 

              Places the contents stored on the clipboard at the insertion point. 

Find

Look for a case.

View

Status Bar

       redo        Turn the status bar on or off.  See @ref{needNode} for further information.
Font

              View and edit the current font settings. 

Grid Lines

redo              Make the grid lines in the data editor window visible or invisible. 

Value Labels

             Show the value label associated with each result in data view.

Example

The data editor window on the right displays the value labels of the numerical survey data displayed in the window to the left. 
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Variables

Switch the data editor between data and variable view.

Data

Sort Cases

Sort cases in ascending or descending order based on one or more variables. 

Transpose

            Switch rows and columns on data that is in the reverse order to the PSPP file format. The standard file format lists cases in rows and variables in columns.

 (ref data editor section)

Split File

           Split data into groups using grouping variables. If you select more than one grouping variable then you need to nest each successive category within the previous one. 

redo
Note: Cases should be sorted with the emph{Sort Cases} command first such that they are in the same order as the grouping variables listed under the emph{Groups based on}textbox.
           Split File Dialog Box
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Example -Split File

Group a file with physiology data according to height.

The physiology data file.
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Open the file xxx.sav.

1) Select Data->Split File.

2) Select the emph{Compare groups}radio button in the pop up window.

3) Click emph{Height in millimeters} to highlight the variable.
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4) Select the arrow to the left of the emph{Groups based on} textbox to move the emph{height} variable inside that textbox. 

5) Click OK to see the view in the output viewer.

An output viewer pops up with result.
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           Compare groups

           

Show split-file group output along side each other. For example, the output viewer displays a chart for each group in a single window.

           Organize output by groups

           Show results for each split-file group separately. 

           Example

Using a data file containing physiology data, the file is grouped based on emph{height} using the Split File menu command. 
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1) Select Data->Split File.

2) Select the Compare Groups radio button in the dialogue box.

3)  Select emph{height} in millimeters.
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4) Press the right arrow.

5) Hit OK.

Select Cases

              Seems non-operational.

Weight Cases

           

 Assign weights to variables. Note that cases with a zero, negative, or missing value for the weighting variable are not included in the analysis.

Transform

Compute

            
Perform operations on numeric and string data columns with inbuilt functions. You can compute new variables or replace existing ones.

Example

Compute the absolute difference in weight before and after participants followed a particular diet plan from the following study.
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Select Transform->Compute from the drop-down menu to bring up a Compute Variable dialogue box.
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Enter  emph{weight_change} in the Target Variable textbox and click the Type & Label button below it; This variable holds the result of the calculation. The Type and Label dialogue box pops up, which allows you to select the properties of the variable.
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Select the Label radio button, and then enter “weight change in kilograms”.

Press Continue.

Select the ABS(number) function from the list of functions and then press the up arrow. This places the function up in the Numeric Expressions text box. 

Select  emph{weight_after} from the list of variables located on the left of the dialog box. Note: when you hover the mouse over the list of variables this brings up their names.
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Click in between the parenthesis of the function. 

Click the right arrow to the left of the Numerical Expressions text box. ABS(weight_after) is now displayed in the Numeric Expressions textbox.

Delete the question mark if it is still present in the ABS arguments. 

Enter a space followed by a minus sign after emph{weight_after}, as follows: ABS(weight_after - )

Select emph{weight_before} variable from the list of variables located on the left side of the Compute Variable dialog box.

Place the cursor after the minus sign of the expression. 

Click the right arrow.
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Click OK.

PSPP adds the result to your data file.
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Rank Cases

The Rank cases component creates new variables that hold the ranks, Savage and Normal scores, and percentile values for numeric variables in the current data file. PSPP automatically names and labels these new variables indicating the original variable name and selected measures. 
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Assign rank 1 to the smallest value for ascending order or the largest value for descending.

Rank numerical variables by moving them into the Variables textbox.

Organize rankings into subgroups by moving one or more variables into the By textbox. For example, if you select emph{gender} and emph{height} then PSPP calculates ranks for each combination of gender and height.

Rank Types

Select different rank types by clicking on the Rank types Button towards the bottom of the Rank Cases dialogue box. 

The Rank Cases Types dialogue box pops up.
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Rank 
        The value of the new variable is its rank.

Savage Score

        Returns the savage score taken from an exponential distribution. 

Fractional Rank

         Returns the rank divided by the sum of the weights.

Fractional Rank as a Percent

           Returns the rank divided by the number of cases as a percent.

 Sum of Case Weights

           Return the sum of the case weights.

Ntiles

           Returns a rank based on the percentile group. The size of each percentile group is given by 100/Ntile. If Ntile=4, then rank 1 corresponds to the 1st 25th percentile, rank 2 to cases between the 25th and 50th percentile, rank 3 to cases between the 50th and 75th percentile and rank 4 to the last percentile group.

Proportion estimates

             Return estimates of the cumulative proportion of the distribution corresponding to a specific rank.

Normal scores

              Returns the z scores corresponding to the estimated cumulative proportion. You can choose from a range of proportion estimate formulae to apply when calculating proportion estimates and normal scores.  Options include Blom, Tukey, Rankit, or Van der Waerden.
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Blom

            The ranking variable is based on proportion estimates which employ the formula (r - 3/8)/(w+ ¼), where w is the sum of the case weights and r is the rank.

Tukey

           Applies the formula (r - 1/3)/(w + 1/3), where r is the rank and w is the sum of the case weights.

Rankit

        Applies the formula (r – ½) / w, where w is the number of observations and r is the rank, ranging from 1 to w.

Van der Waerden

        Returns Van der Waerden’s transformation, given by the formula r/(w+1), where w is the sum of the case weights and r is the rank, ranging from 1 to w.

Ties

The Ties dialog box allows you to select the method for assigning rankings to cases with the same value on the original variable. 
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Recode into Same Variables

Recode different values of the same type (numeric or string) into a variable. 

There are two options available: 1) change a single value to a new one or 2) change a range of values to a category.

Example 1

Change a single value.

Change the value of 12 miles-per-gallon (MPG) to 13 MPG in the following data set.
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Select Transform->Recode into Same Variables. A Recode dialogue box appears.
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Select emph{Miles Per Gallon} and click the right arrow to move the variable into the Variables textbox.

Click the emph{Old and New Values} button to bring up its dialogue box.
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Type the number 12 in the Value text box under Old Value on the left side.

Type the number 13 in the Value text box under New Value on the right side.
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Click the Add button. The number 12 now appears under old and 12 under new.
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Press Continue. The Old and New Values dialogue box disappears.

Select OK on the Recode into Same Variable dialogue box.

The value 12 MPG is now 13 MPG.

Example 2

Collapse a Range of Values into a Category

The automobile data set has mile-per-gallon values that range from 13 to 41 MGH. 

· Split the range of values into categories as follows:

1. If emph{Miles Per Gallon} is less than 19 MPG then give it a value of one.

2. If emph{Miles Per Gallon} is greater than or equal to 19 MPG and less than 24 then give it a value of 2.

3. If emph{Miles Per Gallon} is greater or equal to 24 then give it a value of three.

· Select Transform->Recode into Same Variables

Select the emph{range LOWEST thru value} radio button, and enter 18.

Enter the number 1 in the value field under emph{New Value} on the right side of the dialogue box.

Click the Add button, to get the “LOWEST-18” listed under old and “1” under new.

· Repeat with the other value ranges.

· Select the range-through radio button and enter 19 in the first text box and 23 in the second.

· Enter the number 2 in the value text box under New Value, and click the Add button.

· Select the range thru HIGHEST radio button and enter 24.

           Enter the number 3 in the value text box under New Value, and click the Add button.
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Click Continue. The Old and New Values dialogue box disappears.

Click OK on the Recode into New Variables dialogue box to put the new values into the MPG variable column.
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Recode Into Different Variables
Enables you to change data values and save into a new variable. There are two opt

ions available; change a single value to a new one or change a range of values t

o a category. Note, that the new variable type must be the same as the original;

 numeric or string.
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Run Pending Transforms

Get back to – haven’t found more info about

Analyze

Descriptive Statistics

Statistics

Central Tendency

A measure of the central position of a set of data. 

Mean

        Average value, or first moment (see definition below), defined as sum of all data within a set divided by the number of cases in the set. Note: the mean is susceptible to outlying values, e.g., the average temperature over a month in a region that has had a few unusually hot days will be higher than usual. 

Note: Moments are the sums of integer powers of the values, where a higher integer power corresponds to a higher moment e.g. the variance is the second moment, skewness the third, and kurtosis the fourth. 

       Median

       The central value of an ordered set of numbers. In other words, 50% of the values fall above or below it. When the number of data values is even the median is the average of the middle two. The median is not as susceptible to outlying values as the mean.

Mode

Most frequently occurring value.  Note that there can be more than one mode in a data set.

Sum

The addition of all values across the different cases excluding missing ones.

Dispersion

A measure of the spread or variation in data values about the mean.

Standard deviation

A measure of the spread in values about the mean equal to the square root of the sum of the squares of the difference between each value and the mean, for all values, divided by one less than the number of cases. 

Variance

The standard deviation squared, or the second moment.

Range

The difference between the largest and smallest numerical values in the set.

Minimum

The smallest numerical value in the set.

Maximum

The largest numerical value in the set.

S. E. mean

The standard error of the mean is a measure of by how much the value of the mean varies with different samples from the same distribution.

Distribution

Statistics that describe the shape and symmetry of a distribution. 

Skewness

A measure of the asymmetry of a distribution. You can calculate this by taking the third moment (proportional to the sum of the cube of the difference of each data value and the mean). Note that unlike the mean and variance the definition is such as to make it a dimensionless quantity, and this pure number characterizes the shape of the distribution.  Positive values indicate the distribution has a more heavily pronounced right tail, while negative values indicate a more prominent left one. When both tails are equal the skewness is zero.

Kurtosis

A measure of the relative peakedness or flatness compared to a normal distribution. You can calculate this by taking the fourth moment (proportional to the sum of the fourth power of the difference of each data value and the mean). Like the skewness, this is also a dimensionless quantity. A distribution with negative kurtosis is termed leptokurtic, while a distribution with a positive value as platykurtic, and an in-between one is termed mesorkurtic.

Frequencies

The frequencies dialogue box enables you to generate statistics including central tendency (mean, median, mode, and sum), dispersion (standard deviation, variances, range, minimum, maximum, standard error of the mean) and distribution (skewness and kurtosis). Optionally, you can also view frequency tables and charts.

Frequencies Dialogue Box
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The frequencies dialogue box lists all variables along the left side. In order to perform statistical analyses or plot charts of select variables you need to move them into the Variables dialogue box. To do this, first, click on the variable until it is highlighted and then select the right arrow.
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Frequency Tables Dialogue Box
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You can turn the option to display frequency tables on or off, as well as choose in what way to order the tables; ascending or descending value or ascending or descending frequency.

Charts Dialogue Box
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You can plot histograms or pie charts with the Chart Dialogue box.

Histogram options include scaling with either frequencies or percentages and superimposing a normal curve.

Pie charts come with the option to include slices for missing values.

Example:

(Note histogram plot with percentages seems to be non functional)

Analyze the extent to which hotel customers were satisfied with the level of service in the following survey. 
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Select Analyze-> Descriptive Statistics-> Frequencies to bring up the Frequencies dialogue box.

Select the first variable from the list on the left side then click the right arrow to mover it inside the Variables dialogue box.
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Select the charts button to bring up the Charts dialogue box.

Select Draw Histograms and press Continue to close this dialogue box.
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Select mode from the statistics options in the Frequencies dialogue box.
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​

Press OK. 

PSPP displays the results in the output viewer.
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Descriptives

Display univariate summary statistics and z scores. Statistics include central tendency (mean), dispersion (standard deviation, variance, range, minimum, maximum, and standard error of the mean), and distribution (kurtosis and skewness).

A z score is a dimensionless variable that classifies how many standard deviations a value is from the mean. Also known as standardizing or normalizing. Based on normal theory, these are best for quantitative variables with symmetrical distributions. Note, if the distribution is skewed the z scores will be as well.

Example

First, make relevant data with the syntax editor. Write a small program to generate normally distributed numbers that represent SAT test scores with a mean of 500 and standard deviation of 110.

Select File->New->Syntax to open a syntax window.

Enter the following command lines in the syntax window.
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Select Run->All to execute the program. This populates the data editor with random numbers drawn from a normal distribution.
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Next, calculate the z scores using the Descriptives menu command.

Select Analyze->Descriptive Statistics->Descriptives to bring up the Descriptives dialogue box.

Select the emph{newvar} variable by clicking on it in the variables list to the left of the dialogue box, and then by clicking the right arrow to move it into the Variables textbox.

Select the “save Z scores of selected variables as new variables” check box.

Click OK to generate a list of z scores under the new variable in the data editor window.
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Explore

Provides descriptive statistics including percentiles and extremes, and in addition, enables you to examine subgroups of data.

Descriptive statistics include the mean, median, variance, standard deviation, minimum, maximum, range, skewness, and kurtosis.

Example

You can generate descriptive statistics of the following data set of SAT test scores and gender for all participants, or you can break it down into subgroups and do a separate analysis for each gender type.
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Start by looking at all test scores independent of gender.

Select Analyze-> Descriptive Statistics-> Explore to open the Explore dialogue box.
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Select Score and press the right arrow button next to the emph{Dependent List} box. 

Click the Statistics button at the bottom left side of the dialogue box to bring up the statistics pop-up box.

Select the Descriptives and Extremes check boxes, and then press continue. 
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Press OK on the Explore dialogue box to display the results in the output editor.
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Repeat the analysis, examining each gender group separately, where 0 represents a male.

Select Analyze->Descriptive Statistics->Explore to open the Explore dialogue box.

Select emph{Score} and press the right arrow button beside the Dependent List textbox.

Select emph{Gender} and press the right arrow button beside the Factor List textbox. 
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Press the Statistics button at the bottom of the Explore dialogue box.

Select the Descriptives and Extremes check boxes and then press the continue button.

Press OK on the Explore dialogue box.

The output viewer lists different statistics for each group. For example, the lowest and highest test scores are 182.98 and 835.52, respectively, for the males, and, 179.03 and 805.10 for the female group.
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Crosstabs

Examine bivariate relationships through cross tabulation. This tool is useful for determining if one variable is dependent upon another, e.g.,  in a customer satisfaction survey you might discover a dependency of customer satisfaction levels on price.

Statistics and measures of association

Chi-square
Use Pearson’s Chi-Square test if the frequency in each cell is at least five; when the frequency is less than five, and the contingency table is 2 x 2 in size then Fishers exact test is performed. When both variables are quantitative, this function also returns a linear-by-linear association test. 

Correlations

 Return Spearman’s correlation coefficient and rho for numeric data when the values in the rows and columns are ordered. When both variables are quantitative returns the Pearson’s R. 
             When tables contain only ordered values in the rows and columns Correlations returns Spearman’s correlation coefficient and rho for numeric data. When both variables are quantitative Correlations returns the Pearson’s R. 

Nominal Data

You can measure the degree of association with several coefficients.

***************************************************************
Phi

A measure of association that returns the square root of the chi-square coefficient divided by the sample size. Typically, you apply this to 2 x 2 tables, although, it can handle larger sizes. For 2 x 2 tables phi is identical to the correlation coefficient, but for larger ones the interpretation can be more complex.

Contingency Coefficient 

An adjustment to phi in order to make it suitable for tables larger than 2 x 2. The coefficient is equal to the square root of chi-square divided by chi-square plus the sample size. Note, for tables smaller than 5-by-5 it underestimates the level of association. 

Cramer’s V

            This measure of association gives accurate results when the number of rows and columns are equal, independent of size. V is equal to the square root of chi-square divided by the product of the sample size and the length of the smallest row or column. 

Lambda

            Returns the percent by which you reduce the error when estimating the value of the dependent variable based upon on the value of the independent one. A lambda of zero means that there is no advantage in using the distribution of the independent variable to estimate the value of the dependent variable. 

Uncertainty Coefficient

            Otherwise known as the entropy coefficient, is the percent reduction in error accounting for the variance in the dependent variable, where variance is defined in terms of entropy. When the uncertainty coefficient is zero, the independent variable is not helpful in predicting the dependent variable.

Ordinal Data

            Gamma
Returns the strength of association for ordinal data, ignoring tied (cases have equal values on both variables) pairs. Gamma is the number of concordant pairs minus the number discordant ones over the sum of each type of pair. Cases form a concordant pair when the ranking agrees; meaning one case has a higher value than another case on both variables. When one case has a higher value on one variable, but a lower value on another the ranking disagrees and the cases form a discordant pair. Values range from -1 to 1. A value of 1 indicates perfect agreement between the rankings, while a value of -1 means there is perfect disagreement. There is no association between cases when gamma is equal to zero. Be aware that since gamma ignores ties, the strength of association between two variables might be over-exaggerated.

         Somers’ d

            Modification to Gamma that accounts for pairs tied on the dependent variable; Values range from -1 for negative relationships to +1 for positive ones. 

         Kendall’s Tau B

           A modification to gamma that takes into account tied pairs tied on both the dependent and independent variable. Kendall’s Tau-B is symmetrical in that the same value is produced regardless of which variable is considered independent. Tau-b can only reach its maximum or minimum values of 1 and -1 for square tables.

         Kendall’s Tau C

             A modification to gamma that takes into account tied pairs tied on both the dependent and independent variable. This is a variant of Tau-B that can reach the maximum and minimum values of +1 and -1 for non-square tables. 

Nominal by Interval

            Eta

            Use this gauge of association when the dependent variable is a quantitative measure and the independent variable is categorical. Eta ranges from 0 to 1, with increasing values indicating a higher degree of association.


Cohen’s Kappa


Kappa is a measure of the degree to which two raters agree over their sorting of items into mutually exclusive categories, and takes into account agreement that occurs by chance. Values range from -1 to +1 and represent the proportion of agreements between raters after adjusting for those that take place by chance. A value of +1 indicates perfect agreement and -1 perfect disagreement. When kappa is zero, then there is no relationship between the raters and any agreements or disagreements are due to chance only. 


Estimated Relative Risk

           The observed risk of having the outcome of interest be greater due to a specific factor.  Use the odds ratio as an estimate or measure of risk if the occurrence of the factor is rare. A confidence interval greater than one indicates there is a greater chance of the event occurring in the presence of the factor. Note: this is only suitable for 2 x 2 tables.

Example


Consider a medical study examining the relative risk of patients having cerebella toxicity who have taken a generic chemotherapeutic agent rather than a non-generic one.

/////re check five previous pages to be sure
	
	Toxicity +
	Toxicity -

	Generic +
	11
	14

	Generic -
	3
	31



Enter the following data into PSPP as follows, where +1 represents positive (+) and 0 negative (-):
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Weight cases by selecting Data->Weight Cases, and then choose weight cases by freq.
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Select Analyze-> Descriptive Statistics -> Crosstabs to open the Crosstabs dialogue box.


Move the variable emph{toxicity} from the list on the left side of the dialogue box into Rows and emph{Generic} into Columns.

            Click Statistics to bring up the Statistics dialogue box.
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Select the Risk check box and click Continue to close this dialogue box.

Click OK on the Crosstabs dialogue box.

PSPP displays the results in the output viewer.
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Compare Means

One-Sample T-Test


Tests if the mean of a single variable differs from a specified constant. 

Example


You can compare the mean of 100 measurements of the number of hours that soft white light bulbs were operational compared to the time claimed by the manufacturer (700 hours) in the file LightBulbHours.sav. 


Open the file LightBulbHours.sav.

            Select Analyze-> Compare Means -> One Sample T Test.

            Select the hour variable from the list on the left side of the dialogue box and then click the right arrow to move it into the Test Variables text box.


Enter the value 700 into the Test Value text box. 

           [image: image85.jpg]




Click OK.

            You can view the results in the output window.
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Independent Samples T Test

Compares means of the same variable from two independent samples. The test requires normally distributed data, although minor departures from this assumption are tolerable, and there is no requirement that the samples are the same size. 

 Example

Compare the mean height of 12-year-old boys and girls in centimeters measured in a class of ten girls and ten boys. 

Enter the following height and group data into PSPP, where 0 represents female and 1 male.

	152.71
	0

	142.57
	0

	155.48
	0

	148.79
	0

	167.74
	0

	149.51
	0

	142.00
	0

	150.21
	0

	171.19
	0

	141.99
	0

	152.67
	1

	139.65
	1

	152.19
	1

	156.94
	1

	151.86
	1

	157.79
	1

	152.49
	1

	157.52
	1

	156.95
	1

	141.61
	1


Name the first variable Height and the second Gender.

Select Analyze-> Compare Means -> Independent Samples T Test.

Select Height from the list on the left side of the dialogue box and then click the upper right arrow to move it into the Test Variables box.
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Select Gender and click the lower right arrow to move the variable into Define Groups.

Click the Define Groups button at the bottom of the dialogue box.
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Enter 0 into the Group1 Value textbox of the Define Groups dialogue box.

Enter 1 into the Group2 Value textbox of the Define Groups dialogue box.

Select Continue.
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Click OK on the Independent-Samples T Test dialogue box.

Examine the results in the output viewer. As you can see, in this instance, the girls are taller.
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Paired Samples T Test

Compares the mean of two sets of quantitative data where data sets are organized into pairs with a definite relationship, e.g., one set of data might represent a measurement taken before some event and the other a measurement after. Each pair is then the measurement before coupled with the measurement after. 

Example

Use the paired samples t-test to compare the means of the following measurements from nine asthmatics of their peak expiratory flow rate before and after a walk on a cold winter’s day.

[image: image91.jpg]“BloodPressure.sav —

Fle Edit View Data Transform Analyze

89 |
s ERE
[o: Before [250.00
After Before
i 302.00 314.00
z 199.00 240.00
E 230.00 338.00
2 314.00 390.00
5 220.00 296.00
g 258.00 256.00
7 328.00 391.00
& 332.00 404.00
g 231.00 290.00
10





Select Analyze->Compare Means-> Paired Samples T Test.

Highlight the emph{Before} variable with the mouse and then click the right arrow to place it in the Test Variables dialogue box under emph{Var1}.
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Repeat the same steps with the emph{After} variable to place it under Var2.

Click OK to display the results in the Output window.
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One Way Anova

Indicates if there are significant differences between means of three or more independent groups, where the independent variable consists of two or more categorical independent groups while the dependent one is either interval or ratio. Note: this only tells you if the means of the groups are significantly different and not which ones.

One-Way ANOVA dialogue box.
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Optional Statistics include:

· Descriptives (mean, standard deviation, standard error of the mean, minimum, maximum, and 95% confidence intervals for each dependent variable) 

· Homogeneity of variance test that calculates the Levene statistic to test for the equality of variances

The Contrasts feature on the dialogue box enables you to specify contrasts that you want tested by the t statistic. 

Example

Determine if the mean of each smoker group type’s lung capacity varies, where the different groups include non-smoker, light-smoker, medium-smoker, and heavy-smoker.

Open the data file XXX.sav. This lists forced expiratory flow measurements under the variable emph{FEF} and the corresponding group type (non-smoker=0, light-smoker=1, medium-smoker=2, heavy-smoker=3) under emph{Groups}.
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Select Analyze-> Compare Means-> One Way ANOVA

Click on emph{FEF} from the list of variables on the left side of the dialogue box then select the upper right arrow to move it into the Dependent Variables textbox. 

Select the emph{Group} variable and click the lower right arrow button to place it inside the Factor textbox.
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Click OK to displays the results in the output viewer.
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Contrast

Contrast is a weighted sum of the means that enables you to test your research hypothesis as opposed to the statistical one.

Example

Examine if the mean lung capacity of non-smokers varies from smokers, independent of how many they smoke. There are four different groups, of which three are smokers of different intensities. This means the non-smoking group should have a mean with a weighting of unity and the others a weighting of one-third.

Select Contrasts on the One-Way ANOVA dialogue box.
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Enter 1.0 in the Coefficients textbox and then click the Add button.

Add the values -0.333, -0.333, and -0.334 to the coefficients list.
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Press Continue to close the Contrasts dialogue box.

Press OK on the One-Way ANOVA dialogue box to display the results in the output viewer.
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Bivariate Correlation

Computes Pearson’s correlation coefficient, defined as a value between -1 and +1 that indicates the degree of association between variables. A positive value means large values of one variable are associated with large values of the other and likewise, small values of one variable are associated with small values of the other. A negative value indicates that large values of one variable are associated with small values of the other and vise-versa. 

Example

Use this feature to investigate the correlation, if any, between ice cream sales and outside temperature. 

Open a new data file.

Enter the following pairs of values listing the number of ice cream cones sold per day at one store along with the corresponding daytime high temperature in degrees Fahrenheit for that day.

Number of       Temperature

 Cones Sold     (Fahrenheit) 

  171.00
   76.00

  161.00
   71.00

  156.00
   66.00

  151.00
   61.00

  154.00
   73.00

  143.00
   61.00

  146.00
   64.00

  157.00
   69.00

  171.00
   78.00

  173.00
   78.00

  166.00
   76.00

  168.00
   76.00

  176.00
   81.00

  181.00
   83.00

  181.00
   86.00

  144.00
   60.00

  174.00
   87.00

  177.00
   89.00

  178.00
   86.00

  186.00
   91.00

  164.00
   75.00

  161.00
   74.00

  163.00
   72.00

  149.00
   69.00

  161.00
   71.00

  155.00
   74.00

  170.00
   86.00

  179.00
   91.00

  176.00
   71.00

  165.00
   82.00

Select Analyze-> Bivariate Correlation to bring up the Bivariate Correlation dialogue box.

Select Cones and click the right arrow button to move it into the right-hand-side textbox.
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Repeat the same steps with the Temperature variable.

Click OK to display the results in the output viewer.
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Factor Analysis

Helps identify the underlying variables, or factors, to explain correlations. Variables should be either interval or ratio, and not categorical. Note: PSPP assumes the data has a nearly bivariate normal distribution for each pair of variables and that observations are independent. 

Factor Analysis Dialogue Box
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Extraction Dialogue Box
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Method

The emph{Method} button on the Extraction dialogue box enables you to choose the method of factor extraction. Options include Principal Components Analysis and Principal Axis Factoring.

· Principal Components Analysis

Used when the correlation matrix is singular. This function assembles uncorrelated linear combinations of the observed variables such that each successive component accounts for a progressively smaller portion of the variance.

· Principal Axis Factoring

An iterative procedure that extracts and replaces factors from the current correlation matrix with new estimates repeatedly until the convergence criterion for extraction is satisfied. 

Analyse 

This feature enables you to choose either a correlation or covariance matrix.

Display

You can display the unrotated factor solution and Scree plot with this option.

Unrotated Factor Solution

Displays the unrotated factor loadings, communalities, and eigenvalues for the solution.

Scree Plot

A plot of the variance for each factor. 

Extract

Specify to keep factors whose eigenvalues exceed a specified factor above the mean eigenvalue, or choose a specific number of factors to keep.

Maximum Iterations for Convergence

Specify the maximum number of steps the algorithm can take to estimate the solution.

Rotation Dialogue Box
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Method

Enables you to choose the type of factor rotation method. Options include none, varimax, quartimax, and equimax.

Varimax

An orthogonal rotation of the factor axes which has the effect of differentiating the original variables by the extracted factor. This solution provides results that make it easier to identify each variable with a single factor.

Quartimax

An orthogonal rotation that minimizes the number of factors needed to explain each variable.

Equimax

A combination of the varimax and quartimax rotations.

Display Rotated Solution

When you select a rotation method, then you have the option of choosing to display the solution in this way.

Maximum iterations for convergence

You can choose the maximum number of steps the algorithm can take to reach convergence. The default value is twenty-five. 

Example

Perform factor analysis to determine the leading factors that drive people to purchase specific brands of bread. 

Enter the data in figure x, or open file xxx. sav.
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Select Analyze-> Factor Analysis to bring up Factor Analysis dialogue box.

Click the first variable, emph{Reputation}, and then press the right arrow button to move it into the Variables dialogue box.

[image: image107.jpg]Variables:

# Freshness
# Brand
/ Advertising

# Colour
./ Quanitity





Repeat with all the other variables until no more remain on the left side.
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Click the Extraction button.

Select the Principal Components Analysis method.

Select the Correlation matrix option under Analyse.

Select Unrotated factor solution and Scree plot under Display.

Click Continue to close this dialogue box.

Select the Rotations button the Factor Analysis dialogue box.

Select the Varimax option under Method.

Select Display rotated solution.

Click Continue to close the dialogue box.

Click the OK button on the Factor Analysis dialogue box to display the results in the output viewer.
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Reliability

Estimate the internal consistency reliability. Options include Split-half reliability and Chronbach’s Alpha. 
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Split-Half Reliability

An estimation based on the correlation of two equivalent forms of the scale. This is a three-step process: 1) Randomly divide all items that measure the same construct into two sets, 2) administer the whole instrument and divide the total score for each item in half, and 3) estimate the split-half reliability by calculating the correlation of these two sets. 

Cronbach’s Alpha

This estimation is equivalent to the average of all possible split-half estimates, and is an indication of the correlation among the variables. 

Example

Examine the internal reliability of the following pass-fail test data, where zero represents fail and one pass. 
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Enter the test data into a new data file, or open the file xxx.sav.

Select Analyze-> Reliability.

Click the first variable and select the right arrow to move it into the items textbox.
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Repeat with the other variables until they are all listed in the items text box.
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Click OK to display the results. In this instance Cronbach’s Alpha is 0.61 indicating the internal consistency is questionable.
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Linear Regression 

Non-functional, at least in the version I have.

Non-Parametric Statistics

Provides Binomial statistics and Chi-Square for an arbitrary distribution of data.  Tests the differences between the observed and expected distribution of a sample, and can also test the difference between two or more samples.

Binomial

Compare the observed frequencies of dichotomous data to the expected values from the binomial distribution. The primary purpose of this test is to observe if the number of outcomes for each variable differs, e.g., you can verify a fair coin by comparing the frequency of heads and tails in coin tosses.

Example:

 The following table indicates the temperatures at which customers ordered their gourmet drinks on a midsummer’s day; available menu options included ice-cold, luke-warm, warm, or steaming-hot. The first column, emph{HotCold}is a dichotomous variable with a value of zero for ice-cold drinks and unity otherwise. The next column, emph{Range} varies from 0 to 3 depending upon temperature range, where 0=cold, 1=luke-warm, 2=warm, and 3= hot. 

  (Note data might be downloadable)

HotCold   Range

     0
    0

    0 
    0 

    1
    2

    1
    2

     0
     0

    1
    1

    1
    1

    1
    1

    1
    2

    1
    1

    1
    3

    1
    3

    1
    2

    0 
     0

     0
     0

     0
     0

    1
    1

     0
     0

     0
     0

    1
    2

    1
    2

     0
     0

    1
    3

     0
     0
Start by examining the data in the first column; emph{HotCold}.

Copy table x.x into a data file, or open xxx.sav.

Select Analyze->Non-Parametric Statistics->Binomial.

Select emph{HotCold} and click the right arrow button  to place it in the emph{Test Variable List} textbox.

Verify Test proportion has the value 0.5.

Verify that you have emph{Get from data} selected under Define Dichotomy.
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Click OK to display the results in the output viewer.
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Next, examine the variable emph{Range}.

Select Analyze->Non-Parametric Statistics->Chi-Square.

Select the Range variable, and then click the right arrow to place it into the emph{Test Variable List} textbox.

[image: image118.jpg]@ Chi-Square Test

# HotCold

Test Variable List:

Expected Range:
®© Get from data

O Use specified range

Lower:

Upper:

Expected Values:
© Al categories equal

O Values!
s £dd
[P edic

=== Remove





Verify that emph{All categories equal} is selected under emph{Expected Values}.

Verify that the emph{Get from data} option under emph{Expected Range} is selected.

Click OK to display the results in the output viewer.
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ROC Curve

Use this option to analyze binary classification systems. Examples of binary classification schemes include passing or failing newly made items during an inspection, or labeling patients to be either with or without a medical problem. The Roc Curve function returns an ROC curve with the option to display a diagonal reference line, standard error and confidence interval, as well as the coordinate points. 
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Test Variable

Continuous numerical data holding the test results.

State Variable
Indicates which category is positive.

Display
Options for the output viewer including: 1) ROC curve with or without a diagonal reference line, 2) standard error and confidence interval, and 3) coordinate points of the ROC curve.
ROC Curve

Produce a plot of one classification rate from a binary classification scheme versus the other as the criterion changes, e.g., you can plot the true positive rate versus the false positive rate for a disease as the threshold value between the two classifications varies. 

With a diagonal reference line

Include a diagonal reference line in the plot. An ROC curve that coincides with this line indicates the distribution of each classification group is similar. 

Standard Error and Confidence Interval

Show the standard error, confidence interval, and area in a separate table in the output viewer. The area ranges in value from 0 to 1, where 1 indicates the distribution of each classification group does not overlap and 0.5 means both distributions are the same.

Example

Make an ROC curve of the following medical test data describing the dependence of a disease with age. The emph{age} variable holds the patients ages and the corresponding emph{disease}column is either 0 indicating a negative diagnosis or 1 otherwise.
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Open the file xxx.sav.

Select Analyze-> ROC Curve

Select emph{Age} from the list of variables on the left side of the dialogue box, and click the upper right arrow button to move it under  emph{Test Variable}.

Select emph{Disease} and click the lower right arrow button to move it into the emph{State Variable} box.

Select all the check boxes under emph{Display}.

Enter the number 1 in the emph{Value of state variable} box.
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Click OK to display the ROC curve and accompanying tables in the output viewer.

[image: image123.jpg]Output—

Fle Edit_Windows Help

b ROC

RoC
ROC Age BY Disasse (1)
JPLOT CURVE (ReFeRencE)
[PRINT SE COORDINATES

Vali N (istwise)
|Disease [Unweightedweigtes)
Fostve T
Negative 51 si00

ROC Curve

W e

T
0 _speliiy 04 06 08

[Asymp 55% Confidence inerval

0.8
0.6
0.4
0.2
0,
T
\areslstd Emorssymptotic Sia | _Lowsr5:
sl o3 o0
[Fesiive 7 grester than or aaual to[sarsiti
FEX T/
2500
2650
2700
2750
2800
2500
3050
3100

ound__Upper Bound|
71 a7

1 - Speciiciy]

o Too|

5 s4)

57 &

57 a8

5 o

57 a0

57 o)

53 7

5 73l





Utilities

Variables

Shows the following information for each selected variable in its dialogue box:

Variable Name

Variable Label

Data Format

User-missing values

Measurement Level

Value Labels

For a definition of each variable property, please see section xxx.

In addition the Variables dialogue box enables you to jump directly to a variable in the data file by selecting the variable from the list in the dialogue box and clicking the emph{Jump To} button. 

Example

Select Utilities-> Variables to bring up the Variables dialogue box.

Select a variable from the list in the left column to view its properties on the right side of the dialogue box.
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Data File Comments

This feature enables you to add comments to a data file. 

Display comments in output

Display comments in the output viewer.

Reset

Clears the current comment.
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Windows

Minimize All Windows

Collapses all windows.  Click the PSPP icon on the tool bar to open them again.

Split

Split the current data editor window.
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Example -Split File

Group the following file with physiology data according to height. 

The physiology data file.
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First, group the data according to height.

Open the file xxx.sav.

1) Select Data->Split File.

2) Select the “Compare groups” radio button in the pop up window.

3) Click “Height in millimeters”. This highlights the variable in blue.
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4) Select the arrow to the left of the “Groups based on:” text box. This will put the height variable inside that area. 

5) Click OK.

An output viewer pops up with result.
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Help

Reference Manual

About

All the toolbar functions have been described elsewhere so provide links/refs to other pages

PSPP provides a tool bar across the top with short cuts to the more commonly used menu commands.
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Short Cuts Include:

Open

Save

Go To Case

Variables

Find 

Insert Cases

Insert Variable

Split File

Weight Cases

Value Labels

