[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-arm] [PATCH RFC 10/16] hw/ppc/spapr: don't use smp_cores, smp_
From: |
David Gibson |
Subject: |
Re: [Qemu-arm] [PATCH RFC 10/16] hw/ppc/spapr: don't use smp_cores, smp_threads |
Date: |
Tue, 14 Jun 2016 13:03:41 +1000 |
User-agent: |
Mutt/1.6.1 (2016-04-27) |
On Fri, Jun 10, 2016 at 07:40:21PM +0200, Andrew Jones wrote:
> Use CPUState nr_cores,nr_threads and MachineState
> cores,threads instead.
>
> Signed-off-by: Andrew Jones <address@hidden>
> ---
> hw/ppc/spapr.c | 9 +++++----
> hw/ppc/spapr_rtas.c | 2 +-
> 2 files changed, 6 insertions(+), 5 deletions(-)
>
> diff --git a/hw/ppc/spapr.c b/hw/ppc/spapr.c
> index 063664234106e..f78276bb4b164 100644
> --- a/hw/ppc/spapr.c
> +++ b/hw/ppc/spapr.c
> @@ -35,7 +35,6 @@
> #include "net/net.h"
> #include "sysemu/device_tree.h"
> #include "sysemu/block-backend.h"
> -#include "sysemu/cpus.h"
> #include "sysemu/kvm.h"
> #include "sysemu/device_tree.h"
> #include "kvm_ppc.h"
> @@ -603,7 +602,7 @@ static void spapr_populate_cpu_dt(CPUState *cs, void
> *fdt, int offset,
> uint32_t cpufreq = kvm_enabled() ? kvmppc_get_clockfreq() : 1000000000;
> uint32_t page_sizes_prop[64];
> size_t page_sizes_prop_size;
> - uint32_t vcpus_per_socket = smp_threads * smp_cores;
> + uint32_t vcpus_per_socket = cs->nr_cores * cs->nr_threads;
> uint32_t pft_size_prop[] = {0, cpu_to_be32(spapr->htab_shift)};
>
> /* Note: we keep CI large pages off for now because a 64K capable guest
> @@ -1774,7 +1773,7 @@ static void ppc_spapr_init(MachineState *machine)
> /* Set up Interrupt Controller before we create the VCPUs */
> spapr->icp = xics_system_init(machine,
> DIV_ROUND_UP(max_cpus *
> kvmppc_smt_threads(),
> - smp_threads),
> + machine->threads),
> XICS_IRQS, &error_fatal);
>
> if (smc->dr_lmb_enabled) {
> @@ -2268,9 +2267,11 @@ static HotplugHandler
> *spapr_get_hotpug_handler(MachineState *machine,
>
> static unsigned spapr_cpu_index_to_socket_id(unsigned cpu_index)
> {
> + CPUState *cs = first_cpu;
> +
> /* Allocate to NUMA nodes on a "socket" basis (not that concept of
> * socket means much for the paravirtualized PAPR platform) */
> - return cpu_index / smp_threads / smp_cores;
> + return cpu_index / cs->nr_cores / cs->nr_threads;
> }
>
> static void spapr_machine_class_init(ObjectClass *oc, void *data)
> diff --git a/hw/ppc/spapr_rtas.c b/hw/ppc/spapr_rtas.c
> index 43e2c684fda8d..3fdfbb01a20dd 100644
> --- a/hw/ppc/spapr_rtas.c
> +++ b/hw/ppc/spapr_rtas.c
> @@ -742,7 +742,7 @@ int spapr_rtas_device_tree_setup(void *fdt, hwaddr
> rtas_addr,
> lrdr_capacity[1] = cpu_to_be32(max_hotplug_addr & 0xffffffff);
> lrdr_capacity[2] = 0;
> lrdr_capacity[3] = cpu_to_be32(SPAPR_MEMORY_BLOCK_SIZE);
> - lrdr_capacity[4] = cpu_to_be32(max_cpus/smp_threads);
> + lrdr_capacity[4] = cpu_to_be32(max_cpus / machine->threads);
> ret = qemu_fdt_setprop(fdt, "/rtas", "ibm,lrdr-capacity", lrdr_capacity,
> sizeof(lrdr_capacity));
> if (ret < 0) {
I think all the places that use cs->nr_* here it actually makes more
sense to use the value in the machine state.
--
David Gibson | I'll have my music baroque, and my code
david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_
| _way_ _around_!
http://www.ozlabs.org/~dgibson
signature.asc
Description: PGP signature
- Re: [Qemu-arm] [Qemu-devel] [PATCH RFC 07/16] qom/cpu: make nr-cores, nr-threads real properties, (continued)
[Qemu-arm] [PATCH RFC 11/16] target-ppc: don't use smp_threads, Andrew Jones, 2016/06/10
[Qemu-arm] [PATCH RFC 10/16] hw/ppc/spapr: don't use smp_cores, smp_threads, Andrew Jones, 2016/06/10
- Re: [Qemu-arm] [PATCH RFC 10/16] hw/ppc/spapr: don't use smp_cores, smp_threads,
David Gibson <=
[Qemu-arm] [PATCH RFC 13/16] hw/arm/virt: don't use smp_cpus, max_cpus, Andrew Jones, 2016/06/10
[Qemu-arm] [PATCH RFC 14/16] hw/arm/virt: stash cpu topo info in VirtGuestInfo, Andrew Jones, 2016/06/10
[Qemu-arm] [PATCH RFC 12/16] hw/arm/virt: rename *.smp_cpus to *.cpus, Andrew Jones, 2016/06/10
[Qemu-arm] [PATCH RFC 15/16] smbios: don't use smp_cores, smp_threads, Andrew Jones, 2016/06/10
[Qemu-arm] [PATCH RFC 16/16] sysemu/cpus: bye, bye smp_cores, smp_threads, Andrew Jones, 2016/06/10
Re: [Qemu-arm] [Qemu-devel] [PATCH RFC 00/16] Rework SMP parameters, Thomas Huth, 2016/06/11