[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [RFC v6 02/13] memory: Add IOMMUTLBNotificationType to IOMMUTLBEntry
From: |
Eugenio Perez Martin |
Subject: |
Re: [RFC v6 02/13] memory: Add IOMMUTLBNotificationType to IOMMUTLBEntry |
Date: |
Thu, 27 Aug 2020 08:11:47 +0200 |
On Wed, Aug 26, 2020 at 5:42 PM Peter Xu <peterx@redhat.com> wrote:
>
> On Wed, Aug 26, 2020 at 04:36:40PM +0200, Eugenio Pérez wrote:
> > This way we can tell between MAPs and UNMAP, and potentially avoid to
> > send them to a notifier that does not require them.
> >
> > Signed-off-by: Eugenio Pérez <eperezma@redhat.com>
> > ---
> > include/exec/memory.h | 17 ++++++++++++-----
> > 1 file changed, 12 insertions(+), 5 deletions(-)
> >
> > diff --git a/include/exec/memory.h b/include/exec/memory.h
> > index 22c5f564d1..f6d91c54aa 100644
> > --- a/include/exec/memory.h
> > +++ b/include/exec/memory.h
> > @@ -59,6 +59,12 @@ struct ReservedRegion {
> >
> > typedef struct IOMMUTLBEntry IOMMUTLBEntry;
> >
> > +typedef enum {
> > + IOMMU_IOTLB_NONE = 0,
> > + IOMMU_IOTLB_UNMAP = 1,
> > + IOMMU_IOTLB_MAP = 2,
> > +} IOMMUTLBNotificationType;
>
> Can we directly use IOMMUNotifierFlag as the type rather than introducing a
> similar enumeration? Thanks,
>
Right, I think it's simpler your way.
Thanks!
> --
> Peter Xu
>
- [RFC v6 00/13] memory: Delete assertion in memory_region_unregister_iommu_notifier, Eugenio Pérez, 2020/08/26
- [RFC v6 01/13] memory: Rename memory_region_notify_one to memory_region_notify_iommu_one, Eugenio Pérez, 2020/08/26
- [RFC v6 02/13] memory: Add IOMMUTLBNotificationType to IOMMUTLBEntry, Eugenio Pérez, 2020/08/26
- [RFC v6 03/13] hw/alpha/typhoon: Mark all IOMMUTLBEntry as IOMMU_IOTLB_NONE type, Eugenio Pérez, 2020/08/26
- [RFC v6 04/13] amd_iommu: Mark all IOMMUTLBEntry as IOMMU_IOTLB_NONE type, Eugenio Pérez, 2020/08/26
- [RFC v6 05/13] hw/arm/smmu: Fill IOMMUTLBEntry notifier type, Eugenio Pérez, 2020/08/26
- [RFC v6 06/13] dma/rc4030: Mark all IOMMUTLBEntry as IOMMU_IOTLB_NONE type, Eugenio Pérez, 2020/08/26
- [RFC v6 07/13] intel_iommu: Mark IOMMUTLBEntry of page notification as IOMMU_IOTLB_UNMAP type, Eugenio Pérez, 2020/08/26
- [RFC v6 08/13] virtio-iommu: Mark virtio_iommu_translate IOTLB as IOMMU_IOTLB_NONE type, Eugenio Pérez, 2020/08/26
- [RFC v6 09/13] intel_iommu: Set IOMMUTLBEntry type in vtd_page_walk_level, Eugenio Pérez, 2020/08/26
- [RFC v6 10/13] memory: Notify IOMMU IOTLB based on entry type, not permissions, Eugenio Pérez, 2020/08/26
- [RFC v6 11/13] memory: Add IOMMU_DEVIOTLB_UNMAP IOMMUTLBNotificationType, Eugenio Pérez, 2020/08/26