[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 2/6] qemu/main-loop: rename QEMU_IOTHREAD_LOCK_GUARD to QEMU_
From: |
Stefan Hajnoczi |
Subject: |
Re: [PATCH 2/6] qemu/main-loop: rename QEMU_IOTHREAD_LOCK_GUARD to QEMU_BQL_LOCK_GUARD |
Date: |
Thu, 30 Nov 2023 15:27:32 -0500 |
On Thu, Nov 30, 2023 at 10:14:47AM +0100, Ilya Leoshkevich wrote:
> On Wed, 2023-11-29 at 16:26 -0500, Stefan Hajnoczi wrote:
> > The name "iothread" is overloaded. Use the term Big QEMU Lock (BQL)
> > instead, it is already widely used and unambiguous.
> >
> > Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
> > ---
> > include/qemu/main-loop.h | 20 ++++++++++----------
> > hw/i386/kvm/xen_evtchn.c | 14 +++++++-------
> > hw/i386/kvm/xen_gnttab.c | 2 +-
> > hw/mips/mips_int.c | 2 +-
> > hw/ppc/ppc.c | 2 +-
> > target/i386/kvm/xen-emu.c | 2 +-
> > target/ppc/excp_helper.c | 2 +-
> > target/ppc/helper_regs.c | 2 +-
> > target/riscv/cpu_helper.c | 4 ++--
> > 9 files changed, 25 insertions(+), 25 deletions(-)
> >
> > diff --git a/include/qemu/main-loop.h b/include/qemu/main-loop.h
> > index d6f75e57bd..0b6a3e4824 100644
> > --- a/include/qemu/main-loop.h
> > +++ b/include/qemu/main-loop.h
> > @@ -344,13 +344,13 @@ void qemu_bql_lock_impl(const char *file, int
> > line);
> > void qemu_bql_unlock(void);
> >
> > /**
> > - * QEMU_IOTHREAD_LOCK_GUARD
> > + * QEMU_BQL_LOCK_GUARD
> > *
> > - * Wrap a block of code in a conditional
> > qemu_mutex_{lock,unlock}_iothread.
> > + * Wrap a block of code in a conditional qemu_bql_{lock,unlock}.
> > */
> > -typedef struct IOThreadLockAuto IOThreadLockAuto;
> > +typedef struct BQLLockAuto BQLLockAuto;
> >
> > -static inline IOThreadLockAuto *qemu_iothread_auto_lock(const char
> > *file,
> > +static inline BQLLockAuto *qemu_bql_auto_lock(const char *file,
> > int line)
>
> The padding is not correct anymore.
Good point, I didn't check the formatting after search-and-replace. I
will fix this across the patch series in v2.
Stefan
signature.asc
Description: PGP signature
- [PATCH 5/6] Replace "iothread lock" with "BQL" in comments, (continued)