[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_b
From: |
Eric Farman |
Subject: |
Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock() |
Date: |
Thu, 30 Nov 2023 16:48:41 -0500 |
User-agent: |
Evolution 3.48.4 (3.48.4-1.fc38) |
On Wed, 2023-11-29 at 16:26 -0500, Stefan Hajnoczi wrote:
> The Big QEMU Lock (BQL) has many names and they are confusing. The
> actual QemuMutex variable is called qemu_global_mutex but it's
> commonly
> referred to as the BQL in discussions and some code comments. The
> locking APIs, however, are called qemu_mutex_lock_iothread() and
> qemu_mutex_unlock_iothread().
>
> The "iothread" name is historic and comes from when the main thread
> was
> split into into KVM vcpu threads and the "iothread" (now called the
> main
> loop thread). I have contributed to the confusion myself by
> introducing
> a separate --object iothread, a separate concept unrelated to the
> BQL.
>
> The "iothread" name is no longer appropriate for the BQL. Rename the
> locking APIs to:
> - void qemu_bql_lock(void)
> - void qemu_bql_unlock(void)
> - bool qemu_bql_locked(void)
>
> There are more APIs with "iothread" in their names. Subsequent
> patches
> will rename them. There are also comments and documentation that will
> be
> updated in later patches.
>
> Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
Acked-by: Eric Farman <farman@linux.ibm.com>
- Re: [PATCH 4/6] system/cpus: rename qemu_global_mutex to qemu_bql, (continued)
- [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), Stefan Hajnoczi, 2023/11/29
- Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), Paul Durrant, 2023/11/30
- Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), Fabiano Rosas, 2023/11/30
- Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), David Woodhouse, 2023/11/30
- Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), Cédric Le Goater, 2023/11/30
- Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), Peter Xu, 2023/11/30
- Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(),
Eric Farman <=
- [PATCH 5/6] Replace "iothread lock" with "BQL" in comments, Stefan Hajnoczi, 2023/11/29
- [PATCH 6/6] Rename "QEMU global mutex" to "BQL" in comments and docs, Stefan Hajnoczi, 2023/11/29
- [PATCH 2/6] qemu/main-loop: rename QEMU_IOTHREAD_LOCK_GUARD to QEMU_BQL_LOCK_GUARD, Stefan Hajnoczi, 2023/11/29