[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 15/22] hw/elf_ops: Rename elf_ops.h -> elf_ops.h.inc
From: |
Philippe Mathieu-Daudé |
Subject: |
[PULL 15/22] hw/elf_ops: Rename elf_ops.h -> elf_ops.h.inc |
Date: |
Thu, 25 Apr 2024 13:01:48 +0200 |
Since commit 139c1837db ("meson: rename included C source files
to .c.inc"), QEMU standard procedure for included C files is to
use *.c.inc.
Besides, since commit 6a0057aa22 ("docs/devel: make a statement
about includes") this is documented in the Coding Style:
If you do use template header files they should be named with
the ``.c.inc`` or ``.h.inc`` suffix to make it clear they are
being included for expansion.
Therefore rename "hw/elf_ops.h" as "hw/elf_ops.h.inc".
Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Acked-by: Richard Henderson <richard.henderson@linaro.org>
Message-Id: <20240424173333.96148-2-philmd@linaro.org>
---
include/hw/{elf_ops.h => elf_ops.h.inc} | 0
bsd-user/elfload.c | 2 +-
hw/core/loader.c | 4 ++--
linux-user/elfload.c | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)
rename include/hw/{elf_ops.h => elf_ops.h.inc} (100%)
diff --git a/include/hw/elf_ops.h b/include/hw/elf_ops.h.inc
similarity index 100%
rename from include/hw/elf_ops.h
rename to include/hw/elf_ops.h.inc
diff --git a/bsd-user/elfload.c b/bsd-user/elfload.c
index baf2f63d2f..833fa3bd05 100644
--- a/bsd-user/elfload.c
+++ b/bsd-user/elfload.c
@@ -383,7 +383,7 @@ static const char *lookup_symbolxx(struct syminfo *s,
uint64_t orig_addr)
return "";
}
-/* FIXME: This should use elf_ops.h */
+/* FIXME: This should use elf_ops.h.inc */
static int symcmp(const void *s0, const void *s1)
{
struct elf_sym *sym0 = (struct elf_sym *)s0;
diff --git a/hw/core/loader.c b/hw/core/loader.c
index b8e52f3fb0..2f8105d7de 100644
--- a/hw/core/loader.c
+++ b/hw/core/loader.c
@@ -305,7 +305,7 @@ static void *load_at(int fd, off_t offset, size_t size)
#define elf_word uint32_t
#define elf_sword int32_t
#define bswapSZs bswap32s
-#include "hw/elf_ops.h"
+#include "hw/elf_ops.h.inc"
#undef elfhdr
#undef elf_phdr
@@ -327,7 +327,7 @@ static void *load_at(int fd, off_t offset, size_t size)
#define elf_sword int64_t
#define bswapSZs bswap64s
#define SZ 64
-#include "hw/elf_ops.h"
+#include "hw/elf_ops.h.inc"
const char *load_elf_strerror(ssize_t error)
{
diff --git a/linux-user/elfload.c b/linux-user/elfload.c
index f4a0b78c75..a0999dac15 100644
--- a/linux-user/elfload.c
+++ b/linux-user/elfload.c
@@ -3572,7 +3572,7 @@ static const char *lookup_symbolxx(struct syminfo *s,
uint64_t orig_addr)
return "";
}
-/* FIXME: This should use elf_ops.h */
+/* FIXME: This should use elf_ops.h.inc */
static int symcmp(const void *s0, const void *s1)
{
struct elf_sym *sym0 = (struct elf_sym *)s0;
--
2.41.0
- [PULL 07/22] hw/misc/applesmc: Simplify DeviceReset handler, (continued)
- [PULL 07/22] hw/misc/applesmc: Simplify DeviceReset handler, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 08/22] hw/misc/imx: Replace sprintf() by snprintf(), Philippe Mathieu-Daudé, 2024/04/25
- [PULL 06/22] target/i386: Move APIC related code to cpu-apic.c, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 14/22] hw/cxl/cxl-cdat: Make cxl_doe_cdat_init() return boolean, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 19/22] hw/core/machine: Introduce the module as a CPU topology level, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 18/22] hw/i386/pc_sysfw: Remove unused parameter from pc_isa_bios_init(), Philippe Mathieu-Daudé, 2024/04/25
- [PULL 09/22] hw/riscv/virt: Replace sprintf by g_strdup_printf, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 12/22] hw/cxl/cxl-cdat: Make ct3_load_cdat() return boolean, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 13/22] hw/cxl/cxl-cdat: Make ct3_build_cdat() return boolean, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 16/22] hw/xtensa: Include missing 'exec/cpu-common.h' in 'bootparam.h', Philippe Mathieu-Daudé, 2024/04/25
- [PULL 15/22] hw/elf_ops: Rename elf_ops.h -> elf_ops.h.inc,
Philippe Mathieu-Daudé <=
- [PULL 10/22] hw: Fix problem with the A*MPCORE switches in the Kconfig files, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 20/22] hw/core/machine: Support modules in -smp, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 11/22] hw: Add a Kconfig switch for the TYPE_CPU_CLUSTER device, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 21/22] hw/core: Introduce module-id as the topology subindex, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 22/22] hw/core: Support module-id in numa configuration, Philippe Mathieu-Daudé, 2024/04/25
- [PULL 17/22] hw/misc : Correct 5 spaces indents in stm32l4x5_exti, Philippe Mathieu-Daudé, 2024/04/25
- Re: [PULL 00/22] Misc HW patches for 2024-04-25, Richard Henderson, 2024/04/25