[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v5 08/16] acpi/ghes: don't check if physical_address is not z
From: |
Jonathan Cameron |
Subject: |
Re: [PATCH v5 08/16] acpi/ghes: don't check if physical_address is not zero |
Date: |
Mon, 9 Dec 2024 10:15:03 +0000 |
On Wed, 4 Dec 2024 14:12:46 +0100
Igor Mammedov <imammedo@redhat.com> wrote:
> On Wed, 4 Dec 2024 08:41:16 +0100
> Mauro Carvalho Chehab <mchehab+huawei@kernel.org> wrote:
>
> > The 'physical_address' value is a faulty page. As such, 0 is
> > as valid as any other value.
I'm not sure what a 'faulty page' is. but code looks fine.
Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
> >
> > Suggested-by: Igor Mammedov <imammedo@redhat.com>
> > Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
>
> Reviewed-by: Igor Mammedov <imammedo@redhat.com>
>
> > ---
> > hw/acpi/ghes.c | 4 ----
> > 1 file changed, 4 deletions(-)
> >
> > diff --git a/hw/acpi/ghes.c b/hw/acpi/ghes.c
> > index edc74c38bf8a..a3dffd78b012 100644
> > --- a/hw/acpi/ghes.c
> > +++ b/hw/acpi/ghes.c
> > @@ -400,10 +400,6 @@ int acpi_ghes_record_errors(uint16_t source_id,
> > uint64_t physical_address)
> >
> > start_addr = le64_to_cpu(ags->ghes_addr_le);
> >
> > - if (!physical_address) {
> > - return -1;
> > - }
> > -
> > start_addr += source_id * sizeof(uint64_t);
> >
> > cpu_physical_memory_read(start_addr, &error_block_addr,
>
>
- Re: [PATCH v5 10/16] acpi/ghes: better name GHES memory error function, (continued)
[PATCH v5 08/16] acpi/ghes: don't check if physical_address is not zero, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 01/16] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 09/16] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 07/16] acpi/ghes: Change the type for source_id, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 06/16] acpi/ghes: Remove a duplicated out of bounds check, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 14/16] acpi/ghes: move offset calculus to a separate function, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 16/16] docs: acpi_hest_ghes: fix documentation for CPER size, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 02/16] acpi/ghes: simplify acpi_ghes_record_errors() code, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 15/16] acpi/ghes: Change ghes fill logic to work with only one source, Mauro Carvalho Chehab, 2024/12/04