qemu-arm
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v2 01/10] target: Set disassemble_info::endian value for litt


From: Richard Henderson
Subject: Re: [PATCH v2 01/10] target: Set disassemble_info::endian value for little-endian targets
Date: Mon, 10 Feb 2025 13:54:00 -0800
User-agent: Mozilla Thunderbird

On 2/10/25 13:29, Philippe Mathieu-Daudé wrote:
@@ -35,6 +35,11 @@ static const gchar *tricore_gdb_arch_name(CPUState *cs)
      return "tricore";
  }
+static void tricore_cpu_disas_set_info(CPUState *cpu, disassemble_info *info)
+{
+    info->endian = BFD_ENDIAN_LITTLE;
+}

While this is not wrong, since there's no disassembler it's slightly 
disingenuous.

This is the only target without a callback function, correct? Let's split this function out separately, along with the hunk in patch 10 which makes the disas_set_info call unconditional.

Otherwise,
Reviewed-by: Richard Henderson <richard.henderson@linaro.org>


r~



reply via email to

[Prev in Thread] Current Thread [Next in Thread]