[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-block] [Qemu-devel] [PATCH v2 2/7] vmdk: Rename get_whole_clus
From: |
Fam Zheng |
Subject: |
Re: [Qemu-block] [Qemu-devel] [PATCH v2 2/7] vmdk: Rename get_whole_cluster() to vmdk_perform_cow() |
Date: |
Fri, 31 Mar 2017 13:55:10 +0800 |
User-agent: |
Mutt/1.8.0 (2017-02-23) |
On Sat, 03/25 16:48, Ashijeet Acharya wrote:
> Rename the existing function get_whole_cluster() to vmdk_perform_cow()
> as its sole purpose is to perform COW for the first and the last
> allocated clusters if needed.
>
> Signed-off-by: Ashijeet Acharya <address@hidden>
> ---
> block/vmdk.c | 21 +++++++++++++--------
> 1 file changed, 13 insertions(+), 8 deletions(-)
>
> diff --git a/block/vmdk.c b/block/vmdk.c
> index 7795c5f..f5fda2c 100644
> --- a/block/vmdk.c
> +++ b/block/vmdk.c
> @@ -1036,8 +1036,8 @@ static void vmdk_refresh_limits(BlockDriverState *bs,
> Error **errp)
> }
> }
>
> -/**
> - * get_whole_cluster
> +/*
> + * vmdk_perform_cow
> *
> * Copy backing file's cluster that covers @sector_num, otherwise write zero,
> * to the cluster at @cluster_sector_num.
> @@ -1045,13 +1045,18 @@ static void vmdk_refresh_limits(BlockDriverState *bs,
> Error **errp)
> * If @skip_start_sector < @skip_end_sector, the relative range
> * address@hidden, @skip_end_sector) is not copied or written, and leave
> * it for call to write user data in the request.
> + *
> + * Returns:
> + * VMDK_OK: on success
> + *
> + * VMDK_ERROR: in error cases
> */
> -static int get_whole_cluster(BlockDriverState *bs,
> - VmdkExtent *extent,
> - uint64_t cluster_offset,
> - uint64_t offset,
> - uint64_t skip_start_bytes,
> - uint64_t skip_end_bytes)
> +static int vmdk_perform_cow(BlockDriverState *bs,
> + VmdkExtent *extent,
> + uint64_t cluster_offset,
> + uint64_t offset,
> + uint64_t skip_start_bytes,
> + uint64_t skip_end_bytes)
> {
> int ret = VMDK_OK;
> int64_t cluster_bytes;
> --
> 2.6.2
>
>
Rule: each and every patch must be compilable. A rename patch must take care of
all the users. Please find all get_whole_cluster occasions in the file and
change them to use the new name.
Fam
- [Qemu-block] [PATCH v2 0/7] Optiomize VMDK I/O by allocating multiple clusters, Ashijeet Acharya, 2017/03/25
- [Qemu-block] [PATCH v2 1/7] vmdk: Refactor and introduce new helper functions, Ashijeet Acharya, 2017/03/25
- [Qemu-block] [PATCH v2 2/7] vmdk: Rename get_whole_cluster() to vmdk_perform_cow(), Ashijeet Acharya, 2017/03/25
- Re: [Qemu-block] [Qemu-devel] [PATCH v2 2/7] vmdk: Rename get_whole_cluster() to vmdk_perform_cow(),
Fam Zheng <=
- [Qemu-block] [PATCH v2 3/7] vmdk: Factor out metadata loading code out of get_cluster_offset(), Ashijeet Acharya, 2017/03/25
- [Qemu-block] [PATCH v2 4/7] vmdk: New functions to allocate multiple clusters and cluster offset, Ashijeet Acharya, 2017/03/25
- [Qemu-block] [PATCH v2 5/7] vmdk: Rename get_cluster_offset() to vmdk_get_cluster_offset(), Ashijeet Acharya, 2017/03/25
- [Qemu-block] [PATCH v2 6/7] vmdk: Allocate multiple clusters at once, Ashijeet Acharya, 2017/03/25
- [Qemu-block] [PATCH v2 7/7] vmdk: Update metadata for multiple clusters, Ashijeet Acharya, 2017/03/25