[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH for-9.2 v13 02/12] hw/ppc/spapr_pci: Do not create DT for disable
From: |
Akihiko Odaki |
Subject: |
[PATCH for-9.2 v13 02/12] hw/ppc/spapr_pci: Do not create DT for disabled PCI device |
Date: |
Mon, 05 Aug 2024 18:58:59 +0900 |
Disabled means it is a disabled SR-IOV VF or it is powered off, and
hidden from the guest.
Signed-off-by: Akihiko Odaki <akihiko.odaki@daynix.com>
---
hw/ppc/spapr_pci.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/hw/ppc/spapr_pci.c b/hw/ppc/spapr_pci.c
index 7cf9904c3546..f63182a03c41 100644
--- a/hw/ppc/spapr_pci.c
+++ b/hw/ppc/spapr_pci.c
@@ -1296,6 +1296,10 @@ static void spapr_dt_pci_device_cb(PCIBus *bus,
PCIDevice *pdev,
return;
}
+ if (!pdev->enabled) {
+ return;
+ }
+
err = spapr_dt_pci_device(p->sphb, pdev, p->fdt, p->offset);
if (err < 0) {
p->err = err;
--
2.45.2
- [PATCH for-9.2 v13 00/12] hw/pci: SR-IOV related fixes and improvements, Akihiko Odaki, 2024/08/05
- [PATCH for-9.2 v13 01/12] hw/pci: Rename has_power to enabled, Akihiko Odaki, 2024/08/05
- [PATCH for-9.2 v13 02/12] hw/ppc/spapr_pci: Do not create DT for disabled PCI device,
Akihiko Odaki <=
- [PATCH for-9.2 v13 03/12] hw/ppc/spapr_pci: Do not reject VFs created after a PF, Akihiko Odaki, 2024/08/05
- [PATCH for-9.2 v13 04/12] s390x/pci: Check for multifunction after device realization, Akihiko Odaki, 2024/08/05
- [PATCH for-9.2 v13 05/12] pcie_sriov: Do not manually unrealize, Akihiko Odaki, 2024/08/05
- [PATCH for-9.2 v13 06/12] pcie_sriov: Ensure VF function number does not overflow, Akihiko Odaki, 2024/08/05
- [PATCH for-9.2 v13 08/12] pcie_sriov: Release VFs failed to realize, Akihiko Odaki, 2024/08/05
- [PATCH for-9.2 v13 07/12] pcie_sriov: Reuse SR-IOV VF device instances, Akihiko Odaki, 2024/08/05
- [PATCH for-9.2 v13 09/12] pcie_sriov: Remove num_vfs from PCIESriovPF, Akihiko Odaki, 2024/08/05
- [PATCH for-9.2 v13 10/12] pcie_sriov: Register VFs after migration, Akihiko Odaki, 2024/08/05
- [PATCH for-9.2 v13 11/12] hw/pci: Use -1 as the default value for rombar, Akihiko Odaki, 2024/08/05
- [PATCH for-9.2 v13 12/12] hw/qdev: Remove opts member, Akihiko Odaki, 2024/08/05