[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH 00/14] Refactor Makefile object selection
From: |
quintela |
Subject: |
[Qemu-devel] [PATCH 00/14] Refactor Makefile object selection |
Date: |
Thu, 25 Jun 2009 00:07:57 +0200 |
From: Juan Quintela <address@hidden>
Hi
Following Anthony suggestion, I changed Makefile* and confiure to:
a- s/OBJS/obj-y/
b- changed configure to generate CONFIG_FOO=y instead of CONFIG_FOO=yes
c- Switch all occurences of
ifdef CONFIG_FOO
obj-y += foo.o
endif
to
obj-$(CONFIG_FOO) += foo.o
If people agree on this approach, I will rebase my previous series on top of
this one.
If you preffer to pull, you can get it:
git://git.et.redhat.com/qemu-quintela new_selection
Later, Juan.
Juan Quintela (14):
Rename OBJS to obj-y
Rename LIBOBJS to libobj-y
Rename OBJS to obj-y
Rename BLOCK_OBJS to block-obj-y
Rename AUDIO_OBJS to audio-obj-y
Rename SLIRP_OBJS to slirp-obj-y
Rename XEN_OBJS to xen-obj-y
Rename USER_OBJS to user-obj-y
Rename OBJS to obj-y
move CONFIG_* values from yes to y
Substitute ifdef CONFIG_FOO by obj-
Substitute ifdef CONFIG_FOO by obj-
Rename SOUND_HW to sound-obj-y
Substitute ifdef CONFIG_FOO by sound-obj-
Makefile | 164 ++++++++++++++-------------------
Makefile.hw | 18 ++--
Makefile.target | 281 ++++++++++++++++++++++++++----------------------------
configure | 74 +++++++-------
4 files changed, 250 insertions(+), 287 deletions(-)
- [Qemu-devel] [PATCH 00/14] Refactor Makefile object selection,
quintela <=
- [Qemu-devel] [PATCH 01/14] Rename OBJS to obj-y, quintela, 2009/06/24
- [Qemu-devel] [PATCH 02/14] Rename LIBOBJS to libobj-y, quintela, 2009/06/24
- [Qemu-devel] [PATCH 03/14] Rename OBJS to obj-y, quintela, 2009/06/24
- [Qemu-devel] [PATCH 04/14] Rename BLOCK_OBJS to block-obj-y, quintela, 2009/06/24
- [Qemu-devel] [PATCH 05/14] Rename AUDIO_OBJS to audio-obj-y, quintela, 2009/06/24
- [Qemu-devel] [PATCH 06/14] Rename SLIRP_OBJS to slirp-obj-y, quintela, 2009/06/24
- [Qemu-devel] [PATCH 07/14] Rename XEN_OBJS to xen-obj-y, quintela, 2009/06/24
- [Qemu-devel] [PATCH 08/14] Rename USER_OBJS to user-obj-y, quintela, 2009/06/24