[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH V2 20/20] pci: convert goto into scope in bridge_fil
From: |
Isaku Yamahata |
Subject: |
[Qemu-devel] [PATCH V2 20/20] pci: convert goto into scope in bridge_filter |
Date: |
Fri, 13 Nov 2009 13:29:56 +0900 |
From: Michael S. Tsirkin <address@hidden>
goto into scope is evil. rearrange pci_bridge_filter
so that we always go to end of function on error.
Signed-off-by: Michael S. Tsirkin <address@hidden>
Acked-by: Isaku Yamahata <address@hidden>
---
hw/pci.c | 13 +++++++------
1 files changed, 7 insertions(+), 6 deletions(-)
diff --git a/hw/pci.c b/hw/pci.c
index 7d930eb..a06003e 100644
--- a/hw/pci.c
+++ b/hw/pci.c
@@ -716,13 +716,14 @@ static void pci_bridge_filter(PCIDevice *d, pcibus_t
*addr, pcibus_t *size,
}
if (base > limit) {
- no_map:
- *addr = PCI_BAR_UNMAPPED;
- *size = 0;
- } else {
- *addr = base;
- *size = limit - base + 1;
+ goto no_map;
}
+ *addr = base;
+ *size = limit - base + 1;
+ return;
+no_map:
+ *addr = PCI_BAR_UNMAPPED;
+ *size = 0;
}
static pcibus_t pci_bar_address(PCIDevice *d,
--
1.6.0.2
- [Qemu-devel] [PATCH V2 17/20] pci: remove magic number, 256 in pci.c, (continued)
- [Qemu-devel] [PATCH V2 17/20] pci: remove magic number, 256 in pci.c, Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH V2 14/20] pci: remove unused constants., Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH V2 19/20] pci: pci bridge related clean up., Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH V2 06/20] pci: shorten pci_host_{conf, data}_register_xxx function a bit., Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH V2 12/20] pci: remove some unnecessary comment in pci.h, Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH V2 15/20] pci: clean up of pci_update_mappings(), Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH V2 08/20] pci: s/pci_find_host_bus/pci_find_root_bus/g, Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH V2 16/20] pci: split up up pci_update mappings, Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH V2 18/20] pci: fix pci_config_get_io_base()., Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH V2 10/20] pci: kill unnecessary included in pci.c, Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH V2 20/20] pci: convert goto into scope in bridge_filter,
Isaku Yamahata <=
- [Qemu-devel] [PATCH V2 04/20] pci: remove pci_addr_to_config() by open code, Isaku Yamahata, 2009/11/13