[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH 4/6] Handle CPU interrupts by inline checking of
From: |
Peter Maydell |
Subject: |
Re: [Qemu-devel] [PATCH 4/6] Handle CPU interrupts by inline checking of a flag |
Date: |
Sat, 23 Feb 2013 10:03:13 +0000 |
On 22 February 2013 21:15, Paul Brook <address@hidden> wrote:
>> @@ -100,6 +102,7 @@ struct CPUState {
>> bool stop;
>> bool stopped;
>> volatile sig_atomic_t exit_request;
>> + volatile sig_atomic_t tcg_exit_req;
>
> Do we really need annother variable/check? It seems like this should be at
> least partially redundant with the existing icount code. I have a simialr
> patch to that effect.
I wanted to keep the code simple and easy to review for correctness
and obvious non-interaction with other features. (My first patch
along these lines tried to reuse exit_request, but this hangs
Linux in SMP in system mode, for instance.)
-- PMM
- [Qemu-devel] [PATCH 0/6] Drop the irredeemably racy cpu_unlink_tb(), Peter Maydell, 2013/02/22
- [Qemu-devel] [PATCH 1/6] tcg: Document tcg_qemu_tb_exec() and provide constants for low bit uses, Peter Maydell, 2013/02/22
- [Qemu-devel] [PATCH 4/6] Handle CPU interrupts by inline checking of a flag, Peter Maydell, 2013/02/22
- [Qemu-devel] [PATCH 6/6] gen-icount.h: Rename gen_icount_start/end to gen_tb_start/end, Peter Maydell, 2013/02/22
- [Qemu-devel] [PATCH 5/6] translate-all.c: Remove cpu_unlink_tb(), Peter Maydell, 2013/02/22
- [Qemu-devel] [PATCH 3/6] cpu-exec: wrap tcg_qemu_tb_exec() in a fn to restore the PC, Peter Maydell, 2013/02/22
- [Qemu-devel] [PATCH 2/6] cpu: Introduce ENV_OFFSET macros, Peter Maydell, 2013/02/22