[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PULL 00/17] tcg ldst conversions
From: |
Richard Henderson |
Subject: |
[Qemu-devel] [PULL 00/17] tcg ldst conversions |
Date: |
Sat, 12 Oct 2013 16:31:06 -0700 |
All of these patches have been posted over the month of September.
This pull includes conversions of 4 of the tcg backends to the new
ldst opcodes. There are 2 more backends that I have also converted,
ia64 and sparc, but at present I'm not able to re-test those so I've
left them out.
I also include the conversion of the alpha front-end to the new helpers.
r~
The following changes since commit 1cdae4573d7613149348d834c605bfbe3c7d405b:
Merge remote-tracking branch 'mdroth/qga-pull-2013-10-10' into staging
(2013-10-11 09:38:07 -0700)
are available in the git repository at:
git://github.com/rth7680/qemu.git tcg-ldst-6
for you to fetch changes up to f8da40aefbd1b40a0c5ab6fb25987943fe01125c:
target-alpha: Convert to new ldst opcodes (2013-10-12 16:19:20 -0700)
----------------------------------------------------------------
Richard Henderson (17):
tcg: Use TCGMemOp for TCGLabelQemuLdst.opc
tcg-i386: Use TCGMemOp within qemu_ldst routines
tcg-i386: Tidy softmmu routines
tcg-i386: Remove "cb" output restriction from qemu_st8 for i386
tcg-i386: Support new ldst opcodes
tcg-arm: Use TCGMemOp within qemu_ldst routines
tcg-arm: Convert to le/be ldst helpers
tcg-arm: Tidy variable naming convention in qemu_ld/st
tcg-arm: Convert to new ldst opcodes
tcg-arm: Improve GUEST_BASE qemu_ld/st
tcg-ppc: Use TCGMemOp within qemu_ldst routines
tcg-ppc64: Use TCGMemOp within qemu_ldst routines
tcg-ppc: Convert to le/be ldst helpers
tcg-ppc64: Convert to le/be ldst helpers
tcg-ppc: Support new ldst opcodes
tcg-ppc64: Support new ldst opcodes
target-alpha: Convert to new ldst opcodes
target-alpha/translate.c | 49 ++--
tcg/arm/tcg-target.c | 556 ++++++++++++++++++++--------------------
tcg/arm/tcg-target.h | 2 +-
tcg/i386/tcg-target.c | 643 +++++++++++++++++++++--------------------------
tcg/i386/tcg-target.h | 2 +-
tcg/ppc/tcg-target.c | 202 +++++++--------
tcg/ppc/tcg-target.h | 2 +-
tcg/ppc64/tcg-target.c | 163 +++++-------
tcg/ppc64/tcg-target.h | 2 +-
tcg/tcg-be-ldst.h | 2 +-
10 files changed, 722 insertions(+), 901 deletions(-)
- [Qemu-devel] [PULL 00/17] tcg ldst conversions,
Richard Henderson <=
- [Qemu-devel] [PULL 01/17] tcg: Use TCGMemOp for TCGLabelQemuLdst.opc, Richard Henderson, 2013/10/12
- [Qemu-devel] [PULL 02/17] tcg-i386: Use TCGMemOp within qemu_ldst routines, Richard Henderson, 2013/10/12
- [Qemu-devel] [PULL 05/17] tcg-i386: Support new ldst opcodes, Richard Henderson, 2013/10/12
- [Qemu-devel] [PULL 04/17] tcg-i386: Remove "cb" output restriction from qemu_st8 for i386, Richard Henderson, 2013/10/12
- [Qemu-devel] [PULL 06/17] tcg-arm: Use TCGMemOp within qemu_ldst routines, Richard Henderson, 2013/10/12
- [Qemu-devel] [PULL 03/17] tcg-i386: Tidy softmmu routines, Richard Henderson, 2013/10/12
- [Qemu-devel] [PULL 07/17] tcg-arm: Convert to le/be ldst helpers, Richard Henderson, 2013/10/12
- [Qemu-devel] [PULL 08/17] tcg-arm: Tidy variable naming convention in qemu_ld/st, Richard Henderson, 2013/10/12
- [Qemu-devel] [PULL 09/17] tcg-arm: Convert to new ldst opcodes, Richard Henderson, 2013/10/12
- [Qemu-devel] [PULL 10/17] tcg-arm: Improve GUEST_BASE qemu_ld/st, Richard Henderson, 2013/10/12