[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 0/7] block: Use definitions instead of magic values
From: |
Philippe Mathieu-Daudé |
Subject: |
[PATCH 0/7] block: Use definitions instead of magic values |
Date: |
Fri, 14 Aug 2020 10:28:34 +0200 |
Trivial block patches:
- Fix a typo
- Replace '1 << 30' by '1 * GiB' in null-co
- Replace 512 by BDRV_SECTOR_SIZE when appropriate.
Philippe Mathieu-Daudé (7):
block/null: Make more explicit the driver default size is 1GiB
hw/ide/core: Trivial typo fix
hw/ide/core: Replace magic '512' value by BDRV_SECTOR_SIZE
hw/ide/ahci: Replace magic '512' value by BDRV_SECTOR_SIZE
hw/ide/atapi: Replace magic '512' value by BDRV_SECTOR_SIZE
hw/ide/pci: Replace magic '512' value by BDRV_SECTOR_SIZE
hw/scsi/scsi-disk: Replace magic '512' value by BDRV_SECTOR_SIZE
block/null.c | 4 +++-
hw/ide/ahci.c | 5 +++--
hw/ide/atapi.c | 8 ++++----
hw/ide/core.c | 25 +++++++++++++------------
hw/ide/pci.c | 2 +-
hw/scsi/scsi-disk.c | 44 +++++++++++++++++++++++---------------------
6 files changed, 47 insertions(+), 41 deletions(-)
--
2.21.3
- [PATCH 0/7] block: Use definitions instead of magic values,
Philippe Mathieu-Daudé <=