[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 0/7] block: Use definitions instead of magic values
From: |
Stefano Garzarella |
Subject: |
Re: [PATCH 0/7] block: Use definitions instead of magic values |
Date: |
Mon, 17 Aug 2020 11:03:35 +0200 |
On Fri, Aug 14, 2020 at 10:28:34AM +0200, Philippe Mathieu-Daudé wrote:
> Trivial block patches:
> - Fix a typo
> - Replace '1 << 30' by '1 * GiB' in null-co
> - Replace 512 by BDRV_SECTOR_SIZE when appropriate.
>
> Philippe Mathieu-Daudé (7):
> block/null: Make more explicit the driver default size is 1GiB
> hw/ide/core: Trivial typo fix
> hw/ide/core: Replace magic '512' value by BDRV_SECTOR_SIZE
> hw/ide/ahci: Replace magic '512' value by BDRV_SECTOR_SIZE
> hw/ide/atapi: Replace magic '512' value by BDRV_SECTOR_SIZE
> hw/ide/pci: Replace magic '512' value by BDRV_SECTOR_SIZE
> hw/scsi/scsi-disk: Replace magic '512' value by BDRV_SECTOR_SIZE
>
> block/null.c | 4 +++-
> hw/ide/ahci.c | 5 +++--
> hw/ide/atapi.c | 8 ++++----
> hw/ide/core.c | 25 +++++++++++++------------
> hw/ide/pci.c | 2 +-
> hw/scsi/scsi-disk.c | 44 +++++++++++++++++++++++---------------------
> 6 files changed, 47 insertions(+), 41 deletions(-)
Series:
Reviewed-by: Stefano Garzarella <sgarzare@redhat.com>
Thanks for the cleaning that makes the code more readable!
Stefano
- [PATCH 5/7] hw/ide/atapi: Replace magic '512' value by BDRV_SECTOR_SIZE, (continued)