[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v4 0/4] migration: Add block-bitmap-mapping parameter
From: |
Max Reitz |
Subject: |
[PATCH v4 0/4] migration: Add block-bitmap-mapping parameter |
Date: |
Tue, 18 Aug 2020 15:32:36 +0200 |
RFC v1: https://lists.nongnu.org/archive/html/qemu-block/2020-05/msg00912.html
RFC v2: https://lists.nongnu.org/archive/html/qemu-block/2020-05/msg00915.html
v1: https://lists.nongnu.org/archive/html/qemu-devel/2020-06/msg09792.html
v2: https://lists.nongnu.org/archive/html/qemu-block/2020-07/msg01179.html
v3: https://lists.nongnu.org/archive/html/qemu-block/2020-07/msg01385.html
Branch: https://github.com/XanClic/qemu.git migration-bitmap-mapping-v4
Branch: https://git.xanclic.moe/XanClic/qemu.git migration-bitmap-mapping-v4
Hi,
This new migration parameter allows mapping block node names and bitmap
names to aliases for the purpose of block dirty bitmap migration.
This way, management tools can use different node names on the source
and destination and pass the mapping of how bitmaps are to be
transferred to qemu (on the source, the destination, or even both with
arbitrary aliases in the migration stream).
v4:
- Patch 1:
- Rebased
- %s/5.1/5.2/
- The destination side will now ignore unmapped aliases, too (though
they are reported to stderr)
- Check that the aliases given will fit in the migration stream (i.e.
are shorter than 256 bytes)
- On that note, fix a pre-existing bug where a bitmap with a name
longer than 255 bytes would make qemu_put_counted_string() fail an
assertion
- Patch 2:
- import time (apparently, I forgot that in v3...?)
- Patch 3:
- Added; I need this now
- Patch 4:
- Migration rarely ever really fails now (just one case, where a
non-aliased bitmap name is too long, which can only be detected when
beginning migration)
- Thus, we have to read most error messages from the VM log now, for
which I’ve added a new function (verify_dest_error)
- Added tests for overly long bitmap names and node/bitmap aliases
git-backport-diff against v3:
Key:
[----] : patches are identical
[####] : number of functional differences between upstream/downstream patch
[down] : patch is downstream-only
The flags [FC] indicate (F)unctional and (C)ontextual differences, respectively
001/4:[0167] [FC] 'migration: Add block-bitmap-mapping parameter'
002/4:[0001] [FC] 'iotests.py: Add wait_for_runstate()'
003/4:[down] 'iotests.py: Let wait_migration() return on failure'
004/4:[0232] [FC] 'iotests: Test node/bitmap aliases during migration'
Max Reitz (4):
migration: Add block-bitmap-mapping parameter
iotests.py: Add wait_for_runstate()
iotests.py: Let wait_migration() return on failure
iotests: Test node/bitmap aliases during migration
qapi/migration.json | 101 +++++-
migration/migration.h | 3 +
migration/block-dirty-bitmap.c | 409 +++++++++++++++++++---
migration/migration.c | 30 ++
monitor/hmp-cmds.c | 30 ++
tests/qemu-iotests/300 | 595 +++++++++++++++++++++++++++++++++
tests/qemu-iotests/300.out | 5 +
tests/qemu-iotests/group | 1 +
tests/qemu-iotests/iotests.py | 22 +-
9 files changed, 1134 insertions(+), 62 deletions(-)
create mode 100755 tests/qemu-iotests/300
create mode 100644 tests/qemu-iotests/300.out
--
2.26.2
- [PATCH v4 0/4] migration: Add block-bitmap-mapping parameter,
Max Reitz <=