[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v2 8/9] hw/dma: Use dma_addr_t type definition when relevant
From: |
David Hildenbrand |
Subject: |
Re: [PATCH v2 8/9] hw/dma: Use dma_addr_t type definition when relevant |
Date: |
Mon, 10 Jan 2022 09:49:25 +0100 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.4.0 |
On 04.01.22 09:54, Philippe Mathieu-Daudé wrote:
> From: Philippe Mathieu-Daudé <philmd@redhat.com>
>
> Update the obvious places where dma_addr_t should be used
> (instead of uint64_t, hwaddr, size_t, int32_t types).
>
> This allows to have &dma_addr_t type portable on 32/64-bit
> hosts.
>
> Move QEMUSGList declaration after dma_addr_t declaration
> so this structure can use the new type.
>
> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>
> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
> ---
> include/sysemu/dma.h | 22 +++++++++++-----------
> hw/nvme/ctrl.c | 2 +-
> hw/rdma/rdma_utils.c | 2 +-
> hw/scsi/megasas.c | 10 +++++-----
> softmmu/dma-helpers.c | 6 +++---
> 5 files changed, 21 insertions(+), 21 deletions(-)
>
> diff --git a/include/sysemu/dma.h b/include/sysemu/dma.h
> index 0db2478a506..7a8ae4fcd0b 100644
> --- a/include/sysemu/dma.h
> +++ b/include/sysemu/dma.h
> @@ -15,22 +15,11 @@
> #include "block/block.h"
> #include "block/accounting.h"
>
> -typedef struct ScatterGatherEntry ScatterGatherEntry;
> -
> typedef enum {
> DMA_DIRECTION_TO_DEVICE = 0,
> DMA_DIRECTION_FROM_DEVICE = 1,
> } DMADirection;
>
> -struct QEMUSGList {
> - ScatterGatherEntry *sg;
> - int nsg;
> - int nalloc;
> - size_t size;
> - DeviceState *dev;
> - AddressSpace *as;
> -};
> -
> /*
> * When an IOMMU is present, bus addresses become distinct from
> * CPU/memory physical addresses and may be a different size. Because
> @@ -43,6 +32,17 @@ typedef uint64_t dma_addr_t;
> #define DMA_ADDR_BITS 64
> #define DMA_ADDR_FMT "%" PRIx64
>
> +typedef struct ScatterGatherEntry ScatterGatherEntry;
> +
> +struct QEMUSGList {
> + ScatterGatherEntry *sg;
> + int nsg;
> + int nalloc;
> + dma_addr_t size;
> + DeviceState *dev;
> + AddressSpace *as;
> +};
Changing one member while moving is sneaky. Why the move in this patch?
Apart from that and Peters comment
Reviewed-by: David Hildenbrand <david@redhat.com>
--
Thanks,
David / dhildenb
- Re: [PATCH v2 5/9] hw/rdma/rdma_utils: Rename rdma_pci_dma_map 'len' argument, (continued)
- [PATCH v2 6/9] hw/scsi: Rename SCSIRequest::resid as 'residual', Philippe Mathieu-Daudé, 2022/01/04
- [PATCH v2 7/9] hw/dma: Fix format string issues using dma_addr_t, Philippe Mathieu-Daudé, 2022/01/04
- [PATCH v2 8/9] hw/dma: Use dma_addr_t type definition when relevant, Philippe Mathieu-Daudé, 2022/01/04
- [PATCH v2 9/9] hw/dma: Let dma_buf_read() / dma_buf_write() propagate MemTxResult, Philippe Mathieu-Daudé, 2022/01/04
- Re: [PATCH v2 0/9] hw/dma: Use dma_addr_t type definition when relevant, Michael S. Tsirkin, 2022/01/06